95a3bb3361
Resolves: CVE-2019-9511 "Data Dribble" Resolves: CVE-2019-9512 "Ping Flood" Resolves: CVE-2019-9513 "Resource Loop" Resolves: CVE-2019-9514 "Reset Flood" Resolves: CVE-2019-9515 "Settings Flood" Resolves: CVE-2019-9516 "0-Length Headers Leak" Resolves: CVE-2019-9517 "Internal Data Buffering" Resolves: CVE-2019-9518 "Empty Frames Flood" https://github.com/nodejs/node/blob/v12.8.1/doc/changelogs/CHANGELOG_V12.md#12.8.1 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From d8cdfcd680cbd728904c19b2eea7730c61b16c73 Mon Sep 17 00:00:00 2001
|
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
|
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
|
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
|
|
|
---
|
|
Makefile | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 1e4915a6d2ebedc8af009d8505b5b8d11a53f5f7..cae1c3c1da9a440d84a6f86fa6353e81db535c71 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -139,13 +139,13 @@ with-code-cache:
|
|
.PHONY: test-code-cache
|
|
test-code-cache: with-code-cache
|
|
echo "'test-code-cache' target is a noop"
|
|
|
|
out/Makefile: config.gypi common.gypi node.gyp \
|
|
- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
|
|
- tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
- tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
+ deps/http_parser/http_parser.gyp \
|
|
+ tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
$(PYTHON) tools/gyp_node.py -f make
|
|
|
|
config.gypi: configure configure.py
|
|
@if [ -x config.status ]; then \
|
|
./config.status; \
|
|
--
|
|
2.21.0
|
|
|