50d0647ce7
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.4.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
56 lines
1.8 KiB
Diff
56 lines
1.8 KiB
Diff
From b9f76742bb9120ec9ee84dd5833eaf885be8766a Mon Sep 17 00:00:00 2001
|
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
|
|
|
Signed-off-by: rpm-build <rpm-build>
|
|
---
|
|
Makefile | 2 +-
|
|
node.gyp | 17 -----------------
|
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 9f7ab7129d06471760c707a4bf7764cb2bdff862..78f91cf7f57b0de32961b1d491edf28a4ad375d2 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
|
|
$(warning '$@' target is a noop)
|
|
|
|
out/Makefile: config.gypi common.gypi node.gyp \
|
|
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
|
+ deps/llhttp/llhttp.gyp \
|
|
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
$(PYTHON) tools/gyp_node.py -f make
|
|
diff --git a/node.gyp b/node.gyp
|
|
index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026cad1370ccf 100644
|
|
--- a/node.gyp
|
|
+++ b/node.gyp
|
|
@@ -423,23 +423,6 @@
|
|
],
|
|
},
|
|
],
|
|
- }, {
|
|
- 'variables': {
|
|
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
- 'opensslconfig': './deps/openssl/openssl/apps/openssl.cnf',
|
|
- },
|
|
- 'actions': [
|
|
- {
|
|
- 'action_name': 'reset_openssl_cnf',
|
|
- 'inputs': [ '<(opensslconfig)', ],
|
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
|
- 'action': [
|
|
- 'python', 'tools/copyfile.py',
|
|
- './deps/openssl/openssl/apps/openssl.cnf',
|
|
- '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
- ],
|
|
- },
|
|
- ],
|
|
}],
|
|
],
|
|
}, # node_core_target_name
|
|
--
|
|
2.35.1
|
|
|