Update to 12.13.0 (LTS)
- https://github.com/nodejs/node/blob/v12.13.0/doc/changelogs/CHANGELOG_V12.md - NPM no longer clobbers RPM-installed Node.js modules - Drop no-longer needed patch to suppress `npm update -g npm` message Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
79a5087033
commit
ed04b00a69
@ -1,4 +1,4 @@
|
|||||||
From eb4c49be960358e395ade13372f3790e6e41461b Mon Sep 17 00:00:00 2001
|
From 80542232e5b9c3ede63b7a70c1077497e130da81 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||||
@ -8,12 +8,10 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
|||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 33d43798f52617797d787b4999317e258811c157..a59615648f49a72411ac086ad1bc0c2623b4a41f 100644
|
index 0a5177d1c3e7d6769535d79e063f987157a30f4d..1f3dd0abe4031defb5b7cc817b12886bdea002c7 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -139,13 +139,13 @@ with-code-cache:
|
@@ -141,9 +141,9 @@ test-code-cache: with-code-cache
|
||||||
.PHONY: test-code-cache
|
|
||||||
test-code-cache: with-code-cache
|
|
||||||
echo "'test-code-cache' target is a noop"
|
echo "'test-code-cache' target is a noop"
|
||||||
|
|
||||||
out/Makefile: config.gypi common.gypi node.gyp \
|
out/Makefile: config.gypi common.gypi node.gyp \
|
||||||
@ -25,9 +23,7 @@ index 33d43798f52617797d787b4999317e258811c157..a59615648f49a72411ac086ad1bc0c26
|
|||||||
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||||
$(PYTHON) tools/gyp_node.py -f make
|
$(PYTHON) tools/gyp_node.py -f make
|
||||||
|
|
||||||
config.gypi: configure configure.py
|
# node_version.h is listed because the N-API version is taken from there
|
||||||
@if [ -x config.status ]; then \
|
|
||||||
./config.status; \
|
|
||||||
--
|
--
|
||||||
2.21.0
|
2.23.0
|
||||||
|
|
||||||
|
@ -1,87 +0,0 @@
|
|||||||
From 0461fabf259b36a156c55dc402b1d66d09eb90ca Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
|
||||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
|
||||||
|
|
||||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
---
|
|
||||||
deps/npm/bin/npm-cli.js | 54 -----------------------------------------
|
|
||||||
1 file changed, 54 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
|
||||||
index 93eddc7a3c892b0f5d35c477c042a8e5087d7b01..ceb12b5d9a33ab7b98df05d7ef082c42f03eedb9 100755
|
|
||||||
--- a/deps/npm/bin/npm-cli.js
|
|
||||||
+++ b/deps/npm/bin/npm-cli.js
|
|
||||||
@@ -67,69 +67,15 @@
|
|
||||||
if (conf.usage && npm.command !== 'help') {
|
|
||||||
npm.argv.unshift(npm.command)
|
|
||||||
npm.command = 'help'
|
|
||||||
}
|
|
||||||
|
|
||||||
- var isGlobalNpmUpdate = conf.global && ['install', 'update'].includes(npm.command) && npm.argv.includes('npm')
|
|
||||||
-
|
|
||||||
// now actually fire up npm and run the command.
|
|
||||||
// this is how to use npm programmatically:
|
|
||||||
conf._exit = true
|
|
||||||
npm.load(conf, function (er) {
|
|
||||||
if (er) return errorHandler(er)
|
|
||||||
- if (
|
|
||||||
- !isGlobalNpmUpdate &&
|
|
||||||
- npm.config.get('update-notifier') &&
|
|
||||||
- !unsupported.checkVersion(process.version).unsupported
|
|
||||||
- ) {
|
|
||||||
- const pkg = require('../package.json')
|
|
||||||
- let notifier = require('update-notifier')({pkg})
|
|
||||||
- const isCI = require('ci-info').isCI
|
|
||||||
- if (
|
|
||||||
- notifier.update &&
|
|
||||||
- notifier.update.latest !== pkg.version &&
|
|
||||||
- !isCI
|
|
||||||
- ) {
|
|
||||||
- const color = require('ansicolors')
|
|
||||||
- const useColor = npm.config.get('color')
|
|
||||||
- const useUnicode = npm.config.get('unicode')
|
|
||||||
- const old = notifier.update.current
|
|
||||||
- const latest = notifier.update.latest
|
|
||||||
- let type = notifier.update.type
|
|
||||||
- if (useColor) {
|
|
||||||
- switch (type) {
|
|
||||||
- case 'major':
|
|
||||||
- type = color.red(type)
|
|
||||||
- break
|
|
||||||
- case 'minor':
|
|
||||||
- type = color.yellow(type)
|
|
||||||
- break
|
|
||||||
- case 'patch':
|
|
||||||
- type = color.green(type)
|
|
||||||
- break
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- const changelog = `https://github.com/npm/cli/releases/tag/v${latest}`
|
|
||||||
- notifier.notify({
|
|
||||||
- message: `New ${type} version of ${pkg.name} available! ${
|
|
||||||
- useColor ? color.red(old) : old
|
|
||||||
- } ${useUnicode ? '→' : '->'} ${
|
|
||||||
- useColor ? color.green(latest) : latest
|
|
||||||
- }\n` +
|
|
||||||
- `${
|
|
||||||
- useColor ? color.yellow('Changelog:') : 'Changelog:'
|
|
||||||
- } ${
|
|
||||||
- useColor ? color.cyan(changelog) : changelog
|
|
||||||
- }\n` +
|
|
||||||
- `Run ${
|
|
||||||
- useColor
|
|
||||||
- ? color.green(`npm install -g ${pkg.name}`)
|
|
||||||
- : `npm i -g ${pkg.name}`
|
|
||||||
- } to update!`
|
|
||||||
- })
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
npm.commands[npm.command](npm.argv, function (err) {
|
|
||||||
// https://genius.com/Lin-manuel-miranda-your-obedient-servant-lyrics
|
|
||||||
if (
|
|
||||||
!err &&
|
|
||||||
npm.config.get('ham-it-up') &&
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
26
0002-Use-etc-npmrc-for-the-default-configuration.patch
Normal file
26
0002-Use-etc-npmrc-for-the-default-configuration.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 194e21ab7bb3faf34211a0f9474755064cb8d579 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
Date: Mon, 28 Oct 2019 13:24:57 -0400
|
||||||
|
Subject: [PATCH 2/3] Use /etc/npmrc for the default configuration
|
||||||
|
|
||||||
|
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
---
|
||||||
|
deps/npm/lib/config/defaults.js | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/deps/npm/lib/config/defaults.js b/deps/npm/lib/config/defaults.js
|
||||||
|
index 57d373df1e10c349142e14fa9e4bbc95b7df79e3..c0e2926ac5af12582fa3b4a4a48804fe5a9cea68 100644
|
||||||
|
--- a/deps/npm/lib/config/defaults.js
|
||||||
|
+++ b/deps/npm/lib/config/defaults.js
|
||||||
|
@@ -153,7 +153,7 @@ Object.defineProperty(exports, 'defaults', {get: function () {
|
||||||
|
'commit-hooks': true,
|
||||||
|
|
||||||
|
global: false,
|
||||||
|
- globalconfig: path.resolve(globalPrefix, 'etc', 'npmrc'),
|
||||||
|
+ globalconfig: '/etc/npmrc'
|
||||||
|
'global-style': false,
|
||||||
|
group: process.platform === 'win32' ? 0
|
||||||
|
: process.env.SUDO_GID || (process.getgid && process.getgid()),
|
||||||
|
--
|
||||||
|
2.23.0
|
||||||
|
|
@ -1,4 +1,4 @@
|
|||||||
From f35fcd689dce64e7d6b5f3496e5e5358a24ae4e0 Mon Sep 17 00:00:00 2001
|
From 68a68c00f78bade05487d34412f3a4b773c4363e Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||||
@ -13,12 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
|||||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index ce01a14566e65ad9d568e0cb8594b35bacd698c6..180f0b4861463e3d4fab979fce4b4c8dfc6ceee2 100755
|
index 473bbfeb294b34e0cb4ead9db607adfc3781be29..a1f98be9a68c360f3bd17c8f5e0a1478adce9a55 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -554,10 +554,16 @@ parser.add_option('--shared',
|
@@ -556,6 +556,12 @@ parser.add_option('--shared',
|
||||||
action='store_true',
|
|
||||||
dest='shared',
|
|
||||||
help='compile shared library for embedding node in another project. ' +
|
help='compile shared library for embedding node in another project. ' +
|
||||||
'(This mode is not officially supported for regular applications)')
|
'(This mode is not officially supported for regular applications)')
|
||||||
|
|
||||||
@ -31,11 +29,7 @@ index ce01a14566e65ad9d568e0cb8594b35bacd698c6..180f0b4861463e3d4fab979fce4b4c8d
|
|||||||
parser.add_option('--without-v8-platform',
|
parser.add_option('--without-v8-platform',
|
||||||
action='store_true',
|
action='store_true',
|
||||||
dest='without_v8_platform',
|
dest='without_v8_platform',
|
||||||
default=False,
|
@@ -1098,6 +1104,7 @@ def configure_node(o):
|
||||||
help='do not initialize v8 platform during node.js startup. ' +
|
|
||||||
@@ -1096,10 +1102,11 @@ def configure_node(o):
|
|
||||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
|
||||||
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
|
||||||
if o['variables']['want_separate_host_toolset'] == 0:
|
if o['variables']['want_separate_host_toolset'] == 0:
|
||||||
o['variables']['node_code_cache'] = 'yes' # For testing
|
o['variables']['node_code_cache'] = 'yes' # For testing
|
||||||
o['variables']['node_shared'] = b(options.shared)
|
o['variables']['node_shared'] = b(options.shared)
|
||||||
@ -43,15 +37,11 @@ index ce01a14566e65ad9d568e0cb8594b35bacd698c6..180f0b4861463e3d4fab979fce4b4c8d
|
|||||||
node_module_version = getmoduleversion.get_version()
|
node_module_version = getmoduleversion.get_version()
|
||||||
|
|
||||||
if sys.platform == 'darwin':
|
if sys.platform == 'darwin':
|
||||||
shlib_suffix = '%s.dylib'
|
|
||||||
elif sys.platform.startswith('aix'):
|
|
||||||
diff --git a/tools/install.py b/tools/install.py
|
diff --git a/tools/install.py b/tools/install.py
|
||||||
index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c049b0503 100755
|
index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c049b0503 100755
|
||||||
--- a/tools/install.py
|
--- a/tools/install.py
|
||||||
+++ b/tools/install.py
|
+++ b/tools/install.py
|
||||||
@@ -119,30 +119,27 @@ def subdir_files(path, dest, action):
|
@@ -121,26 +121,23 @@ def subdir_files(path, dest, action):
|
||||||
for subdir, files_in_path in ret.items():
|
|
||||||
action(files_in_path, subdir + '/')
|
|
||||||
|
|
||||||
def files(action):
|
def files(action):
|
||||||
is_windows = sys.platform == 'win32'
|
is_windows = sys.platform == 'win32'
|
||||||
@ -91,8 +81,6 @@ index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c
|
|||||||
|
|
||||||
if 'true' == variables.get('node_use_dtrace'):
|
if 'true' == variables.get('node_use_dtrace'):
|
||||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||||
|
|
||||||
# behave similarly for systemtap
|
|
||||||
--
|
--
|
||||||
2.21.0
|
2.23.0
|
||||||
|
|
||||||
|
33
nodejs.spec
33
nodejs.spec
@ -19,7 +19,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 12
|
%global nodejs_major 12
|
||||||
%global nodejs_minor 10
|
%global nodejs_minor 13
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
@ -32,9 +32,9 @@
|
|||||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||||
%global v8_epoch 2
|
%global v8_epoch 2
|
||||||
%global v8_major 7
|
%global v8_major 7
|
||||||
%global v8_minor 6
|
%global v8_minor 7
|
||||||
%global v8_build 303
|
%global v8_build 299
|
||||||
%global v8_patch 29
|
%global v8_patch 13
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||||
%global v8_abi %{v8_major}.%{v8_minor}
|
%global v8_abi %{v8_major}.%{v8_minor}
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
@ -61,7 +61,7 @@
|
|||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
%global libuv_major 1
|
%global libuv_major 1
|
||||||
%global libuv_minor 31
|
%global libuv_minor 32
|
||||||
%global libuv_patch 0
|
%global libuv_patch 0
|
||||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||||
|
|
||||||
@ -101,8 +101,8 @@
|
|||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_major 6
|
%global npm_major 6
|
||||||
%global npm_minor 10
|
%global npm_minor 12
|
||||||
%global npm_patch 3
|
%global npm_patch 0
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
@ -127,6 +127,7 @@ ExclusiveArch: %{nodejs_arches}
|
|||||||
# because openssl contains prohibited code, we remove openssl completely from
|
# because openssl contains prohibited code, we remove openssl completely from
|
||||||
# the tarball, using the script in Source100
|
# the tarball, using the script in Source100
|
||||||
Source0: node-v%{nodejs_version}-stripped.tar.gz
|
Source0: node-v%{nodejs_version}-stripped.tar.gz
|
||||||
|
Source1: npmrc
|
||||||
Source100: %{name}-tarball.sh
|
Source100: %{name}-tarball.sh
|
||||||
|
|
||||||
# The native module Requires generator remains in the nodejs SRPM, so it knows
|
# The native module Requires generator remains in the nodejs SRPM, so it knows
|
||||||
@ -137,9 +138,9 @@ Source7: nodejs_native.attr
|
|||||||
# Disable running gyp on bundled deps we don't use
|
# Disable running gyp on bundled deps we don't use
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||||
|
|
||||||
# Suppress the message from npm to run `npm -g update npm`
|
# Use /etc/npmrc for the default configuration
|
||||||
# This does bad things on an RPM-managed npm.
|
# We'll use this to set the prefix to /usr/local for `npm -g install`
|
||||||
Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
Patch2: 0002-Use-etc-npmrc-for-the-default-configuration.patch
|
||||||
|
|
||||||
# Patch to install both node and libnode.so, using the correct libdir
|
# Patch to install both node and libnode.so, using the correct libdir
|
||||||
Patch3: 0003-Install-both-binaries-and-use-libdir.patch
|
Patch3: 0003-Install-both-binaries-and-use-libdir.patch
|
||||||
@ -500,6 +501,10 @@ chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/npm-lifecycl
|
|||||||
chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
|
chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js
|
||||||
|
|
||||||
|
|
||||||
|
# Drop the NPM default configuration in place
|
||||||
|
cp %{SOURCE1} %{buildroot}%{_sysconfdir}/
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
# Fail the build if the versions don't match
|
# Fail the build if the versions don't match
|
||||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||||
@ -602,7 +607,7 @@ end
|
|||||||
%{_bindir}/npm
|
%{_bindir}/npm
|
||||||
%{_bindir}/npx
|
%{_bindir}/npx
|
||||||
%{_prefix}/lib/node_modules/npm
|
%{_prefix}/lib/node_modules/npm
|
||||||
%ghost %{_sysconfdir}/npmrc
|
%config(noreplace) %{_sysconfdir}/npmrc
|
||||||
%ghost %{_sysconfdir}/npmignore
|
%ghost %{_sysconfdir}/npmignore
|
||||||
%doc %{_mandir}/man*/npm*
|
%doc %{_mandir}/man*/npm*
|
||||||
%doc %{_mandir}/man*/npx*
|
%doc %{_mandir}/man*/npx*
|
||||||
@ -619,6 +624,12 @@ end
|
|||||||
%{_pkgdocdir}/npm/doc
|
%{_pkgdocdir}/npm/doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 28 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.13.0-1
|
||||||
|
- Update to 12.13.0 (LTS)
|
||||||
|
- https://github.com/nodejs/node/blob/v12.13.0/doc/changelogs/CHANGELOG_V12.md
|
||||||
|
- NPM no longer clobbers RPM-installed Node.js modules
|
||||||
|
- Drop no-longer needed patch to suppress `npm update -g npm` message
|
||||||
|
|
||||||
* Wed Sep 04 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.10.0-1
|
* Wed Sep 04 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.10.0-1
|
||||||
- Update to 12.10.0
|
- Update to 12.10.0
|
||||||
- https://github.com/nodejs/node/blob/v12.10.0/doc/changelogs/CHANGELOG_V12.md#12.10.0
|
- https://github.com/nodejs/node/blob/v12.10.0/doc/changelogs/CHANGELOG_V12.md#12.10.0
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (node-v12.10.0-stripped.tar.gz) = 4e99ffe8565f0bac1a2ce7c3797d5e734d42d11998c7c36033a6e4ddda7a432d1a4c7d02c1a606ebc28c1b7324caecf38c701fb2c8dafcc56af97eaf5f996318
|
SHA512 (node-v12.13.0-stripped.tar.gz) = be475255aaddcd6f5b26fbbc8a4ec7c29538fd9fe7115f93710606a7d876d3e44568f623ce1ca9e90b2db22499d61d6b61e680524217f67f4976493afbc2427f
|
||||||
|
Loading…
Reference in New Issue
Block a user