Update to 16.10.0
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
0787dcc5e4
commit
e13a2ee556
@ -1,4 +1,4 @@
|
||||
From 2c7f9fbe4a30ef6e06d4edf5603a638e1775567a Mon Sep 17 00:00:00 2001
|
||||
From b67fd1cbe8be07f4f3c2eb2cfa6df4cd78ab6e70 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index cc0539d98e8ab985acf75cd3714d165fc60c34c6..079823ad619ce1b859be26f283af6ac3ee4397e2 100644
|
||||
index baae6a3b46bd2680ede8f18166657d3ca6b27027..6b62d40a2ce479e7155a2f23253013b46f11b8b8 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -142,11 +142,11 @@ endif
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c5cf0a60bc07de8fa7a23f98c242a218094a6c9c Mon Sep 17 00:00:00 2001
|
||||
From 7f409cba5389bba6bb10f9a0f05cdf68c4a39338 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
|
23
nodejs.spec
23
nodejs.spec
@ -8,7 +8,7 @@
|
||||
# This is used by both the nodejs package and the npm subpackage thar
|
||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||
# will bump this rather than adding .1 to the end.
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -19,8 +19,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 16
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 10
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 93
|
||||
@ -36,7 +36,7 @@
|
||||
%global v8_major 9
|
||||
%global v8_minor 3
|
||||
%global v8_build 345
|
||||
%global v8_patch 16
|
||||
%global v8_patch 19
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||
|
||||
@ -89,8 +89,8 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 7
|
||||
%global npm_minor 21
|
||||
%global npm_patch 1
|
||||
%global npm_minor 24
|
||||
%global npm_patch 0
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||
@ -375,8 +375,11 @@ rm -rf tools/inspector_protocol/jinja2
|
||||
%global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
|
||||
%endif
|
||||
|
||||
export CC='%{__cc}'
|
||||
export CXX='%{__cxx}'
|
||||
#export CC='%{__cc}'
|
||||
#export CXX='%{__cxx}'
|
||||
|
||||
export CC='ccache gcc'
|
||||
export CXX='ccache g++'
|
||||
|
||||
# build with debugging symbols and add defines from libuv (#892601)
|
||||
# Node's v8 breaks with GCC 6 because of incorrect usage of methods on
|
||||
@ -673,6 +676,10 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Sep 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.10.0-1
|
||||
- Update to 16.10.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0
|
||||
|
||||
* Tue Sep 14 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-4
|
||||
- Correct the bad merge of corepack fix
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v16.9.1-stripped.tar.gz) = aba020f272d351c0dc5c54fdd8db7a8cf07965d1af2ac1b77879f7dc1736848820648d4d75b6ded4eb3cb51e2f5d6314cbdb31d9a62bbbdc1f43dc1efa7521d5
|
||||
SHA512 (node-v16.10.0-stripped.tar.gz) = db3e99cd64dc5879be342603affb6b31f674deb7b5e37b08c482d93a862c19c2eb929c20ac5636ad19aeec60693c599466c530f911d48da6e8f4cac5d6c81fe4
|
||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||
|
Loading…
Reference in New Issue
Block a user