Update to 18.5.0
Add %autorelease support Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
690f39ef06
commit
e0e64a6d19
@ -1,4 +1,4 @@
|
|||||||
From b9f76742bb9120ec9ee84dd5833eaf885be8766a Mon Sep 17 00:00:00 2001
|
From 5f4369b4448337c034067744711b02a496cb3d39 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||||
@ -23,7 +23,7 @@ index 9f7ab7129d06471760c707a4bf7764cb2bdff862..78f91cf7f57b0de32961b1d491edf28a
|
|||||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||||
$(PYTHON) tools/gyp_node.py -f make
|
$(PYTHON) tools/gyp_node.py -f make
|
||||||
diff --git a/node.gyp b/node.gyp
|
diff --git a/node.gyp b/node.gyp
|
||||||
index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026cad1370ccf 100644
|
index 340ffc27ade9f73c1a5b4121bd9184a1fc3976a9..dfed3734eb52936c6e56ae6df533ca94150c7f69 100644
|
||||||
--- a/node.gyp
|
--- a/node.gyp
|
||||||
+++ b/node.gyp
|
+++ b/node.gyp
|
||||||
@@ -423,23 +423,6 @@
|
@@ -423,23 +423,6 @@
|
||||||
@ -33,7 +33,7 @@ index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026ca
|
|||||||
- }, {
|
- }, {
|
||||||
- 'variables': {
|
- 'variables': {
|
||||||
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
||||||
- 'opensslconfig': './deps/openssl/openssl/apps/openssl.cnf',
|
- 'opensslconfig': './deps/openssl/nodejs-openssl.cnf',
|
||||||
- },
|
- },
|
||||||
- 'actions': [
|
- 'actions': [
|
||||||
- {
|
- {
|
||||||
@ -42,8 +42,8 @@ index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026ca
|
|||||||
- 'outputs': [ '<(opensslconfig_internal)', ],
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
||||||
- 'action': [
|
- 'action': [
|
||||||
- 'python', 'tools/copyfile.py',
|
- 'python', 'tools/copyfile.py',
|
||||||
- './deps/openssl/openssl/apps/openssl.cnf',
|
- '<(opensslconfig)',
|
||||||
- '<(obj_dir)/deps/openssl/openssl.cnf',
|
- '<(opensslconfig_internal)',
|
||||||
- ],
|
- ],
|
||||||
- },
|
- },
|
||||||
- ],
|
- ],
|
||||||
@ -51,5 +51,5 @@ index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026ca
|
|||||||
],
|
],
|
||||||
}, # node_core_target_name
|
}, # node_core_target_name
|
||||||
--
|
--
|
||||||
2.35.1
|
2.36.1
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 649a983dc168ff0f7a7157e0e9f5da5cf146837c Mon Sep 17 00:00:00 2001
|
From 19844592f46490cd7cff5f58aca73a64a992fb42 Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||||
@ -15,10 +15,10 @@ Signed-off-by: rpm-build <rpm-build>
|
|||||||
2 files changed, 8 insertions(+), 1 deletion(-)
|
2 files changed, 8 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index 187c381660b369bf4d6f9ce7bfddcf23c5b6c46a..3b948a0ffac6653aad12dfb5565ac703adba5f2a 100755
|
index e53a83f332ffd60cf7b6fe7e079470a52a43a8de..efdda6afce33201976e3811907bf4d7e3c2d4302 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -729,6 +729,12 @@ parser.add_argument('--shared',
|
@@ -735,6 +735,12 @@ parser.add_argument('--shared',
|
||||||
help='compile shared library for embedding node in another project. ' +
|
help='compile shared library for embedding node in another project. ' +
|
||||||
'(This mode is not officially supported for regular applications)')
|
'(This mode is not officially supported for regular applications)')
|
||||||
|
|
||||||
@ -31,7 +31,7 @@ index 187c381660b369bf4d6f9ce7bfddcf23c5b6c46a..3b948a0ffac6653aad12dfb5565ac703
|
|||||||
parser.add_argument('--without-v8-platform',
|
parser.add_argument('--without-v8-platform',
|
||||||
action='store_true',
|
action='store_true',
|
||||||
dest='without_v8_platform',
|
dest='without_v8_platform',
|
||||||
@@ -1366,6 +1372,7 @@ def configure_node(o):
|
@@ -1372,6 +1378,7 @@ def configure_node(o):
|
||||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||||
|
|
||||||
o['variables']['node_shared'] = b(options.shared)
|
o['variables']['node_shared'] = b(options.shared)
|
||||||
@ -53,5 +53,5 @@ index 47e9d8bd7a1ae596a7c6e1d5917f538e81533726..c1afbbf0827ced2e166668e793250468
|
|||||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||||
|
|
||||||
--
|
--
|
||||||
2.35.1
|
2.36.1
|
||||||
|
|
||||||
|
38
nodejs.spec
38
nodejs.spec
@ -40,7 +40,7 @@
|
|||||||
# This is used by both the nodejs package and the npm subpackage that
|
# This is used by both the nodejs package and the npm subpackage that
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 4
|
%global baserelease %autorelease
|
||||||
|
|
||||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -51,7 +51,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 18
|
%global nodejs_major 18
|
||||||
%global nodejs_minor 4
|
%global nodejs_minor 5
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
@ -80,7 +80,7 @@
|
|||||||
%global c_ares_version 1.18.1
|
%global c_ares_version 1.18.1
|
||||||
|
|
||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
%global llhttp_version 6.0.6
|
%global llhttp_version 6.0.7
|
||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
%global libuv_version 1.43.0
|
%global libuv_version 1.43.0
|
||||||
@ -126,7 +126,7 @@
|
|||||||
Name: nodejs
|
Name: nodejs
|
||||||
Epoch: %{nodejs_epoch}
|
Epoch: %{nodejs_epoch}
|
||||||
Version: %{nodejs_version}
|
Version: %{nodejs_version}
|
||||||
Release: %{nodejs_release}%{?dist}
|
Release: %{nodejs_release}
|
||||||
Summary: JavaScript runtime
|
Summary: JavaScript runtime
|
||||||
License: MIT and ASL 2.0 and ISC and BSD
|
License: MIT and ASL 2.0 and ISC and BSD
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -286,9 +286,9 @@ Requires: (nodejs-packaging if rpm-build)
|
|||||||
|
|
||||||
# Make sure we keep NPM up to date when we update Node.js
|
# Make sure we keep NPM up to date when we update Node.js
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
Recommends: npm >= %{npm_epoch}:%{npm_version}-%{npm_release}%{?dist}
|
Recommends: npm >= %{npm_epoch}:%{npm_version}-%{npm_release}
|
||||||
%endif
|
%endif
|
||||||
Conflicts: npm < %{npm_epoch}:%{npm_version}-%{npm_release}%{?dist}
|
Conflicts: npm < %{npm_epoch}:%{npm_version}-%{npm_release}
|
||||||
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -302,8 +302,8 @@ real-time applications that run across distributed devices.
|
|||||||
%package devel
|
%package devel
|
||||||
Summary: JavaScript runtime - development headers
|
Summary: JavaScript runtime - development headers
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Requires: %{name}%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: %{name}%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
Requires: %{name}-libs%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: %{name}-libs%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
Requires: openssl-devel%{?_isa}
|
Requires: openssl-devel%{?_isa}
|
||||||
%if !%{with bundled_zlib}
|
%if !%{with bundled_zlib}
|
||||||
Requires: zlib-devel%{?_isa}
|
Requires: zlib-devel%{?_isa}
|
||||||
@ -334,8 +334,8 @@ Provides: libv8_libbase.so.%{v8_major} = %{v8_epoch}:%{v8_version}
|
|||||||
Provides: libv8_libplatform.so.%{v8_major} = %{v8_epoch}:%{v8_version}
|
Provides: libv8_libplatform.so.%{v8_major} = %{v8_epoch}:%{v8_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Provides: v8 = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
Provides: v8 = %{v8_epoch}:%{v8_version}-%{nodejs_release}
|
||||||
Provides: v8%{?_isa} = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
Provides: v8%{?_isa} = %{v8_epoch}:%{v8_version}-%{nodejs_release}
|
||||||
Obsoletes: v8 < 1:6.7.17-10
|
Obsoletes: v8 < 1:6.7.17-10
|
||||||
|
|
||||||
%description libs
|
%description libs
|
||||||
@ -344,7 +344,7 @@ Libraries to support Node.js and provide stable v8 interfaces.
|
|||||||
|
|
||||||
%package full-i18n
|
%package full-i18n
|
||||||
Summary: Non-English locale data for Node.js
|
Summary: Non-English locale data for Node.js
|
||||||
Requires: %{name}%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: %{name}%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
|
|
||||||
%description full-i18n
|
%description full-i18n
|
||||||
Optional data files to provide full-icu support for Node.js. Remove this
|
Optional data files to provide full-icu support for Node.js. Remove this
|
||||||
@ -355,9 +355,9 @@ package to save space if non-English locales are not needed.
|
|||||||
Summary: v8 - development headers
|
Summary: v8 - development headers
|
||||||
Epoch: %{v8_epoch}
|
Epoch: %{v8_epoch}
|
||||||
Version: %{v8_version}
|
Version: %{v8_version}
|
||||||
Release: %{v8_release}%{?dist}
|
Release: %{v8_release}
|
||||||
Requires: %{name}-devel%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: %{name}-devel%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
Requires: %{name}-libs%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: %{name}-libs%{?_isa} = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
Conflicts: v8-314-devel
|
Conflicts: v8-314-devel
|
||||||
|
|
||||||
%description -n v8-devel
|
%description -n v8-devel
|
||||||
@ -368,15 +368,15 @@ Development headers for the v8 runtime.
|
|||||||
Summary: Node.js Package Manager
|
Summary: Node.js Package Manager
|
||||||
Epoch: %{npm_epoch}
|
Epoch: %{npm_epoch}
|
||||||
Version: %{npm_version}
|
Version: %{npm_version}
|
||||||
Release: %{npm_release}%{?dist}
|
Release: %{npm_release}
|
||||||
|
|
||||||
# We used to ship npm separately, but it is so tightly integrated with Node.js
|
# We used to ship npm separately, but it is so tightly integrated with Node.js
|
||||||
# (and expected to be present on all Node.js systems) that we ship it bundled
|
# (and expected to be present on all Node.js systems) that we ship it bundled
|
||||||
# now.
|
# now.
|
||||||
Obsoletes: npm < 0:3.5.4-6
|
Obsoletes: npm < 0:3.5.4-6
|
||||||
Requires: nodejs = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Requires: nodejs = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||||
Recommends: nodejs-docs = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Recommends: nodejs-docs = %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Do not add epoch to the virtual NPM provides or it will break
|
# Do not add epoch to the virtual NPM provides or it will break
|
||||||
@ -396,8 +396,8 @@ BuildArch: noarch
|
|||||||
# We don't require that the main package be installed to
|
# We don't require that the main package be installed to
|
||||||
# use the docs, but if it is installed, make sure the
|
# use the docs, but if it is installed, make sure the
|
||||||
# version always matches
|
# version always matches
|
||||||
Conflicts: %{name} > %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Conflicts: %{name} > %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
Conflicts: %{name} < %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
Conflicts: %{name} < %{nodejs_epoch}:%{nodejs_version}-%{nodejs_release}
|
||||||
|
|
||||||
%description docs
|
%description docs
|
||||||
The API documentation for the Node.js JavaScript runtime.
|
The API documentation for the Node.js JavaScript runtime.
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (node-v18.4.0-stripped.tar.gz) = 19d9446773ff1039ba7f08d6ed22e9bca14b889345a0779d089a4b42e003c91433e97dd0029588a1295b1d995a64ccb99d0b414259f2fe1b0537751874e2c1d1
|
SHA512 (node-v18.5.0-stripped.tar.gz) = 96e22871ba2cdc4a44bd00f0a157a1355cf9997023ca2e0b9535c7e6628ab64d73eaed13b5b8cc1c9844a25117868ff69b28b0681695d8944c3c860cabd6d1d9
|
||||||
SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd
|
SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd
|
||||||
SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e
|
SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e
|
||||||
|
Loading…
Reference in New Issue
Block a user