Merge remote-tracking branch 'origin/f26' into epel7
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
commit
dd07899571
1
.gitignore
vendored
1
.gitignore
vendored
@ -70,3 +70,4 @@
|
||||
/node-v6.11.0-stripped.tar.gz
|
||||
/node-v6.11.1-stripped.tar.gz
|
||||
/node-v6.11.2-stripped.tar.gz
|
||||
/node-v6.11.3-stripped.tar.gz
|
||||
|
@ -1,19 +1,17 @@
|
||||
From be1738c229765ad0796b97e842515b5d8834c894 Mon Sep 17 00:00:00 2001
|
||||
From 8946146b37e4170c406fbdd7c60f1bbb79a9311a Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Wed, 22 Mar 2017 19:13:10 +0100
|
||||
Subject: [PATCH] Disable running gyp files for bundled deps
|
||||
Date: Wed, 6 Sep 2017 14:17:21 +0200
|
||||
Subject: [PATCH] dont run gyp on shared deps
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index cfbd426033c7f2882f77cd60faaf3bb0277e6c57..8ca97d5552ebb328d8d6727531b13843864a6e86 100644
|
||||
index 577d0e232a..bb47a1b95e 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -75,11 +75,11 @@ $(NODE_EXE): config.gypi out/Makefile
|
||||
|
||||
$(NODE_G_EXE): config.gypi out/Makefile
|
||||
@@ -77,7 +77,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
|
||||
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
|
||||
if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi
|
||||
|
||||
@ -22,8 +20,6 @@ index cfbd426033c7f2882f77cd60faaf3bb0277e6c57..8ca97d5552ebb328d8d6727531b13843
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
config.gypi: configure
|
||||
$(error Missing or stale $@, please run ./$<)
|
||||
|
||||
--
|
||||
2.13.5
|
||||
2.14.1
|
||||
|
||||
|
@ -1,52 +0,0 @@
|
||||
From 655af65a132fe7cea8aeff4f8cbc9d06181f3d2e Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 15 Aug 2017 09:34:07 -0400
|
||||
Subject: [PATCH 3/3] EPEL openssl 1.0.1
|
||||
|
||||
---
|
||||
src/node_crypto.cc | 2 --
|
||||
src/node_crypto.h | 7 +++++++
|
||||
2 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
|
||||
index 7aaff07fb513945d6272f238814a4cd297da7b0e..b5fb547ce35b4c66e8a52de9324f83f9a25aff7a 100644
|
||||
--- a/src/node_crypto.cc
|
||||
+++ b/src/node_crypto.cc
|
||||
@@ -959,12 +959,10 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
||||
ERR_error_string(err, nullptr));
|
||||
}
|
||||
}
|
||||
}
|
||||
|
||||
- // Increment reference count so global store is not deleted along with CTX.
|
||||
- X509_STORE_up_ref(root_cert_store);
|
||||
SSL_CTX_set_cert_store(sc->ctx_, root_cert_store);
|
||||
}
|
||||
|
||||
|
||||
void SecureContext::SetCiphers(const FunctionCallbackInfo<Value>& args) {
|
||||
diff --git a/src/node_crypto.h b/src/node_crypto.h
|
||||
index 8304e719719dae41757071b4463f8631cb1e442f..a5161aa502e56a6ceb9522ce0ad9c8a677291081 100644
|
||||
--- a/src/node_crypto.h
|
||||
+++ b/src/node_crypto.h
|
||||
@@ -151,10 +151,17 @@ class SecureContext : public BaseObject {
|
||||
if (!ctx_) {
|
||||
return;
|
||||
}
|
||||
|
||||
env()->isolate()->AdjustAmountOfExternalAllocatedMemory(-kExternalSize);
|
||||
+ if (ctx_->cert_store == root_cert_store) {
|
||||
+ // SSL_CTX_free() will attempt to free the cert_store as well.
|
||||
+ // Since we want our root_cert_store to stay around forever
|
||||
+ // we just clear the field. Hopefully OpenSSL will not modify this
|
||||
+ // struct in future versions.
|
||||
+ ctx_->cert_store = nullptr;
|
||||
+ }
|
||||
SSL_CTX_free(ctx_);
|
||||
if (cert_ != nullptr)
|
||||
X509_free(cert_);
|
||||
if (issuer_ != nullptr)
|
||||
X509_free(issuer_);
|
||||
--
|
||||
2.13.5
|
||||
|
41
nodejs.spec
41
nodejs.spec
@ -1,5 +1,7 @@
|
||||
%global with_debug 1
|
||||
|
||||
%{!?_with_bootstrap: %global bootstrap 0}
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
# ARM builds currently break on the Debug builds, so we'll just
|
||||
@ -16,17 +18,17 @@
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 6
|
||||
%global nodejs_minor 11
|
||||
%global nodejs_patch 2
|
||||
%global nodejs_patch 3
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 2
|
||||
%global nodejs_release 1
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
%global v8_major 5
|
||||
%global v8_minor 1
|
||||
%global v8_build 281
|
||||
%global v8_patch 103
|
||||
%global v8_patch 107
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -37,6 +39,12 @@
|
||||
%global c_ares_patch 1
|
||||
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
||||
|
||||
# http-parser - from deps/http_parser/http_parser.h
|
||||
%global http_parser_major 2
|
||||
%global http_parser_minor 7
|
||||
%global http_parser_patch 0
|
||||
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
||||
|
||||
# punycode - from lib/punycode.js
|
||||
# Note: this was merged into the mainline since 0.6.x
|
||||
# Note: this will be unmerged in v7 or v8
|
||||
@ -96,7 +104,13 @@ BuildRequires: libicu-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: gcc >= 4.8.0
|
||||
BuildRequires: gcc-c++ >= 4.8.0
|
||||
|
||||
%if ! 0%{?bootstrap}
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: http-parser-devel >= 2.7.0
|
||||
%else
|
||||
Provides: bundled(http-parser) = %{http_parser_version}
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} > 25
|
||||
BuildRequires: compat-openssl10-devel >= 1:1.0.2
|
||||
@ -148,7 +162,7 @@ Provides: bundled(c-ares) = %{c_ares_version}
|
||||
Provides: bundled(v8) = %{v8_version}
|
||||
|
||||
# Make sure we keep NPM up to date when we update Node.js
|
||||
%if 0%{?epel} || 0%{?rhel}
|
||||
%if 0%{?epel}
|
||||
# EPEL doesn't support Recommends, so make it strict
|
||||
Requires: npm = %{npm_epoch}:%{npm_version}-%{npm_release}%{?dist}
|
||||
%else
|
||||
@ -168,10 +182,12 @@ Summary: JavaScript runtime - development headers
|
||||
Group: Development/Languages
|
||||
Requires: %{name}%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
||||
Requires: libuv-devel%{?_isa}
|
||||
Requires: http-parser-devel%{?_isa}
|
||||
Requires: openssl-devel%{?_isa}
|
||||
Requires: zlib-devel%{?_isa}
|
||||
Requires: nodejs-packaging
|
||||
%if ! 0%{?bootstrap}
|
||||
Requires: http-parser-devel%{?_isa}
|
||||
%endif
|
||||
|
||||
%description devel
|
||||
Development headers for the Node.js JavaScript runtime.
|
||||
@ -242,6 +258,7 @@ export CXXFLAGS='%{optflags} -g \
|
||||
export CFLAGS="$(echo ${CFLAGS} | tr '\n\\' ' ')"
|
||||
export CXXFLAGS="$(echo ${CXXFLAGS} | tr '\n\\' ' ')"
|
||||
|
||||
%if ! 0%{?bootstrap}
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
@ -250,6 +267,15 @@ export CXXFLAGS="$(echo ${CXXFLAGS} | tr '\n\\' ' ')"
|
||||
--without-dtrace \
|
||||
--with-intl=system-icu \
|
||||
--openssl-use-def-ca-store
|
||||
%else
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--shared-libuv \
|
||||
--without-dtrace \
|
||||
--with-intl=system-icu \
|
||||
--openssl-use-def-ca-store
|
||||
%endif
|
||||
|
||||
%if %{?with_debug} == 1
|
||||
# Setting BUILDTYPE=Debug builds both release and debug binaries
|
||||
@ -390,6 +416,11 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Thu Sep 07 2017 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:6.11.3-1
|
||||
- Update to 6.11.3
|
||||
- https://nodejs.org/en/blog/release/v6.11.3/
|
||||
- remove openssl 1.0.1 patches
|
||||
|
||||
* Wed Aug 23 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:6.11.2-2
|
||||
- Move to requiring OpenSSL 1.0.2
|
||||
- Unbundle http-parser again
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v6.11.2-stripped.tar.gz) = f87b65626877ed102f101d095a50a162ca8f471474d6099af40ca27783c6a9da082de4f251325bb51e214395c714b894b22d6d6adb983916e3880c929865703c
|
||||
SHA512 (node-v6.11.3-stripped.tar.gz) = 7e1e60d42d197c4634dd3d79888ea3cffa580bdbb8db1ec359a5d6277504bc013dd22b3a2c33cf957b4a858a3bcdc4e3752ab42b821e3c504887ade40286655a
|
||||
|
Loading…
Reference in New Issue
Block a user