Update to 12.15.0
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
0d8fd851cb
commit
dc276a246e
@ -1,4 +1,4 @@
|
||||
From a560ff12ff44d9732ce325ca4bcde6e536fe3ed0 Mon Sep 17 00:00:00 2001
|
||||
From 5f69e0ff5cd84daec8d6ed49868d0c2a01337107 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e9997670c6a69c5 100644
|
||||
index 56f53582d1f494a05571e3228c4585647e1a30a7..2fb80e742637fdbd039714bda9a9022be7ea259b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -141,9 +141,9 @@ test-code-cache: with-code-cache
|
||||
@ -25,5 +25,5 @@ index 0947300f24028d00bcfb79b38d96bded136228e3..5d4f88a705053fbdd6b56ec85e999767
|
||||
|
||||
# node_version.h is listed because the N-API version is taken from there
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From cf581096dd350cf7267e5a12ff26159120274c5c Mon Sep 17 00:00:00 2001
|
||||
From 4c96b8cdb6690dc0ce329aaddf1a41e58afbd5b4 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/3] Install both binaries and use libdir.
|
||||
@ -82,5 +82,5 @@ index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c
|
||||
if 'true' == variables.get('node_use_dtrace'):
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 30e8730b88afc2c3ac46503a8cc668b367c70e3e Mon Sep 17 00:00:00 2001
|
||||
From c811931a72908b90608fbdc6669da482ac5e7fd9 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Fri, 6 Dec 2019 16:40:25 -0500
|
||||
Subject: [PATCH 3/3] build: auto-load ICU data from
|
||||
@ -86,7 +86,7 @@ index 05d80e846cffd31a0a61943e5ab391ad79cddab0..144544214316a3a5ce256e8772d57d14
|
||||
}],
|
||||
[ 'node_no_browser_globals=="true"', {
|
||||
diff --git a/src/node.cc b/src/node.cc
|
||||
index ae53d0c31c3568d04387da89ab6e9d049e41c919..cbd1c632008f89f2c4aedccb00db19f686693c75 100644
|
||||
index 9d182d2aeb48c8b600bace036df868fb695dfa7c..bfad9a633ceab2493b8fa79badfe8c6c9110e001 100644
|
||||
--- a/src/node.cc
|
||||
+++ b/src/node.cc
|
||||
@@ -79,6 +79,7 @@
|
||||
@ -97,7 +97,7 @@ index ae53d0c31c3568d04387da89ab6e9d049e41c919..cbd1c632008f89f2c4aedccb00db19f6
|
||||
#endif
|
||||
|
||||
|
||||
@@ -848,6 +849,25 @@ int InitializeNodeWithArgs(std::vector<std::string>* argv,
|
||||
@@ -823,6 +824,25 @@ int InitializeNodeWithArgs(std::vector<std::string>* argv,
|
||||
if (per_process::cli_options->icu_data_dir.empty())
|
||||
credentials::SafeGetenv("NODE_ICU_DATA",
|
||||
&per_process::cli_options->icu_data_dir);
|
||||
@ -124,5 +124,5 @@ index ae53d0c31c3568d04387da89ab6e9d049e41c919..cbd1c632008f89f2c4aedccb00db19f6
|
||||
// If icu_data_dir is empty here, it will load the 'minimal' data.
|
||||
if (!i18n::InitializeICUDirectory(per_process::cli_options->icu_data_dir)) {
|
||||
--
|
||||
2.23.0
|
||||
2.24.1
|
||||
|
||||
|
21
nodejs.spec
21
nodejs.spec
@ -8,7 +8,7 @@
|
||||
# This is used by both the nodejs package and the npm subpackage thar
|
||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||
# will bump this rather than adding .1 to the end.
|
||||
%global baserelease 3
|
||||
%global baserelease 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -19,8 +19,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 12
|
||||
%global nodejs_minor 14
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 15
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 72
|
||||
@ -51,13 +51,13 @@
|
||||
|
||||
# http-parser - from deps/http_parser/http_parser.h
|
||||
%global http_parser_major 2
|
||||
%global http_parser_minor 8
|
||||
%global http_parser_patch 0
|
||||
%global http_parser_minor 9
|
||||
%global http_parser_patch 3
|
||||
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
||||
|
||||
# llhttp - from deps/llhttp/include/llhttp.h
|
||||
%global llhttp_major 1
|
||||
%global llhttp_minor 1
|
||||
%global llhttp_major 2
|
||||
%global llhttp_minor 0
|
||||
%global llhttp_patch 4
|
||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
||||
|
||||
@ -69,8 +69,8 @@
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
%global nghttp2_major 1
|
||||
%global nghttp2_minor 39
|
||||
%global nghttp2_patch 2
|
||||
%global nghttp2_minor 40
|
||||
%global nghttp2_patch 0
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
# ICU - from tools/icu/current_ver.dep
|
||||
@ -676,6 +676,9 @@ end
|
||||
%{_pkgdocdir}/npm/docs
|
||||
|
||||
%changelog
|
||||
* Thu Feb 06 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:12.15.0-1
|
||||
- Update to 12.15.0
|
||||
|
||||
* Mon Jan 13 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:12.14.1-3
|
||||
- Fix issue with header symlinks in v8-devel
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v12.14.1-stripped.tar.gz) = c42e5e29c22a836e6cc4b3fedab102d3bec732339f3e924c5e7578ac52a1ade1b5e6382f93bccacdfeb5d74d456a2e3cec735c664c980a5351263a3a14f6cf9d
|
||||
SHA512 (node-v12.15.0-stripped.tar.gz) = 89616891c666224b42fff53c4893e5fd4e9a4a5635f61954cb7ad9a0731ba0637b7f4a778508091324321250b33d5d70f77022436afdbafbf79cc58942e89f51
|
||||
SHA512 (icu4c-64_2-src.tgz) = 5ecb4c230ba45918747a1cf9aef86f555aa07d5b29b1d07ab674e8013f46dfb907a0e9d6945db41155f9dc3012fd94e1152ffc19f61a68b6dfcbabdcb8ae9d78
|
||||
|
Loading…
Reference in New Issue
Block a user