Update to Node.js 18.2.0

https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.2.0
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2022-05-17 14:16:51 -04:00
parent 17860dee0a
commit cec740c48c
No known key found for this signature in database
GPG Key ID: 45DB85A568286D11
4 changed files with 33 additions and 52 deletions

View File

@ -1,4 +1,4 @@
From dd952f69bcbf0a9947a0629e44c49003dcb9f77f Mon Sep 17 00:00:00 2001 From 221a54bccf0c373abe711553e5d5a1887c9650bf Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com> From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Fri, 17 Apr 2020 12:59:44 +0200 Date: Fri, 17 Apr 2020 12:59:44 +0200
Subject: [PATCH 1/2] Disable running gyp on shared deps Subject: [PATCH 1/2] Disable running gyp on shared deps
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 688ebc550e9d6677f468bb791b5d06d5507d3ab5..b34b49db53a4b0cb4a3867921f5c6fb71ae34bf1 100644 index 4aace77c7c8c63c652755b4e1d03be51eb53131e..0bad86420d64762f2df225aa2e070befd5801612 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -145,11 +145,11 @@ endif @@ -145,11 +145,11 @@ endif
@ -25,5 +25,5 @@ index 688ebc550e9d6677f468bb791b5d06d5507d3ab5..b34b49db53a4b0cb4a3867921f5c6fb7
# node_version.h is listed because the N-API version is taken from there # node_version.h is listed because the N-API version is taken from there
-- --
2.34.1 2.35.1

View File

@ -1,4 +1,4 @@
From a1c35106e7e9ab3d4a01779079cf9788a2fe777a Mon Sep 17 00:00:00 2001 From 9f8cd8f9ef8a9466e7d315cdf05fb24eab2678b8 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com> From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400 Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 2/2] Install both binaries and use libdir. Subject: [PATCH 2/2] Install both binaries and use libdir.
@ -9,15 +9,15 @@ still providing the normal executable.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com> Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com> Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
--- ---
configure.py | 7 +++++++ configure.py | 7 +++++++
tools/install.py | 21 +++++++++------------ tools/install.py | 2 +-
2 files changed, 16 insertions(+), 12 deletions(-) 2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/configure.py b/configure.py diff --git a/configure.py b/configure.py
index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a32a3c29e7 100755 index 17ff53ef645493c8090e809b021e1127a07921cd..ad952f6a063d433a76065162baccdca2bab71fbf 100755
--- a/configure.py --- a/configure.py
+++ b/configure.py +++ b/configure.py
@@ -731,10 +731,16 @@ parser.add_argument('--shared', @@ -727,10 +727,16 @@ parser.add_argument('--shared',
dest='shared', dest='shared',
default=None, default=None,
help='compile shared library for embedding node in another project. ' + help='compile shared library for embedding node in another project. ' +
@ -34,7 +34,7 @@ index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a3
dest='without_v8_platform', dest='without_v8_platform',
default=False, default=False,
help='do not initialize v8 platform during node.js startup. ' + help='do not initialize v8 platform during node.js startup. ' +
@@ -1332,10 +1338,11 @@ def configure_node(o): @@ -1364,10 +1370,11 @@ def configure_node(o):
o['variables']['debug_nghttp2'] = 'false' o['variables']['debug_nghttp2'] = 'false'
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals) o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
@ -47,45 +47,22 @@ index 47137d8912dd1439962127a3c1f417eb78572021..c59037a39fcefdfe173d16a7aa9622a3
shlib_suffix = 'so' shlib_suffix = 'so'
elif sys.platform == 'darwin': elif sys.platform == 'darwin':
diff --git a/tools/install.py b/tools/install.py diff --git a/tools/install.py b/tools/install.py
index eafcb19bf8b29f87c39b0fe7d3c3fd2d175a7b7b..71b5371578711fcc9a1b80069850f0b61bdfebe2 100755 index 47e9d8bd7a1ae596a7c6e1d5917f538e81533726..c1afbbf0827ced2e166668e7932504687009bb9e 100755
--- a/tools/install.py --- a/tools/install.py
+++ b/tools/install.py +++ b/tools/install.py
@@ -128,26 +128,23 @@ def subdir_files(path, dest, action): @@ -141,11 +141,11 @@ def files(action):
for subdir, files_in_path in ret.items(): if is_windows:
action(files_in_path, subdir + '/') action([output_prefix + 'libnode.dll'], 'bin/libnode.dll')
action([output_prefix + 'libnode.lib'], 'lib/libnode.lib')
def files(action): else:
is_windows = sys.platform == 'win32' output_lib = 'libnode.' + variables.get('shlib_suffix')
- output_file = 'node' - action([output_prefix + output_lib], 'lib/' + output_lib)
output_prefix = 'out/Release/' + action([output_prefix + output_lib], variables.get('libdir') + '/' + output_lib)
+ output_libprefix = output_prefix
- if 'false' == variables.get('node_shared'):
- if is_windows:
- output_file += '.exe'
+ if is_windows:
+ output_bin = 'node.exe'
+ output_lib = 'node.dll'
else:
- if is_windows:
- output_file += '.dll'
- else:
- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
+ output_bin = 'node'
+ output_lib = 'libnode.' + variables.get('shlib_suffix')
- if 'false' == variables.get('node_shared'):
- action([output_prefix + output_file], 'bin/' + output_file)
- else:
- action([output_prefix + output_file], 'lib/' + output_file)
+ action([output_prefix + output_bin], 'bin/' + output_bin)
+ if 'true' == variables.get('node_shared'):
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
if 'true' == variables.get('node_use_dtrace'): if 'true' == variables.get('node_use_dtrace'):
action(['out/Release/node.d'], 'lib/dtrace/node.d') action(['out/Release/node.d'], 'lib/dtrace/node.d')
# behave similarly for systemtap # behave similarly for systemtap
action(['src/node.stp'], 'share/systemtap/tapset/')
-- --
2.34.1 2.35.1

View File

@ -40,7 +40,7 @@
# This is used by both the nodejs package and the npm subpackage that # This is used by both the nodejs package and the npm subpackage that
# has a separate version - the name is special so that rpmdev-bumpspec # has a separate version - the name is special so that rpmdev-bumpspec
# will bump this rather than adding .1 to the end. # will bump this rather than adding .1 to the end.
%global baserelease 2 %global baserelease 1
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}} %{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
@ -51,7 +51,7 @@
# than a Fedora release lifecycle. # than a Fedora release lifecycle.
%global nodejs_epoch 1 %global nodejs_epoch 1
%global nodejs_major 18 %global nodejs_major 18
%global nodejs_minor 1 %global nodejs_minor 2
%global nodejs_patch 0 %global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor} %global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h # nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
@ -80,7 +80,7 @@
%global c_ares_version 1.18.1 %global c_ares_version 1.18.1
# llhttp - from deps/llhttp/include/llhttp.h # llhttp - from deps/llhttp/include/llhttp.h
%global llhttp_version 6.0.4 %global llhttp_version 6.0.6
# libuv - from deps/uv/include/uv/version.h # libuv - from deps/uv/include/uv/version.h
%global libuv_version 1.43.0 %global libuv_version 1.43.0
@ -109,7 +109,7 @@
# npm - from deps/npm/package.json # npm - from deps/npm/package.json
%global npm_epoch 1 %global npm_epoch 1
%global npm_version 8.8.0 %global npm_version 8.9.0
# In order to avoid needing to keep incrementing the release version for the # In order to avoid needing to keep incrementing the release version for the
# main package forever, we will just construct one for npm that is guaranteed # main package forever, we will just construct one for npm that is guaranteed
@ -532,13 +532,13 @@ mkdir -p %{buildroot}%{_mandir} \
cp -pr deps/npm/man/* %{buildroot}%{_mandir}/ cp -pr deps/npm/man/* %{buildroot}%{_mandir}/
rm -rf %{buildroot}%{_prefix}/lib/node_modules/npm/man rm -rf %{buildroot}%{_prefix}/lib/node_modules/npm/man
ln -sf %{_mandir} %{buildroot}%{_prefix}/lib/node_modules/npm/man ln -srf %{_mandir} %{buildroot}%{_prefix}/lib/node_modules/npm/man
# Install Gatsby HTML documentation to %%{_pkgdocdir} # Install Gatsby HTML documentation to %%{_pkgdocdir}
cp -pr deps/npm/docs %{buildroot}%{_pkgdocdir}/npm/ cp -pr deps/npm/docs %{buildroot}%{_pkgdocdir}/npm/
rm -rf %{buildroot}%{_prefix}/lib/node_modules/npm/docs rm -rf %{buildroot}%{_prefix}/lib/node_modules/npm/docs
ln -sf %{_pkgdocdir}/npm %{buildroot}%{_prefix}/lib/node_modules/npm/docs ln -srf %{_pkgdocdir}/npm %{buildroot}%{_prefix}/lib/node_modules/npm/docs
# Node tries to install some python files into a documentation directory # Node tries to install some python files into a documentation directory
# (and not the proper one). Remove them for now until we figure out what to # (and not the proper one). Remove them for now until we figure out what to
@ -565,7 +565,7 @@ cp %{SOURCE1} %{buildroot}%{_sysconfdir}/npmrc
# NPM upstream expects it to be in /usr/etc/npmrc, so we'll put a symlink here # NPM upstream expects it to be in /usr/etc/npmrc, so we'll put a symlink here
# This is done in the interests of keeping /usr read-only. # This is done in the interests of keeping /usr read-only.
mkdir -p %{buildroot}%{_prefix}/etc mkdir -p %{buildroot}%{_prefix}/etc
ln -s %{_sysconfdir}/npmrc %{buildroot}%{_prefix}/etc/npmrc ln -rs %{_sysconfdir}/npmrc %{buildroot}%{_prefix}/etc/npmrc
# Install the full-icu data files # Install the full-icu data files
mkdir -p %{buildroot}%{icudatadir} mkdir -p %{buildroot}%{icudatadir}
@ -691,6 +691,10 @@ end
%changelog %changelog
* Tue May 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:18.2.0-1
- Update to Node.js 18.2.0
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.2.0
* Fri May 06 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:18.1.0-2 * Fri May 06 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:18.1.0-2
- Fix incorrect epoch in v8-devel dependency - Fix incorrect epoch in v8-devel dependency

View File

@ -1,3 +1,3 @@
SHA512 (node-v18.1.0-stripped.tar.gz) = 0cc8bf11d9b8fabadc1e5ef6f74f793a039345c1a137c8472264d22591de4a7f8b5dfd9c47b523a534222c6a38b8f3bdb5a22ff8f4a1bd72a86e2c4bf9c67b4e SHA512 (node-v18.2.0-stripped.tar.gz) = 9884b0f878cc9fea819626611b099c3d299b750f43b6792c3787ed1829dc8613d14d7a94f0c917b07eda352f98c5ec6f9191f15a72906daa9687ddc44cc3e82b
SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd
SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e