Merge branch 'f19' into f20
This commit is contained in:
commit
c59552d1db
@ -15,17 +15,18 @@ diff --git a/src/node.cc b/src/node.cc
|
||||
index 4223973..e9696cd 100644
|
||||
--- a/src/node.cc
|
||||
+++ b/src/node.cc
|
||||
@@ -178,8 +178,6 @@ static uv_async_t dispatch_debug_messages_async;
|
||||
@@ -180,9 +180,6 @@ static uv_async_t dispatch_debug_messages_async;
|
||||
// Declared in node_internals.h
|
||||
Isolate* node_isolate = NULL;
|
||||
|
||||
-int WRITE_UTF8_FLAGS = v8::String::HINT_MANY_WRITES_EXPECTED |
|
||||
- v8::String::NO_NULL_TERMINATION;
|
||||
|
||||
-
|
||||
static void Spin(uv_idle_t* handle, int status) {
|
||||
assert((uv_idle_t*) handle == &tick_spinner);
|
||||
@@ -3046,11 +3044,6 @@ static char **copy_argv(int argc, char **argv) {
|
||||
}
|
||||
assert(status == 0);
|
||||
@@ -3077,11 +3074,6 @@ static char **copy_argv(int argc, char **argv) {
|
||||
|
||||
|
||||
int Start(int argc, char *argv[]) {
|
||||
- const char* replaceInvalid = getenv("NODE_INVALID_UTF8");
|
||||
|
12
nodejs.spec
12
nodejs.spec
@ -1,6 +1,6 @@
|
||||
Name: nodejs
|
||||
Version: 0.10.32
|
||||
Release: 2%{?dist}
|
||||
Version: 0.10.33
|
||||
Release: 1%{?dist}
|
||||
Summary: JavaScript runtime
|
||||
License: MIT and ASL 2.0 and ISC and BSD
|
||||
Group: Development/Languages
|
||||
@ -185,6 +185,14 @@ cp -p common.gypi %{buildroot}%{_datadir}/node
|
||||
%{_pkgdocdir}/html
|
||||
|
||||
%changelog
|
||||
* Wed Nov 19 2014 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.10.33-1
|
||||
- new upstream release 0.10.33
|
||||
http://blog.nodejs.org/2014/10/23/node-v0-10-33-stable/
|
||||
- This release disables SSLv3 to secure Node.js services against the POODLE
|
||||
attack. (CVE-2014-3566; RHBZ#1152789) For more information or to learn how
|
||||
to re-enable SSLv3 in order to support legacy clients, please see the upstream
|
||||
release announcement linked above.
|
||||
|
||||
* Tue Oct 21 2014 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.10.32-2
|
||||
- add Provides nodejs-punycode (RHBZ#1151811)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user