Update to 10.0.0
https://nodejs.org/en/blog/release/v10.0.0/ Drop workaround patch Temporarily disable debug build Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
e32bc066e3
commit
b9473f5871
1
.gitignore
vendored
1
.gitignore
vendored
@ -92,3 +92,4 @@
|
||||
/node-v9.10.0-stripped.tar.gz
|
||||
/node-v9.11.1.tar.gz
|
||||
/node-v9.11.1-stripped.tar.gz
|
||||
/node-v10.0.0-stripped.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c2aff16cc196a61f4ab1cdae4a91c7926123c239 Mon Sep 17 00:00:00 2001
|
||||
From 078957089ba07fe1e31a3e5ef718bc37da6d911c Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH] Disable running gyp on shared deps
|
||||
@ -8,22 +8,27 @@ Subject: [PATCH] Disable running gyp on shared deps
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0a217bd893..e1229ad07f 100644
|
||||
index f499788d9d86cc9b7a06c5f918ea1aea2ebd3a8c..4b5b8c9834fa8389511d43ffead2b8233137c499 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -79,10 +79,9 @@ $(NODE_G_EXE): config.gypi out/Makefile
|
||||
@@ -89,14 +89,13 @@ $(NODE_EXE): config.gypi out/Makefile
|
||||
|
||||
$(NODE_G_EXE): config.gypi out/Makefile
|
||||
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
|
||||
if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi
|
||||
|
||||
-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
|
||||
- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
|
||||
- deps/v8/gypfiles/features.gypi deps/v8/src/v8.gyp node.gyp \
|
||||
- deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
|
||||
- config.gypi
|
||||
+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
|
||||
+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \
|
||||
+ deps/v8/src/v8.gyp node.gyp config.gypi
|
||||
+ deps/v8/gypfiles/v8.gyp node.gyp config.gypi
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
config.gypi: configure
|
||||
$(error Missing or stale $@, please run ./$<)
|
||||
|
||||
--
|
||||
2.12.2
|
||||
2.17.0
|
||||
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 058e4efd61c7c9ab4efd55bd9aa37e2184654050 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Wed, 20 Sep 2017 13:05:01 +0200
|
||||
Subject: [PATCH] Fix aarch64 debug
|
||||
|
||||
---
|
||||
deps/v8/src/v8.gyp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/deps/v8/src/v8.gyp b/deps/v8/src/v8.gyp
|
||||
index c269f245aa..2ebbd393a9 100644
|
||||
--- a/deps/v8/src/v8.gyp
|
||||
+++ b/deps/v8/src/v8.gyp
|
||||
@@ -348,7 +348,7 @@
|
||||
'<(INTERMEDIATE_DIR)/snapshot.cc',
|
||||
],
|
||||
'variables': {
|
||||
- 'mksnapshot_flags': [],
|
||||
+ 'mksnapshot_flags': ['--nodebug_code'],
|
||||
'conditions': [
|
||||
['v8_random_seed!=0', {
|
||||
'mksnapshot_flags': ['--random-seed', '<(v8_random_seed)'],
|
||||
@@ -449,7 +449,7 @@
|
||||
'<(mksnapshot_exec)',
|
||||
],
|
||||
'variables': {
|
||||
- 'mksnapshot_flags': [],
|
||||
+ 'mksnapshot_flags': ['--nodebug_code'],
|
||||
'conditions': [
|
||||
['v8_random_seed!=0', {
|
||||
'mksnapshot_flags': ['--random-seed', '<(v8_random_seed)'],
|
||||
--
|
||||
2.14.1
|
||||
|
51
nodejs.spec
51
nodejs.spec
@ -1,4 +1,6 @@
|
||||
%global with_debug 1
|
||||
# Debug builds are failing on GCC 8.0.2
|
||||
# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85587
|
||||
%global with_debug 0
|
||||
|
||||
# bundle dependencies that are not available as Fedora modules
|
||||
# %%{!?_with_bootstrap: %%global bootstrap 1}
|
||||
@ -7,32 +9,25 @@
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
# ARM64 builds of 8.5.0 break on the Debug builds, so we'll just
|
||||
# build the standard runtime until that gets sorted out.
|
||||
# https://github.com/nodejs/node/issues/15395
|
||||
%ifarch aarch64
|
||||
%global with_debug 1
|
||||
%endif
|
||||
|
||||
# == Node.js Version ==
|
||||
# Note: Fedora should only ship LTS versions of Node.js (currently expected
|
||||
# to be major versions with even numbers). The odd-numbered versions are new
|
||||
# feature releases that are only supported for nine months, which is shorter
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 9
|
||||
%global nodejs_minor 11
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_major 10
|
||||
%global nodejs_minor 0
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 2
|
||||
%global nodejs_release 1
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
%global v8_major 6
|
||||
%global v8_minor 2
|
||||
%global v8_build 414
|
||||
%global v8_patch 46
|
||||
%global v8_minor 6
|
||||
%global v8_build 346
|
||||
%global v8_patch 24
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -40,7 +35,7 @@
|
||||
# c-ares - from deps/cares/include/ares_version.h
|
||||
# https://github.com/nodejs/node/pull/9332
|
||||
%global c_ares_major 1
|
||||
%global c_ares_minor 13
|
||||
%global c_ares_minor 14
|
||||
%global c_ares_patch 0
|
||||
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
||||
|
||||
@ -52,7 +47,7 @@
|
||||
|
||||
# libuv - from deps/uv/include/uv-version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 19
|
||||
%global libuv_minor 20
|
||||
%global libuv_patch 2
|
||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||
|
||||
@ -118,10 +113,6 @@ Source7: nodejs_native.attr
|
||||
# Disable running gyp on bundled deps we don't use
|
||||
Patch1: 0001-Disable-running-gyp-files-for-bundled-deps.patch
|
||||
|
||||
# Being fixed upstream.
|
||||
# Follow https://bugs.chromium.org/p/v8/issues/detail?id=6939
|
||||
Patch2: 0001-Fix-aarch64-debug.patch
|
||||
|
||||
# Suppress the message from npm to run `npm -g update npm`
|
||||
# This does bad things on an RPM-managed npm.
|
||||
Patch3: no-npm-update-msg.patch
|
||||
@ -140,15 +131,15 @@ Provides: bundled(nghttp2) = %{nghttp2_version}
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: http-parser-devel >= 2.7.0
|
||||
Requires: http-parser >= 2.7.0
|
||||
BuildRequires: libuv-devel >= 1:1.9.1
|
||||
Requires: libuv >= 1:1.9.1
|
||||
BuildRequires: libuv-devel >= 1:1.20.2
|
||||
Requires: libuv >= 1:1.20.2
|
||||
BuildRequires: libnghttp2-devel >= %{nghttp2_version}
|
||||
Requires: libnghttp2 >= %{nghttp2_version}
|
||||
%endif
|
||||
|
||||
BuildRequires: openssl-devel
|
||||
|
||||
# we need the system certificate store when Patch2 is applied
|
||||
# we need the system certificate store
|
||||
Requires: ca-certificates
|
||||
|
||||
#we need ABI virtual provides where SONAMEs aren't enough/not present so deps
|
||||
@ -274,7 +265,6 @@ The API documentation for the Node.js JavaScript runtime.
|
||||
%patch1 -p1
|
||||
rm -rf deps/zlib
|
||||
|
||||
%patch2 -p1
|
||||
|
||||
%patch3 -p1
|
||||
|
||||
@ -392,7 +382,7 @@ FILES=%{buildroot}/%{_prefix}/lib/node/.bundled/npm/*
|
||||
for f in $FILES
|
||||
do
|
||||
module=`basename $f`
|
||||
ln -s %{_prefix}/lib/node/.bundled/npm/$module \
|
||||
ln -s ../../../node/.bundled/npm/$module \
|
||||
%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/$module
|
||||
done
|
||||
|
||||
@ -429,7 +419,7 @@ rm -f %{buildroot}/%{_defaultdocdir}/node/lldb_commands.py \
|
||||
%{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||
|
||||
# Ensure we have npm and that the version matches
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
|
||||
%files
|
||||
%{_bindir}/node
|
||||
@ -488,6 +478,13 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Thu Apr 26 2018 Stephen Gallagher <sgallagh@redhat.com> - 1:10.0.0-1
|
||||
- Update to 10.0.0
|
||||
- https://nodejs.org/en/blog/release/v10.0.0/
|
||||
- Drop workaround patch
|
||||
- Temporarily drop node_g binary due to
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85587
|
||||
|
||||
* Fri Apr 13 2018 Rafael dos Santos <rdossant@redhat.com> - 1:9.11.1-2
|
||||
- Use standard Fedora linker flags (bug #1543859)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v9.11.1-stripped.tar.gz) = d273432f867ff1bb864da2ebf4c964c894682cd6505abc6aa66672db112c1566dd9c533871b638b8b4921a6a77bfca9876939214f9ca962cfaf1bac164860d31
|
||||
SHA512 (node-v10.0.0-stripped.tar.gz) = dd1a1a966b8020a4fe82dadb21b0b9adc9f5656915d63e635bc913d3935529f48e535308440ef4961c791cb9cfb86a53c442c70d8b17b01a7d02d2c39fb30eff
|
||||
|
Loading…
Reference in New Issue
Block a user