Drop unneeded patch
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
3f0c67d5e5
commit
b8c1833746
@ -1,64 +0,0 @@
|
|||||||
From 694be95b2b7f82ec1f053f652c6f297b3f521fb0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
|
||||||
Subject: [PATCH] Disable running gyp on shared deps
|
|
||||||
|
|
||||||
Signed-off-by: rpm-build <rpm-build>
|
|
||||||
---
|
|
||||||
Makefile | 4 ++--
|
|
||||||
node.gyp | 17 -----------------
|
|
||||||
2 files changed, 2 insertions(+), 19 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 830413fdba81da34a56b8a6aabfca3eacda1684d..21f7de35fa36183b30c6f996894b134f80421df4 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -169,7 +169,7 @@ with-code-cache test-code-cache:
|
|
||||||
$(warning '$@' target is a noop)
|
|
||||||
|
|
||||||
out/Makefile: config.gypi common.gypi node.gyp \
|
|
||||||
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
|
||||||
+ deps/llhttp/llhttp.gyp \
|
|
||||||
deps/simdutf/simdutf.gyp deps/ada/ada.gyp \
|
|
||||||
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
||||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
||||||
@@ -1556,7 +1556,7 @@ CONFLICT_RE=^>>>>>>> [[:xdigit:]]+|^<<<<<<< [[:alpha:]]+
|
|
||||||
|
|
||||||
# Related CI job: node-test-linter
|
|
||||||
lint-ci: lint-js-ci lint-cpp lint-py lint-md lint-addon-docs lint-yaml-build lint-yaml
|
|
||||||
- @if ! ( grep -IEqrs "$(CONFLICT_RE)" --exclude="error-message.js" --exclude="merge-conflict.json" benchmark deps doc lib src test tools ) \
|
|
||||||
+ @if ! ( grep -IEqrs "$(CONFLICT_RE)" --exclude="error-message.js" benchmark deps doc lib src test tools ) \
|
|
||||||
&& ! ( $(FIND) . -maxdepth 1 -type f | xargs grep -IEqs "$(CONFLICT_RE)" ); then \
|
|
||||||
exit 0 ; \
|
|
||||||
else \
|
|
||||||
diff --git a/node.gyp b/node.gyp
|
|
||||||
index 6d1b2bf36902cf54f33513873441c403c2e7ee3d..e5c1f696ffb14421df1a5626be6cf1c6738d870e 100644
|
|
||||||
--- a/node.gyp
|
|
||||||
+++ b/node.gyp
|
|
||||||
@@ -421,23 +421,6 @@
|
|
||||||
],
|
|
||||||
},
|
|
||||||
],
|
|
||||||
- }, {
|
|
||||||
- 'variables': {
|
|
||||||
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
||||||
- 'opensslconfig': './deps/openssl/nodejs-openssl.cnf',
|
|
||||||
- },
|
|
||||||
- 'actions': [
|
|
||||||
- {
|
|
||||||
- 'action_name': 'reset_openssl_cnf',
|
|
||||||
- 'inputs': [ '<(opensslconfig)', ],
|
|
||||||
- 'outputs': [ '<(opensslconfig_internal)', ],
|
|
||||||
- 'action': [
|
|
||||||
- '<(python)', 'tools/copyfile.py',
|
|
||||||
- '<(opensslconfig)',
|
|
||||||
- '<(opensslconfig_internal)',
|
|
||||||
- ],
|
|
||||||
- },
|
|
||||||
- ],
|
|
||||||
}],
|
|
||||||
],
|
|
||||||
}, # node_core_target_name
|
|
||||||
--
|
|
||||||
2.39.2
|
|
||||||
|
|
@ -161,9 +161,6 @@ Source102: wasi-sdk-11.0-linux.tar.gz
|
|||||||
Source111: undici-5.20.0-stripped.tar.gz
|
Source111: undici-5.20.0-stripped.tar.gz
|
||||||
Source112: wasi-sdk-14.0-linux.tar.gz
|
Source112: wasi-sdk-14.0-linux.tar.gz
|
||||||
|
|
||||||
# Disable running gyp on bundled deps we don't use
|
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
|
||||||
|
|
||||||
%if 0%{?nodejs_default}
|
%if 0%{?nodejs_default}
|
||||||
%global pkgname nodejs
|
%global pkgname nodejs
|
||||||
%package -n %{pkgname}
|
%package -n %{pkgname}
|
||||||
|
@ -1,2 +0,0 @@
|
|||||||
[koji]
|
|
||||||
targets = rawhide f37
|
|
@ -164,9 +164,6 @@ Source102: wasi-sdk-@LEXER_WASI_MAJOR@.@LEXER_WASI_MINOR@-linux.tar.gz
|
|||||||
Source111: undici-@UNDICI_VERSION@-stripped.tar.gz
|
Source111: undici-@UNDICI_VERSION@-stripped.tar.gz
|
||||||
Source112: wasi-sdk-@UNDICI_WASI_MAJOR@.@UNDICI_WASI_MINOR@-linux.tar.gz
|
Source112: wasi-sdk-@UNDICI_WASI_MAJOR@.@UNDICI_WASI_MINOR@-linux.tar.gz
|
||||||
|
|
||||||
# Disable running gyp on bundled deps we don't use
|
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
|
||||||
|
|
||||||
%if 0%{?nodejs_default}
|
%if 0%{?nodejs_default}
|
||||||
%global pkgname nodejs
|
%global pkgname nodejs
|
||||||
%package -n %{pkgname}
|
%package -n %{pkgname}
|
||||||
|
Loading…
Reference in New Issue
Block a user