Merge branch '12'
This commit is contained in:
commit
ad26e7b46e
@ -1,4 +1,4 @@
|
||||
From 684bbd3b112afbb575f971ea23a03d3d228922f7 Mon Sep 17 00:00:00 2001
|
||||
From 238fd4c35942ecd020349325772cbb72f80748da Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 5834df883b0c232d2c9187f20e61f35dff4f6cef..ba3cacad0382dc17c4a911ea0c0bb39ced96c650 100644
|
||||
index e14edb2a034173956f69280844a1cbd6dcd63150..6bd2c02928f21b6afcfb5b97e9734165d9aa3907 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -139,11 +139,11 @@ with-code-cache:
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 162762fc882d56e48283bd6393242ec613bf74c9 Mon Sep 17 00:00:00 2001
|
||||
From c591d631e1a26010e0dfb72f278f8dc2ed85d218 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a3e5296fcb14cf3e00f31864f305fb40720e8718 Mon Sep 17 00:00:00 2001
|
||||
From 783d6dbce0c3777568bbf8ea2218bb1e58b66e02 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||
@ -13,7 +13,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 15ea5687cf1cd8e4ebe449ea2fc39eea95fb29b6..a738e300d6098bef4975930422b3fa55b3f5421d 100755
|
||||
index b1a04742f00f2a9f23e3f583f8246ff6ec50c797..a0308c848b2a25f8b5f926aaf6eeccd4ffc7b8a7 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -534,10 +534,16 @@ parser.add_option('--shared',
|
||||
@ -33,7 +33,7 @@ index 15ea5687cf1cd8e4ebe449ea2fc39eea95fb29b6..a738e300d6098bef4975930422b3fa55
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1065,10 +1071,11 @@ def configure_node(o):
|
||||
@@ -1072,10 +1078,11 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
||||
if o['variables']['want_separate_host_toolset'] == 0:
|
||||
|
12
nodejs.spec
12
nodejs.spec
@ -12,7 +12,7 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 12
|
||||
%global nodejs_minor 4
|
||||
%global nodejs_minor 5
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
@ -25,9 +25,9 @@
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 1
|
||||
%global v8_major 7
|
||||
%global v8_minor 4
|
||||
%global v8_minor 5
|
||||
%global v8_build 288
|
||||
%global v8_patch 27
|
||||
%global v8_patch 22
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -48,7 +48,7 @@
|
||||
# llhttp - from deps/llhttp/include/llhttp.h
|
||||
%global llhttp_major 1
|
||||
%global llhttp_minor 1
|
||||
%global llhttp_patch 3
|
||||
%global llhttp_patch 4
|
||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
||||
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
@ -578,6 +578,10 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Thu Jun 27 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.5.0-1
|
||||
- Update to 12.5.0
|
||||
- https://nodejs.org/en/blog/release/v12.5.0/
|
||||
|
||||
* Tue Jun 04 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.4.0-1
|
||||
- Update to 12.4.0
|
||||
- https://nodejs.org/en/blog/release/v12.4.0/
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v12.4.0-stripped.tar.gz) = 71619c7d83d9ad7350d0fb6b7389646baa15a7b83b86fed34443f4228ef8e3d8e3d7186364e8da4eaacc743a6d4a2df68556bd8ccd0c12f79114948e0f8f7c76
|
||||
SHA512 (node-v12.5.0-stripped.tar.gz) = 9eec27388eddc766f9b08ef47a3350bdb1d33c17034e3a005c3f2f91e829526d2d5d8ab3bfa3076cb385ea3629de8ffea2e880963dae82c679020ca5b14916a3
|
||||
|
Loading…
Reference in New Issue
Block a user