Update to 16.9.1

Add experimental 'corepack' tool
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.0
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.1

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2021-09-13 17:05:10 -04:00
parent d4c00004d5
commit 97563f52cd
No known key found for this signature in database
GPG Key ID: 45DB85A568286D11
5 changed files with 36 additions and 20 deletions

View File

@ -1,4 +1,4 @@
From 9cb78e590f42d3fea0234912558fdd3902d799ba Mon Sep 17 00:00:00 2001
From 2c7f9fbe4a30ef6e06d4edf5603a638e1775567a Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Fri, 17 Apr 2020 12:59:44 +0200
Subject: [PATCH 1/2] Disable running gyp on shared deps
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 609d0614419f86a4fef6171f23ee45830d3ef324..a7ecbce37008f0e7399a26348fe7bed73c3d7516 100644
index cc0539d98e8ab985acf75cd3714d165fc60c34c6..079823ad619ce1b859be26f283af6ac3ee4397e2 100644
--- a/Makefile
+++ b/Makefile
@@ -142,11 +142,11 @@ endif
@ -25,5 +25,5 @@ index 609d0614419f86a4fef6171f23ee45830d3ef324..a7ecbce37008f0e7399a26348fe7bed7
# node_version.h is listed because the N-API version is taken from there
--
2.31.1
2.32.0

View File

@ -1,4 +1,4 @@
From c93114b805d4dd5860a5bc7dfd6a0a140444aee7 Mon Sep 17 00:00:00 2001
From c5cf0a60bc07de8fa7a23f98c242a218094a6c9c Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 2/2] Install both binaries and use libdir.
@ -47,10 +47,10 @@ index 9327d6e5f5da064b4476adcc38dfa170ad6c16a2..3c54f419e34cb9f06bb32bc318be2de3
shlib_suffix = 'so'
elif sys.platform == 'darwin':
diff --git a/tools/install.py b/tools/install.py
index 24cf51e73199e60b4c24700e1074fe9bd0a399e6..cce482738804a563b5701ae25039b3d72b0aca73 100755
index 41cc1cbc60a9480cc08df3aa0ebe582c2becc3a2..11208f9e7166ab60da46d5ace2257c239a7e9263 100755
--- a/tools/install.py
+++ b/tools/install.py
@@ -119,26 +119,23 @@ def subdir_files(path, dest, action):
@@ -128,26 +128,23 @@ def subdir_files(path, dest, action):
for subdir, files_in_path in ret.items():
action(files_in_path, subdir + '/')
@ -87,5 +87,5 @@ index 24cf51e73199e60b4c24700e1074fe9bd0a399e6..cce482738804a563b5701ae25039b3d7
# behave similarly for systemtap
--
2.31.1
2.32.0

View File

@ -111,7 +111,10 @@ else
version=$(rpm -q --specfile --qf='%{version}\n' nodejs.spec | head -n1)
fi
rm -f node-v${version}.tar.gz node-v${version}-stripped.tar.gz
rm -rf node-v${version}.tar.gz \
node-v${version}-stripped.tar.gz \
node-v${version}/ \
SHASUMS256.txt
wget http://nodejs.org/dist/v${version}/node-v${version}.tar.gz \
http://nodejs.org/dist/v${version}/SHASUMS256.txt
sha256sum -c SHASUMS256.txt --ignore-missing
@ -189,6 +192,10 @@ echo "npm"
echo "========================="
grep "\"version\":" node-v${version}/deps/npm/package.json
echo
echo "corepack"
echo "========================="
grep "\"version\":" node-v${version}/deps/corepack/package.json
echo
echo "Make sure these versions match what is in the RPM spec file"
rm -rf node-v${version}

View File

@ -19,8 +19,8 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 16
%global nodejs_minor 8
%global nodejs_patch 0
%global nodejs_minor 9
%global nodejs_patch 1
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
%global nodejs_soversion 93
@ -34,11 +34,9 @@
# Epoch is set to ensure clean upgrades from the old v8 package
%global v8_epoch 2
%global v8_major 9
%global v8_minor 2
%global v8_build 230
%global v8_patch 21
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
%global v8_abi %{v8_major}.%{v8_minor}
%global v8_minor 3
%global v8_build 345
%global v8_patch 16
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
@ -92,7 +90,7 @@
%global npm_epoch 1
%global npm_major 7
%global npm_minor 21
%global npm_patch 0
%global npm_patch 1
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
# uvwasi - from deps/uvwasi/include/uvwasi.h
@ -114,6 +112,9 @@
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
# Node.js 16.9.1 and later comes with an experimental package management tool
%global corepack_version 0.9.0
Name: nodejs
Epoch: %{nodejs_epoch}
Version: %{nodejs_version}
@ -191,8 +192,6 @@ Recommends: nodejs-full-i18n%{?_isa} = %{nodejs_epoch}:%{version}-%{release}
# break when binary compatibility is broken
Provides: nodejs(abi) = %{nodejs_abi}
Provides: nodejs(abi%{nodejs_major}) = %{nodejs_abi}
Provides: nodejs(v8-abi) = %{v8_abi}
Provides: nodejs(v8-abi%{v8_major}) = %{v8_abi}
# this corresponds to the "engine" requirement in package.json
Provides: nodejs(engine) = %{nodejs_version}
@ -235,6 +234,7 @@ Provides: bundled(icu) = %{icu_version}
# or there's no option to built it as a shared dependency, so we bundle them
Provides: bundled(uvwasi) = %{uvwasi_version}
Provides: bundled(histogram) = %{histogram_version}
Provides: bundled(corepack) = %{corepack_version}
%if 0%{?fedora}
# Make sure to pull in the appropriate packaging macros when building RPMs
@ -487,7 +487,6 @@ install -Dpm0644 %{SOURCE7} %{buildroot}%{_rpmconfigdir}/fileattrs/nodejs_native
cat << EOF > %{buildroot}%{_rpmconfigdir}/nodejs_native.req
#!/bin/sh
echo 'nodejs(abi%{nodejs_major}) >= %nodejs_abi'
echo 'nodejs(v8-abi%{v8_major}) >= %v8_abi'
EOF
chmod 0755 %{buildroot}%{_rpmconfigdir}/nodejs_native.req
@ -589,6 +588,10 @@ end
%dir %{_datadir}/systemtap/tapset
%{_datadir}/systemtap/tapset/node.stp
# corepack
%{_bindir}/corepack
%{_prefix}/lib/node_modules/corepack
%if %{with bootstrap}
# no dtrace
%else
@ -665,6 +668,12 @@ end
%changelog
* Mon Sep 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.9.1-1
- Update to 16.9.1
- Add experimental 'corepack' tool
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.0
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.9.1
* Tue Aug 31 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.8.0-1
- Update to 16.8.0
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.8.0

View File

@ -1,2 +1,2 @@
SHA512 (node-v16.8.0-stripped.tar.gz) = f785d7552548dd6c6514c83467eb197fccba87aee2dda154f631b89dc4dab22674b51450d784e3a7cf239906e951e185db4dcd51ad92a9d4b87a9449c9e4103b
SHA512 (node-v16.9.1-stripped.tar.gz) = aba020f272d351c0dc5c54fdd8db7a8cf07965d1af2ac1b77879f7dc1736848820648d4d75b6ded4eb3cb51e2f5d6314cbdb31d9a62bbbdc1f43dc1efa7521d5
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7