Update to 16.5.0
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.5.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
5e958a4055
commit
9285d83020
@ -1,7 +1,7 @@
|
||||
From 8506b9411c41dd525249f6b728fd9b91131e8c7c Mon Sep 17 00:00:00 2001
|
||||
From 75126d1a069e58e4fd659d411bdf9f60f9ae94fc Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/3] Install both binaries and use libdir.
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
@ -14,7 +14,7 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 4bc790e2f24219fdd57d59cbf2359f51c02707c5..c3802868080920ef5306aef4d6d632ca88f6efcf 100755
|
||||
index d69c52521d80fb3a24f79bcc4d4a364aceb6fa81..83274ac51613cfc3e37fa563aad19447a4028416 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -720,10 +720,16 @@ parser.add_argument('--shared',
|
||||
@ -34,7 +34,7 @@ index 4bc790e2f24219fdd57d59cbf2359f51c02707c5..c3802868080920ef5306aef4d6d632ca
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1300,10 +1306,11 @@ def configure_node(o):
|
||||
@@ -1307,10 +1313,11 @@ def configure_node(o):
|
||||
o['variables']['debug_nghttp2'] = 'false'
|
||||
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
@ -47,7 +47,7 @@ index 4bc790e2f24219fdd57d59cbf2359f51c02707c5..c3802868080920ef5306aef4d6d632ca
|
||||
shlib_suffix = 'so'
|
||||
elif sys.platform == 'darwin':
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index 045d406d84be301722f3de62abc448db84e751f8..b3ef4541999126c512e3811881388e0ec8d401c4 100755
|
||||
index 24cf51e73199e60b4c24700e1074fe9bd0a399e6..cce482738804a563b5701ae25039b3d72b0aca73 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -119,26 +119,23 @@ def subdir_files(path, dest, action):
|
||||
|
@ -1,58 +0,0 @@
|
||||
From 804555d0bf0014393883df59c471b42ed11d1f9e Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Fri, 2 Jul 2021 09:22:28 -0400
|
||||
Subject: [PATCH 3/3] Revert "build: include minimal V8 headers in
|
||||
distribution"
|
||||
|
||||
This reverts commit 38f32386c138073c6a020ce79085daea15e7b800.
|
||||
---
|
||||
tools/install.py | 17 ++++++-----------
|
||||
1 file changed, 6 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index b3ef4541999126c512e3811881388e0ec8d401c4..7c0b1ba999cdeacd3431b5334d650677754a9752 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -152,21 +152,16 @@ def files(action):
|
||||
if 'true' == variables.get('node_install_npm'): npm_files(action)
|
||||
|
||||
headers(action)
|
||||
|
||||
def headers(action):
|
||||
- def wanted_v8_headers(files_arg, dest):
|
||||
- v8_headers = [
|
||||
- 'deps/v8/include/cppgc/common.h',
|
||||
- 'deps/v8/include/v8.h',
|
||||
- 'deps/v8/include/v8-internal.h',
|
||||
- 'deps/v8/include/v8-platform.h',
|
||||
- 'deps/v8/include/v8-profiler.h',
|
||||
- 'deps/v8/include/v8-version.h',
|
||||
- 'deps/v8/include/v8config.h',
|
||||
+ def ignore_inspector_headers(files_arg, dest):
|
||||
+ inspector_headers = [
|
||||
+ 'deps/v8/include/v8-inspector.h',
|
||||
+ 'deps/v8/include/v8-inspector-protocol.h'
|
||||
]
|
||||
- files_arg = [name for name in files_arg if name in v8_headers]
|
||||
+ files_arg = [name for name in files_arg if name not in inspector_headers]
|
||||
action(files_arg, dest)
|
||||
|
||||
action([
|
||||
'common.gypi',
|
||||
'config.gypi',
|
||||
@@ -182,11 +177,11 @@ def headers(action):
|
||||
|
||||
# Add the expfile that is created on AIX
|
||||
if sys.platform.startswith('aix'):
|
||||
action(['out/Release/node.exp'], 'include/node/')
|
||||
|
||||
- subdir_files('deps/v8/include', 'include/node/', wanted_v8_headers)
|
||||
+ subdir_files('deps/v8/include', 'include/node/', ignore_inspector_headers)
|
||||
|
||||
if 'false' == variables.get('node_shared_libuv'):
|
||||
subdir_files('deps/uv/include', 'include/node/', action)
|
||||
|
||||
if 'true' == variables.get('node_use_openssl') and \
|
||||
--
|
||||
2.31.1
|
||||
|
18
nodejs.spec
18
nodejs.spec
@ -8,7 +8,7 @@
|
||||
# This is used by both the nodejs package and the npm subpackage thar
|
||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||
# will bump this rather than adding .1 to the end.
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -19,8 +19,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 16
|
||||
%global nodejs_minor 4
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 5
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 93
|
||||
@ -36,7 +36,7 @@
|
||||
%global v8_major 9
|
||||
%global v8_minor 1
|
||||
%global v8_build 269
|
||||
%global v8_patch 36
|
||||
%global v8_patch 38
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -91,7 +91,7 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 7
|
||||
%global npm_minor 18
|
||||
%global npm_minor 19
|
||||
%global npm_patch 1
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
@ -145,10 +145,6 @@ Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||
# Patch to install both node and libnode.so, using the correct libdir
|
||||
Patch2: 0002-Install-both-binaries-and-use-libdir.patch
|
||||
|
||||
# Upstream no longer ships all of the v8 headers, but Fedora has packages
|
||||
# that require them.
|
||||
Patch3: 0003-Revert-build-include-minimal-V8-headers-in-distribut.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
@ -669,6 +665,10 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 20 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.5.0-1
|
||||
- Update to 16.5.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.5.0
|
||||
|
||||
* Fri Jul 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.4.1-2
|
||||
- Re-add support for v8 development headers
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v16.4.1-stripped.tar.gz) = 20e6537fef961ba7518f4cb26ffb584b6dbc8990cde0bef9b561382c381528940907301e0f1a47063cbc2e133c7a788ae97ea2b0518fcd93e990bfeeff56f011
|
||||
SHA512 (node-v16.5.0-stripped.tar.gz) = 9f370df93afaec7c5cc6cab08f667dfbaf0f0524a07816c5f823375d102226ca30e6f279bbfcf22fb3bd1b5fb37f7f6137b36c7e393724d2206d43f47db4faa8
|
||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||
|
Loading…
Reference in New Issue
Block a user