Update to 18.10.0
https://github.com/nodejs/node/blob/main/doc/changelogs/CHANGELOG_V18.md#18.10.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
4c37e579db
commit
8d3e75401d
@ -1,32 +0,0 @@
|
||||
From 5193cddcee28a721beb589dba2e2165a71c43745 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Wed, 14 Sep 2022 16:23:13 -0400
|
||||
Subject: [PATCH 2/2] build: fix bad upstream merge
|
||||
|
||||
The upstream merge of https://github.com/nodejs/node/commit/e27e709d3c
|
||||
accidentally removed code related to systemtap and dtrace.
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
tools/install.py | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index 4b01d67da54e1f3dd604e7523a846f6a89f69651..9d5f4a48bca2c926b3ffb3c51c070222d4f7ce7b 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -177,6 +177,11 @@ def files(action):
|
||||
else:
|
||||
output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||
action([output_prefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||
+ if 'true' == variables.get('node_use_dtrace'):
|
||||
+ action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
+
|
||||
+ # behave similarly for systemtap
|
||||
+ action(['src/node.stp'], 'share/systemtap/tapset/')
|
||||
|
||||
action(['deps/v8/tools/gdbinit'], 'share/doc/node/')
|
||||
action(['deps/v8/tools/lldb_commands.py'], 'share/doc/node/')
|
||||
--
|
||||
2.37.3
|
||||
|
11
nodejs.spec
11
nodejs.spec
@ -52,8 +52,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 18
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 10
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 108
|
||||
@ -110,7 +110,7 @@
|
||||
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_version 8.19.1
|
||||
%global npm_version 8.19.2
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
# main package forever, we will just construct one for npm that is guaranteed
|
||||
@ -119,7 +119,7 @@
|
||||
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||
|
||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||
%global uvwasi_version 0.0.12
|
||||
%global uvwasi_version 0.0.13
|
||||
|
||||
# histogram_c - assumed from timestamps
|
||||
%global histogram_version 0.9.7
|
||||
@ -154,9 +154,6 @@ Source7: nodejs_native.attr
|
||||
# Disable running gyp on bundled deps we don't use
|
||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||
|
||||
# Fix upstream merge error
|
||||
Patch2: 0002-build-fix-bad-upstream-merge.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python%{python3_pkgversion}-devel
|
||||
BuildRequires: python%{python3_pkgversion}-setuptools
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (node-v18.9.1-stripped.tar.gz) = 59df68a01566994ffb8369339d3cf9484d37adc93eab6fea57cf8df90e19a343a3c98df13d35de889532c22792cdb0dabe4bd120849d3d6dc699c73fdf02b22b
|
||||
SHA512 (node-v18.10.0-stripped.tar.gz) = c62f19be6c2db35e657af6700b818624860bc802a814f850bde8027046c8046ef7446f5523fa9b7f9c053326cfedc713473088fd423721a515c1750aa3455138
|
||||
SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd
|
||||
SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e
|
||||
|
Loading…
Reference in New Issue
Block a user