Update to 14.15.4

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2021-01-04 15:18:59 -05:00
parent d4fae2de5a
commit 74b49c257f
No known key found for this signature in database
GPG Key ID: 45DB85A568286D11
4 changed files with 37 additions and 26 deletions

View File

@ -1,18 +1,20 @@
From 65f5eb67f4691ab535cc00240a00bd33efe29969 Mon Sep 17 00:00:00 2001 From b0b4d1ddbc720db73fb8ab13cdbbf1ce6524eebd Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com> From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Fri, 17 Apr 2020 12:59:44 +0200 Date: Fri, 17 Apr 2020 12:59:44 +0200
Subject: [PATCH] 0001 Subject: [PATCH 1/2] Disable running gyp on shared deps
--- ---
Makefile | 2 +- Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 34cdec7f7767b5152678adaeea10a8cf711fb9a8..3b548907033108831e99e054bc84d3ce91daa25c 100644 index 93d63110ae2e3928a95d24036b86d11885ab240f..79caaec2112cefa8f6a1c947375b517e9676f176 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -141,7 +141,7 @@ test-code-cache: with-code-cache @@ -136,11 +136,11 @@ endif
echo "'test-code-cache' target is a noop" .PHONY: test-code-cache
with-code-cache test-code-cache:
$(warning '$@' target is a noop)
out/Makefile: config.gypi common.gypi node.gyp \ out/Makefile: config.gypi common.gypi node.gyp \
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \ - deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
@ -20,6 +22,8 @@ index 34cdec7f7767b5152678adaeea10a8cf711fb9a8..3b548907033108831e99e054bc84d3ce
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \ tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make $(PYTHON) tools/gyp_node.py -f make
# node_version.h is listed because the N-API version is taken from there
-- --
2.25.2 2.29.2

View File

@ -1,4 +1,4 @@
From 0b315d55b13d098ce8f3e96d501aeb33152a9e00 Mon Sep 17 00:00:00 2001 From 45a9bca165f6ed76c4e43cc2cc3fdf596814bc77 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com> From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400 Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 2/2] Install both binaries and use libdir. Subject: [PATCH 2/2] Install both binaries and use libdir.
@ -9,14 +9,16 @@ still providing the normal executable.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com> Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
--- ---
configure.py | 7 +++++++ configure.py | 7 +++++++
tools/install.py | 29 +++++++++++++---------------- tools/install.py | 21 +++++++++------------
2 files changed, 20 insertions(+), 16 deletions(-) 2 files changed, 16 insertions(+), 12 deletions(-)
diff --git a/configure.py b/configure.py diff --git a/configure.py b/configure.py
index beb08df0884f7693b6c07d7fb5e85ae7bdcd1d7d..9e364586d4f79322fe53f41915ed7aad0e23a30d 100755 index e6f7e4db0040dda00e432352afa7576535d9b672..6cf5c45dde79ce355b532c2f11b5b7ed80fde88a 100755
--- a/configure.py --- a/configure.py
+++ b/configure.py +++ b/configure.py
@@ -582,6 +582,12 @@ parser.add_option('--shared', @@ -624,10 +624,16 @@ parser.add_option('--shared',
action='store_true',
dest='shared',
help='compile shared library for embedding node in another project. ' + help='compile shared library for embedding node in another project. ' +
'(This mode is not officially supported for regular applications)') '(This mode is not officially supported for regular applications)')
@ -29,7 +31,11 @@ index beb08df0884f7693b6c07d7fb5e85ae7bdcd1d7d..9e364586d4f79322fe53f41915ed7aad
parser.add_option('--without-v8-platform', parser.add_option('--without-v8-platform',
action='store_true', action='store_true',
dest='without_v8_platform', dest='without_v8_platform',
@@ -1124,6 +1130,7 @@ def configure_node(o): default=False,
help='do not initialize v8 platform during node.js startup. ' +
@@ -1200,10 +1206,11 @@ def configure_node(o):
o['variables']['debug_nghttp2'] = 'false'
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals) o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
o['variables']['node_shared'] = b(options.shared) o['variables']['node_shared'] = b(options.shared)
@ -37,11 +43,15 @@ index beb08df0884f7693b6c07d7fb5e85ae7bdcd1d7d..9e364586d4f79322fe53f41915ed7aad
node_module_version = getmoduleversion.get_version() node_module_version = getmoduleversion.get_version()
if options.dest_os == 'android': if options.dest_os == 'android':
shlib_suffix = 'so'
elif sys.platform == 'darwin':
diff --git a/tools/install.py b/tools/install.py diff --git a/tools/install.py b/tools/install.py
index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c049b0503 100755 index 729b416fc47d3ff3317ae3671dee977c719a8841..9bfc6234edb7732f9b90f063c2ee4a276e840636 100755
--- a/tools/install.py --- a/tools/install.py
+++ b/tools/install.py +++ b/tools/install.py
@@ -121,26 +121,23 @@ def subdir_files(path, dest, action): @@ -119,26 +119,23 @@ def subdir_files(path, dest, action):
for subdir, files_in_path in ret.items():
action(files_in_path, subdir + '/')
def files(action): def files(action):
is_windows = sys.platform == 'win32' is_windows = sys.platform == 'win32'
@ -60,16 +70,8 @@ index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c
- output_file += '.dll' - output_file += '.dll'
- else: - else:
- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix') - output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
- # GYP will output to lib.target except on OS X, this is hardcoded
- # in its source - see the _InstallableTargetInstallPath function.
- if sys.platform != 'darwin':
- output_prefix += 'lib.target/'
+ output_bin = 'node' + output_bin = 'node'
+ output_lib = 'libnode.' + variables.get('shlib_suffix') + output_lib = 'libnode.' + variables.get('shlib_suffix')
+ # GYP will output to lib.target except on OS X, this is hardcoded
+ # in its source - see the _InstallableTargetInstallPath function.
+ if sys.platform != 'darwin':
+ output_libprefix += 'lib.target/'
- if 'false' == variables.get('node_shared'): - if 'false' == variables.get('node_shared'):
- action([output_prefix + output_file], 'bin/' + output_file) - action([output_prefix + output_file], 'bin/' + output_file)
@ -81,6 +83,8 @@ index 655802980a6ea94d1d4ca1dc63c8c8e905fbb83a..fe4723bf15012c8aacacb0393dc8294c
if 'true' == variables.get('node_use_dtrace'): if 'true' == variables.get('node_use_dtrace'):
action(['out/Release/node.d'], 'lib/dtrace/node.d') action(['out/Release/node.d'], 'lib/dtrace/node.d')
# behave similarly for systemtap
-- --
2.24.1 2.29.2

View File

@ -24,7 +24,7 @@
%global nodejs_epoch 1 %global nodejs_epoch 1
%global nodejs_major 14 %global nodejs_major 14
%global nodejs_minor 15 %global nodejs_minor 15
%global nodejs_patch 1 %global nodejs_patch 4
%global nodejs_abi %{nodejs_major}.%{nodejs_minor} %global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h # nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
%global nodejs_soversion 83 %global nodejs_soversion 83
@ -96,7 +96,7 @@
%global npm_epoch 1 %global npm_epoch 1
%global npm_major 6 %global npm_major 6
%global npm_minor 14 %global npm_minor 14
%global npm_patch 8 %global npm_patch 10
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch} %global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
# uvwasi - from deps/uvwasi/include/uvwasi.h # uvwasi - from deps/uvwasi/include/uvwasi.h
@ -677,6 +677,9 @@ end
%changelog %changelog
* Mon Jan 04 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:14.15.4-1
- Update to 14.15.4
* Wed Dec 02 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:14.15.1-1 * Wed Dec 02 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:14.15.1-1
- Update to 14.15.1 - Update to 14.15.1

View File

@ -1,2 +1,2 @@
SHA512 (node-v14.15.1-stripped.tar.gz) = aa07a49485a0fecc282173b8b6d915b912a19191446ed6f4684d979e4baebadb7708a338410c2c42ee81d8395db6cfaf9b0879baea9e652dd97f7811a077975d SHA512 (node-v14.15.4-stripped.tar.gz) = 2c1d9b67e6b9bbdd960eeb82edfb02c237a7c7190407cf60bf14b02eb2b6143159b6f45e7bddb7c97120eab4faa37455534ab8b90bd4161b6d66dab0a72b122e
SHA512 (icu4c-67_1-src.tgz) = 4779f1ce1ca7976f6fad6768853ea8c540da54d11509e3b6cfd864a04b5f2db1c3d4b546387f91ad02fb90804525bc37d2543173f0d705d6ca11dc6f2b7640a8 SHA512 (icu4c-67_1-src.tgz) = 4779f1ce1ca7976f6fad6768853ea8c540da54d11509e3b6cfd864a04b5f2db1c3d4b546387f91ad02fb90804525bc37d2543173f0d705d6ca11dc6f2b7640a8