Update to 16.6.0
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
368b5190bc
commit
72af3e7809
@ -1,14 +1,14 @@
|
|||||||
From dcc5e9723343bb540ed678e6e3cb93d9a6f00391 Mon Sep 17 00:00:00 2001
|
From 1f9fbdd011f93d9b7818fa4c5e0fd366a89613d0 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||||
|
|
||||||
---
|
---
|
||||||
Makefile | 2 +-
|
Makefile | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 58260979e114588365ebb3ebd5331622440ecff4..9388260f5da5fa01f8881dea53caf849fc278d10 100644
|
index 81907c9220f2027e8d25f985de585fd2c2e7bac7..d2023f39eb61e9b777e0d1d0162d21a6453a6eb1 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -142,11 +142,11 @@ endif
|
@@ -142,11 +142,11 @@ endif
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 75126d1a069e58e4fd659d411bdf9f60f9ae94fc Mon Sep 17 00:00:00 2001
|
From fae25ad98f1aaad77e31a59405730ebbc53eb5c9 Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||||
@ -14,10 +14,10 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|||||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index d69c52521d80fb3a24f79bcc4d4a364aceb6fa81..83274ac51613cfc3e37fa563aad19447a4028416 100755
|
index a4c4d26987cb10297662258fab957d8d89b2f9f9..7738a72ffe82034ce109b9eb398f09493b8cd5f5 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -720,10 +720,16 @@ parser.add_argument('--shared',
|
@@ -721,10 +721,16 @@ parser.add_argument('--shared',
|
||||||
dest='shared',
|
dest='shared',
|
||||||
default=None,
|
default=None,
|
||||||
help='compile shared library for embedding node in another project. ' +
|
help='compile shared library for embedding node in another project. ' +
|
||||||
@ -34,7 +34,7 @@ index d69c52521d80fb3a24f79bcc4d4a364aceb6fa81..83274ac51613cfc3e37fa563aad19447
|
|||||||
dest='without_v8_platform',
|
dest='without_v8_platform',
|
||||||
default=False,
|
default=False,
|
||||||
help='do not initialize v8 platform during node.js startup. ' +
|
help='do not initialize v8 platform during node.js startup. ' +
|
||||||
@@ -1307,10 +1313,11 @@ def configure_node(o):
|
@@ -1305,10 +1311,11 @@ def configure_node(o):
|
||||||
o['variables']['debug_nghttp2'] = 'false'
|
o['variables']['debug_nghttp2'] = 'false'
|
||||||
|
|
||||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||||
|
14
nodejs.spec
14
nodejs.spec
@ -8,7 +8,7 @@
|
|||||||
# This is used by both the nodejs package and the npm subpackage thar
|
# This is used by both the nodejs package and the npm subpackage thar
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
|
|
||||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -19,7 +19,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 16
|
%global nodejs_major 16
|
||||||
%global nodejs_minor 5
|
%global nodejs_minor 6
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
@ -34,9 +34,9 @@
|
|||||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||||
%global v8_epoch 2
|
%global v8_epoch 2
|
||||||
%global v8_major 9
|
%global v8_major 9
|
||||||
%global v8_minor 1
|
%global v8_minor 2
|
||||||
%global v8_build 269
|
%global v8_build 230
|
||||||
%global v8_patch 38
|
%global v8_patch 21
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||||
%global v8_abi %{v8_major}.%{v8_minor}
|
%global v8_abi %{v8_major}.%{v8_minor}
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
@ -665,6 +665,10 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 02 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.6.0-1
|
||||||
|
- Update to 16.6.0
|
||||||
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.6.0
|
||||||
|
|
||||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:16.5.0-2
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:16.5.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (node-v16.5.0-stripped.tar.gz) = 9f370df93afaec7c5cc6cab08f667dfbaf0f0524a07816c5f823375d102226ca30e6f279bbfcf22fb3bd1b5fb37f7f6137b36c7e393724d2206d43f47db4faa8
|
SHA512 (node-v16.6.0-stripped.tar.gz) = 33f318257d0cc1ac13625b5f90c3215d345023aefee0a975fbb24edac8e6192d0db5fc614a68d2c582b4bbdd7eea7efff064057624cf9a759129734c1bc2bf32
|
||||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||||
|
Loading…
Reference in New Issue
Block a user