Update to latest stable release 5.11.0
- https://github.com/nodejs/node/blob/v5.11.0/CHANGELOG.md
This commit is contained in:
parent
b4761abbba
commit
6e360a8b50
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@
|
|||||||
/node-v5.9.1-stripped.tar.gz
|
/node-v5.9.1-stripped.tar.gz
|
||||||
/node-v5.10.0-stripped.tar.gz
|
/node-v5.10.0-stripped.tar.gz
|
||||||
/node-v5.10.1-stripped.tar.gz
|
/node-v5.10.1-stripped.tar.gz
|
||||||
|
/node-v5.11.0-stripped.tar.gz
|
||||||
|
@ -20,17 +20,15 @@ Node.js 4.2
|
|||||||
|
|
||||||
Modified 2016-03-04 by Stephen Gallagher <sgallagh@redhat.com> to update for
|
Modified 2016-03-04 by Stephen Gallagher <sgallagh@redhat.com> to update for
|
||||||
Node.js 5.7.1
|
Node.js 5.7.1
|
||||||
---
|
|
||||||
src/node_crypto.cc | 28 ++++++++--------------------
|
|
||||||
1 file changed, 8 insertions(+), 20 deletions(-)
|
|
||||||
|
|
||||||
|
Modified 2016-04-25 by Joseph Wang <joequant@gmail.com> to update for
|
||||||
|
Node.js 5.11.0
|
||||||
|
---
|
||||||
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
|
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
|
||||||
index acd83e9f2f41ade75ee9a3c8061acfa8b3dbf0f4..70ffe035f8be24b2eb6daf71185649d8ae7d579f 100644
|
index 989110c..a55b69d 100644
|
||||||
--- a/src/node_crypto.cc
|
--- a/src/node_crypto.cc
|
||||||
+++ b/src/node_crypto.cc
|
+++ b/src/node_crypto.cc
|
||||||
@@ -119,11 +119,11 @@ static X509_NAME *cnnic_ev_name =
|
@@ -121,7 +121,7 @@ static X509_NAME *cnnic_ev_name =
|
||||||
sizeof(CNNIC_EV_ROOT_CA_SUBJECT_DATA)-1);
|
|
||||||
|
|
||||||
static uv_mutex_t* locks;
|
static uv_mutex_t* locks;
|
||||||
|
|
||||||
const char* const root_certs[] = {
|
const char* const root_certs[] = {
|
||||||
@ -39,17 +37,13 @@ index acd83e9f2f41ade75ee9a3c8061acfa8b3dbf0f4..70ffe035f8be24b2eb6daf71185649d8
|
|||||||
};
|
};
|
||||||
|
|
||||||
X509_STORE* root_cert_store;
|
X509_STORE* root_cert_store;
|
||||||
|
@@ -750,29 +750,17 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
||||||
// Just to generate static methods
|
|
||||||
@@ -748,33 +748,21 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
|
||||||
(void) &clear_error_on_return; // Silence compiler warning.
|
|
||||||
|
|
||||||
CHECK_EQ(sc->ca_store_, nullptr);
|
CHECK_EQ(sc->ca_store_, nullptr);
|
||||||
|
|
||||||
if (!root_cert_store) {
|
if (!root_cert_store) {
|
||||||
- root_cert_store = X509_STORE_new();
|
- root_cert_store = X509_STORE_new();
|
||||||
-
|
-
|
||||||
- for (size_t i = 0; i < ARRAY_SIZE(root_certs); i++) {
|
- for (size_t i = 0; i < arraysize(root_certs); i++) {
|
||||||
- BIO* bp = NodeBIO::NewFixed(root_certs[i], strlen(root_certs[i]));
|
- BIO* bp = NodeBIO::NewFixed(root_certs[i], strlen(root_certs[i]));
|
||||||
- if (bp == nullptr) {
|
- if (bp == nullptr) {
|
||||||
- return;
|
- return;
|
||||||
@ -72,7 +66,7 @@ index acd83e9f2f41ade75ee9a3c8061acfa8b3dbf0f4..70ffe035f8be24b2eb6daf71185649d8
|
|||||||
+ root_cert_store = X509_STORE_new();
|
+ root_cert_store = X509_STORE_new();
|
||||||
}
|
}
|
||||||
+ } else {
|
+ } else {
|
||||||
+ SSL_CTX_set_cert_store(sc->ctx_, root_cert_store);
|
+ SSL_CTX_set_cert_store(sc->ctx_, root_cert_store);
|
||||||
}
|
}
|
||||||
|
|
||||||
sc->ca_store_ = root_cert_store;
|
sc->ca_store_ = root_cert_store;
|
||||||
@ -80,8 +74,7 @@ index acd83e9f2f41ade75ee9a3c8061acfa8b3dbf0f4..70ffe035f8be24b2eb6daf71185649d8
|
|||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
void SecureContext::SetCiphers(const FunctionCallbackInfo<Value>& args) {
|
|
||||||
SecureContext* sc = Unwrap<SecureContext>(args.Holder());
|
|
||||||
--
|
--
|
||||||
2.7.2
|
2.7.2
|
||||||
|
|
||||||
|
14
nodejs.spec
14
nodejs.spec
@ -8,8 +8,8 @@
|
|||||||
|
|
||||||
# == Node.js Version ==
|
# == Node.js Version ==
|
||||||
%global nodejs_major 5
|
%global nodejs_major 5
|
||||||
%global nodejs_minor 10
|
%global nodejs_minor 11
|
||||||
%global nodejs_patch 1
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||||
|
|
||||||
@ -31,8 +31,8 @@
|
|||||||
|
|
||||||
# http-parser - from deps/http_parser/http_parser.h
|
# http-parser - from deps/http_parser/http_parser.h
|
||||||
%global http_parser_major 2
|
%global http_parser_major 2
|
||||||
%global http_parser_minor 6
|
%global http_parser_minor 7
|
||||||
%global http_parser_patch 2
|
%global http_parser_patch 0
|
||||||
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
||||||
|
|
||||||
# punycode - from lib/punycode.js
|
# punycode - from lib/punycode.js
|
||||||
@ -45,7 +45,7 @@
|
|||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_major 3
|
%global npm_major 3
|
||||||
%global npm_minor 8
|
%global npm_minor 8
|
||||||
%global npm_patch 3
|
%global npm_patch 6
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
# Filter out the NPM bundled dependencies so we aren't providing them
|
# Filter out the NPM bundled dependencies so we aren't providing them
|
||||||
@ -324,6 +324,10 @@ ln -sf %{_pkgdocdir}/npm/html %{buildroot}%{_prefix}/lib/node_modules/npm/doc
|
|||||||
%{_pkgdocdir}/npm/doc
|
%{_pkgdocdir}/npm/doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 25 2016 Stephen Gallagher <sgallagh@redhat.com> - %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}-1
|
||||||
|
- Update to latest stable release 5.11.0
|
||||||
|
- https://github.com/nodejs/node/blob/v5.11.0/CHANGELOG.md
|
||||||
|
|
||||||
* Mon Apr 11 2016 Stephen Gallagher <sgallagh@redhat.com> - 5.10.0-1
|
* Mon Apr 11 2016 Stephen Gallagher <sgallagh@redhat.com> - 5.10.0-1
|
||||||
- Update to latest stable release 5.10.1
|
- Update to latest stable release 5.10.1
|
||||||
- https://github.com/nodejs/node/blob/v5.10.1/CHANGELOG.md
|
- https://github.com/nodejs/node/blob/v5.10.1/CHANGELOG.md
|
||||||
|
Loading…
Reference in New Issue
Block a user