Release Node.js 13.9.0
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
21fad4d53b
commit
6dcddc3699
1
.gitignore
vendored
1
.gitignore
vendored
@ -109,3 +109,4 @@
|
||||
/node-v10.10.0-stripped.tar.gz
|
||||
/node-v10.11.0-stripped.tar.gz
|
||||
/icu4c-64_2-src.tgz
|
||||
/icu4c-65_1-src.tgz
|
||||
|
@ -1,29 +1,25 @@
|
||||
From 2213cf773b7cf503807397aac79f10d6690a6640 Mon Sep 17 00:00:00 2001
|
||||
From 65f5eb67f4691ab535cc00240a00bd33efe29969 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
|
||||
---
|
||||
Makefile | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 05eaa73abbe0c6c651bdf446e3678b92700d57c3..829c4c7c9f8a2132def8767a243cb7160a85d2b2 100644
|
||||
index 34cdec7f7767b5152678adaeea10a8cf711fb9a8..3b548907033108831e99e054bc84d3ce91daa25c 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -141,9 +141,9 @@ test-code-cache: with-code-cache
|
||||
@@ -141,7 +141,7 @@ test-code-cache: with-code-cache
|
||||
echo "'test-code-cache' target is a noop"
|
||||
|
||||
out/Makefile: config.gypi common.gypi node.gyp \
|
||||
- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
|
||||
- tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||
- tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||
+ deps/http_parser/http_parser.gyp \
|
||||
+ tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
||||
+ deps/llhttp/llhttp.gyp \
|
||||
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
# node_version.h is listed because the N-API version is taken from there
|
||||
--
|
||||
2.24.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 11512edeb046b64be4daca76f061a3a918251ee0 Mon Sep 17 00:00:00 2001
|
||||
From 0b315d55b13d098ce8f3e96d501aeb33152a9e00 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
@ -13,10 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 6537a62d3954d83927c698db3fb80c9fc05faba7..b9a894bec9e5fd954004bcb423822ca984066dc5 100755
|
||||
index beb08df0884f7693b6c07d7fb5e85ae7bdcd1d7d..9e364586d4f79322fe53f41915ed7aad0e23a30d 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -571,6 +571,12 @@ parser.add_option('--shared',
|
||||
@@ -582,6 +582,12 @@ parser.add_option('--shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
'(This mode is not officially supported for regular applications)')
|
||||
|
||||
@ -29,7 +29,7 @@ index 6537a62d3954d83927c698db3fb80c9fc05faba7..b9a894bec9e5fd954004bcb423822ca9
|
||||
parser.add_option('--without-v8-platform',
|
||||
action='store_true',
|
||||
dest='without_v8_platform',
|
||||
@@ -1105,6 +1111,7 @@ def configure_node(o):
|
||||
@@ -1124,6 +1130,7 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
|
@ -132,6 +132,8 @@ fedpkg new-sources node-v${version}-stripped.tar.gz icu4c*-src.tgz
|
||||
|
||||
rm -f node-v${version}.tar.gz
|
||||
|
||||
set +e
|
||||
|
||||
# Determine the bundled versions of the various packages
|
||||
echo "Bundled software versions"
|
||||
echo "-------------------------"
|
||||
@ -153,12 +155,6 @@ grep "define ARES_VERSION_MAJOR" node-v${version}/deps/cares/include/ares_versio
|
||||
grep "define ARES_VERSION_MINOR" node-v${version}/deps/cares/include/ares_version.h
|
||||
grep "define ARES_VERSION_PATCH" node-v${version}/deps/cares/include/ares_version.h
|
||||
echo
|
||||
echo "http-parser"
|
||||
echo "========================="
|
||||
grep "define HTTP_PARSER_VERSION_MAJOR" node-v${version}/deps/http_parser/http_parser.h
|
||||
grep "define HTTP_PARSER_VERSION_MINOR" node-v${version}/deps/http_parser/http_parser.h
|
||||
grep "define HTTP_PARSER_VERSION_PATCH" node-v${version}/deps/http_parser/http_parser.h
|
||||
echo
|
||||
echo "llhttp"
|
||||
echo "========================="
|
||||
grep "define LLHTTP_VERSION_MAJOR" node-v${version}/deps/llhttp/include/llhttp.h
|
||||
|
43
nodejs.spec
43
nodejs.spec
@ -18,12 +18,12 @@
|
||||
# feature releases that are only supported for nine months, which is shorter
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 12
|
||||
%global nodejs_minor 16
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_major 13
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 72
|
||||
%global nodejs_soversion 79
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release %{baserelease}
|
||||
|
||||
@ -34,9 +34,9 @@
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 2
|
||||
%global v8_major 7
|
||||
%global v8_minor 8
|
||||
%global v8_build 279
|
||||
%global v8_patch 23
|
||||
%global v8_minor 9
|
||||
%global v8_build 317
|
||||
%global v8_patch 25
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -49,12 +49,6 @@
|
||||
%global c_ares_patch 0
|
||||
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
||||
|
||||
# http-parser - from deps/http_parser/http_parser.h
|
||||
%global http_parser_major 2
|
||||
%global http_parser_minor 9
|
||||
%global http_parser_patch 3
|
||||
%global http_parser_version %{http_parser_major}.%{http_parser_minor}.%{http_parser_patch}
|
||||
|
||||
# llhttp - from deps/llhttp/include/llhttp.h
|
||||
%global llhttp_major 2
|
||||
%global llhttp_minor 0
|
||||
@ -64,7 +58,7 @@
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 34
|
||||
%global libuv_patch 0
|
||||
%global libuv_patch 2
|
||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
@ -74,8 +68,8 @@
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
# ICU - from tools/icu/current_ver.dep
|
||||
%global icu_major 64
|
||||
%global icu_minor 2
|
||||
%global icu_major 65
|
||||
%global icu_minor 1
|
||||
%global icu_version %{icu_major}.%{icu_minor}
|
||||
|
||||
%global icudatadir %{nodejs_datadir}/icudata
|
||||
@ -98,7 +92,7 @@
|
||||
%global npm_epoch 1
|
||||
%global npm_major 6
|
||||
%global npm_minor 13
|
||||
%global npm_patch 4
|
||||
%global npm_patch 7
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
@ -148,7 +142,6 @@ BuildRequires: chrpath
|
||||
BuildRequires: libatomic
|
||||
|
||||
%if %{with bootstrap}
|
||||
Provides: bundled(http-parser) = %{http_parser_version}
|
||||
Provides: bundled(libuv) = %{libuv_version}
|
||||
Provides: bundled(nghttp2) = %{nghttp2_version}
|
||||
%else
|
||||
@ -158,15 +151,12 @@ BuildRequires: libuv-devel >= 1:%{libuv_version}
|
||||
Requires: libuv >= 1:%{libuv_version}
|
||||
BuildRequires: libnghttp2-devel >= %{nghttp2_version}
|
||||
Requires: libnghttp2 >= %{nghttp2_version}
|
||||
|
||||
# Temporarily bundle http-parser and llhttp because the latter
|
||||
# isn't packaged yet and they are controlled by the same
|
||||
# configure flag.
|
||||
Provides: bundled(http-parser) = %{http_parser_version}
|
||||
Provides: bundled(llhttp) = %{llhttp_version}
|
||||
|
||||
%endif
|
||||
|
||||
# Temporarily bundle llhttp because the upstream doesn't
|
||||
# provide releases for it.
|
||||
Provides: bundled(llhttp) = %{llhttp_version}
|
||||
|
||||
BuildRequires: openssl-devel >= %{openssl_minimum}
|
||||
Requires: openssl >= %{openssl_minimum}
|
||||
|
||||
@ -672,6 +662,9 @@ end
|
||||
%{_pkgdocdir}/npm/docs
|
||||
|
||||
%changelog
|
||||
* Tue Feb 25 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:13.9.0--1
|
||||
- Release Node.js 13.9.0
|
||||
|
||||
* Tue Feb 25 2020 Stephen Gallagher <sgallagh@redhat.com> - 1:12.16.1-1
|
||||
- Update to 12.16.1
|
||||
- Fixes six regressions introduced in 12.16.0
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v12.16.1-stripped.tar.gz) = 489d337bd522ab48ad9cef99aa2ce3203a05fb05fda0454b805905f699d14da643b51f6b20786995f2aeeb9f468434b60d734e75cec3451e7648da623914c699
|
||||
SHA512 (icu4c-64_2-src.tgz) = 5ecb4c230ba45918747a1cf9aef86f555aa07d5b29b1d07ab674e8013f46dfb907a0e9d6945db41155f9dc3012fd94e1152ffc19f61a68b6dfcbabdcb8ae9d78
|
||||
SHA512 (node-v13.9.0-stripped.tar.gz) = 6d633b8e42954eba13bbf3b3deb47c7514af04a9f650d9d757f4a3ede85d591a21a4e1330d4b9389e59164bd34883c18ba62b50f4479de0daf6080f166f02138
|
||||
SHA512 (icu4c-65_1-src.tgz) = 8f1ef33e1f4abc9a8ee870331c59f01b473d6da1251a19ce403f822f3e3871096f0791855d39c8f20c612fc49cda2c62c06864aa32ddab2dbd186d2b21ce9139
|
||||
|
Loading…
Reference in New Issue
Block a user