Switch to final upstream patch for GCC 7 compatibility
Also drop unused older version of the gyp file patch. This commit makes no functional changes (the upstream patch is identical except for the commit message), so we aren't building this change.
This commit is contained in:
parent
c522b08552
commit
69da18ab93
@ -1,29 +0,0 @@
|
||||
From 061822759b37ab5bda659d74f9149cace5afe628 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 Dec 2015 16:35:29 -0500
|
||||
Subject: [PATCH 1/4] disable running gyp files for bundled deps
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 719b855559383a8011c8f6f073ed69a1cf21aeee..31cd25452dccb0624809c0570a738c5b49cc782c 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -70,11 +70,11 @@ $(NODE_EXE): config.gypi out/Makefile
|
||||
|
||||
$(NODE_G_EXE): config.gypi out/Makefile
|
||||
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
|
||||
ln -fs out/Debug/$(NODE_EXE) $@
|
||||
|
||||
-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
|
||||
+out/Makefile: common.gypi deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
config.gypi: configure
|
||||
$(error Missing or stale $@, please run ./$<)
|
||||
|
||||
--
|
||||
2.12.0
|
||||
|
@ -1,9 +1,18 @@
|
||||
From fbb5821dc3d967e916a187ee009e955530d2ce8d Mon Sep 17 00:00:00 2001
|
||||
From a75f63218b84ee508c770391519a13bd400a5003 Mon Sep 17 00:00:00 2001
|
||||
From: Ben Noordhuis <info@bnoordhuis.nl>
|
||||
Date: Tue, 28 Feb 2017 13:56:40 -0500
|
||||
Subject: [PATCH 4/4] Fix compatibility with GCC 7
|
||||
Date: Thu, 13 Apr 2017 13:48:01 +0200
|
||||
Subject: [PATCH 4/4] v8: fix build errors with g++ 7
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
This is a local patch because upstream fixed it differently by moving
|
||||
large chunks of code out of objects.h. We cannot easily back-port
|
||||
those changes due to their size and invasiveness.
|
||||
|
||||
Fixes: https://github.com/nodejs/node/issues/10388
|
||||
PR-URL: https://github.com/nodejs/node/pull/12392
|
||||
Reviewed-By: Anna Henningsen <anna@addaleax.net>
|
||||
Reviewed-By: Benjamin Gruenbaum <benjamingr@gmail.com>
|
||||
Reviewed-By: Daniel Bevenius <daniel.bevenius@gmail.com>
|
||||
Reviewed-By: James M Snell <jasnell@gmail.com>
|
||||
---
|
||||
deps/v8/src/objects-body-descriptors.h | 2 +-
|
||||
deps/v8/src/objects-inl.h | 21 +++++++++++++++++++++
|
||||
@ -99,5 +108,5 @@ index d1632c9deb298218faea31886ffdb0a8e0201cdc..47b02dadcff9658c9fcfe629e1376670
|
||||
Isolate* isolate, int at_least_space_for,
|
||||
MinimumCapacity capacity_option = USE_DEFAULT_MINIMUM_CAPACITY,
|
||||
--
|
||||
2.12.0
|
||||
2.12.2
|
||||
|
||||
|
@ -19,7 +19,7 @@
|
||||
%global nodejs_patch 2
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 1
|
||||
%global nodejs_release 2
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
@ -101,8 +101,8 @@ Patch2: 0002-Use-openssl-1.0.1.patch
|
||||
# Backported from upstream 7.5.0+
|
||||
Patch3: 0003-crypto-Use-system-CAs-instead-of-using-bundled-ones.patch
|
||||
|
||||
# Patch to allow building with GCC 7 from
|
||||
# https://github.com/nodejs/node/issues/10388#issuecomment-283120731
|
||||
# Backported upstream patch to allow building with GCC 7 from
|
||||
# https://github.com/nodejs/node/commit/2bbee49e6f170a5d6628444a7c9a2235fe0dd929
|
||||
Patch4: 0004-Fix-compatibility-with-GCC-7.patch
|
||||
|
||||
# RHEL 7 still uses OpenSSL 1.0.1 for now, and it segfaults on SSL
|
||||
@ -424,6 +424,9 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Wed Apr 19 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:6.10.2-2
|
||||
- Switch to final upstream patch for GCC 7 compatibility
|
||||
|
||||
* Wed Apr 12 2017 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:6.10.2-1
|
||||
- Update to 6.10.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user