add -g to $C(XX)FLAGS instead of patching configure to add it
This commit is contained in:
parent
af538fcc1b
commit
5dd35b8cd5
@ -1,25 +0,0 @@
|
|||||||
From 93eb51852e0d9cdf5aebc6212eee5cb3273ddbc4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Fri, 14 Dec 2012 08:33:47 -0500
|
|
||||||
Subject: [PATCH 4/4] Build debugging symbols by default
|
|
||||||
|
|
||||||
---
|
|
||||||
configure | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/configure b/configure
|
|
||||||
index 9461d791ec63a63a7271dd3c99ebdf5456032187..ff3e75fd655ad4431dd402a200dbb810bc00eba2 100755
|
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -550,7 +550,7 @@ output = {
|
|
||||||
'include_dirs': [],
|
|
||||||
'libraries': [],
|
|
||||||
'defines': [],
|
|
||||||
- 'cflags': [],
|
|
||||||
+ 'cflags': ['-g'],
|
|
||||||
}
|
|
||||||
|
|
||||||
configure_node(output)
|
|
||||||
--
|
|
||||||
1.8.0.1
|
|
||||||
|
|
14
nodejs.spec
14
nodejs.spec
@ -17,10 +17,6 @@ Source4: nodejs.req
|
|||||||
Source5: nodejs-symlink-deps
|
Source5: nodejs-symlink-deps
|
||||||
Source6: nodejs-fixdep
|
Source6: nodejs-fixdep
|
||||||
|
|
||||||
# This patch is Fedora-specific and allows building the release
|
|
||||||
# binaries with debugging symbols
|
|
||||||
Patch0004: 0004-Build-debugging-symbols-by-default.patch
|
|
||||||
|
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME,
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME,
|
||||||
# so we need to be more explicit until spot fixes that
|
# so we need to be more explicit until spot fixes that
|
||||||
%global v8_ge 3.13.7.5
|
%global v8_ge 3.13.7.5
|
||||||
@ -70,8 +66,6 @@ The API documentation for the Node.js JavaScript runtime.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n node-v%{version}
|
%setup -q -n node-v%{version}
|
||||||
|
|
||||||
%patch0004 -p1
|
|
||||||
|
|
||||||
# Make sure nothing gets included from bundled deps:
|
# Make sure nothing gets included from bundled deps:
|
||||||
# We only delete the source and header files, because
|
# We only delete the source and header files, because
|
||||||
# the remaining build scripts are still used.
|
# the remaining build scripts are still used.
|
||||||
@ -98,8 +92,10 @@ find deps/uv -name "*.c" -exec rm -f {} \;
|
|||||||
find deps/uv -name "*.h" -exec rm -f {} \;
|
find deps/uv -name "*.h" -exec rm -f {} \;
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS='%{optflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
|
# build with debugging symbols and add defines from libuv (#892601)
|
||||||
export CXXFLAGS='%{optflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
|
export CFLAGS='%{optflags} -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
|
||||||
|
export CXXFLAGS='%{optflags} -g -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
|
||||||
|
|
||||||
./configure --prefix=%{_prefix} \
|
./configure --prefix=%{_prefix} \
|
||||||
--shared-v8 \
|
--shared-v8 \
|
||||||
--shared-openssl \
|
--shared-openssl \
|
||||||
@ -111,7 +107,6 @@ export CXXFLAGS='%{optflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
|
|||||||
--without-dtrace
|
--without-dtrace
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
@ -170,6 +165,7 @@ cp -p common.gypi %{buildroot}%{_datadir}/node
|
|||||||
* Wed Jan 09 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-5
|
* Wed Jan 09 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-5
|
||||||
- add defines to match libuv (#892601)
|
- add defines to match libuv (#892601)
|
||||||
- make v8 dependency explicit (and thus more accurate)
|
- make v8 dependency explicit (and thus more accurate)
|
||||||
|
- add -g to $C(XX)FLAGS instead of patching configure to add it
|
||||||
|
|
||||||
* Sat Jan 05 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-4
|
* Sat Jan 05 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-4
|
||||||
- install development headers
|
- install development headers
|
||||||
|
Loading…
Reference in New Issue
Block a user