Update to 8.9.0
Drop upstreamed patch Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
928ef51e4e
commit
599922b4e5
1
.gitignore
vendored
1
.gitignore
vendored
@ -80,3 +80,4 @@
|
||||
/node-v8.7.0-stripped.tar.gz
|
||||
/node-v8.8.0-stripped.tar.gz
|
||||
/node-v8.8.1-stripped.tar.gz
|
||||
/node-v8.9.0-stripped.tar.gz
|
||||
|
@ -1,85 +0,0 @@
|
||||
From 27a4275eb7a52d944b95655fd5afc8b192e95b8c Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Bevenius <daniel.bevenius@gmail.com>
|
||||
Date: Tue, 24 Oct 2017 08:34:02 +0200
|
||||
Subject: [PATCH] src: fix http2 debug build errors
|
||||
|
||||
Currently building with debug enabled produces the following errors:
|
||||
|
||||
In file included from ../src/node_http2.h:6:
|
||||
../src/node_http2_core-inl.h:465:18: error: expected ';' after do/while
|
||||
statement
|
||||
CHECK_GT(id, 0)
|
||||
^
|
||||
;
|
||||
../src/node_http2_core-inl.h:469:18: error: use of undeclared identifier
|
||||
'spec'
|
||||
OnPriority(id, spec.stream_id, spec.weight, spec.exclusive);
|
||||
^
|
||||
../src/node_http2_core-inl.h:469:34: error: use of undeclared identifier
|
||||
'spec'
|
||||
OnPriority(id, spec.stream_id, spec.weight, spec.exclusive);
|
||||
^
|
||||
../src/node_http2_core-inl.h:469:47: error: use of undeclared identifier
|
||||
'spec'
|
||||
OnPriority(id, spec.stream_id, spec.weight, spec.exclusive);
|
||||
^
|
||||
|
||||
This commit adds the missing semicolon to fix the above error.
|
||||
|
||||
../src/node_http2.cc:92:9: error: reference to non-static member
|
||||
function must be called; did you mean to call
|
||||
it with no arguments?
|
||||
CHECK(object->Has(context, env()->ongetpadding_string()).FromJust());
|
||||
^~~~~~
|
||||
../src/util.h:120:20: note: expanded from macro 'CHECK'
|
||||
if (UNLIKELY(!(expr))) {
|
||||
\
|
||||
^~~~
|
||||
../src/util.h:107:44: note: expanded from macro 'UNLIKELY'
|
||||
|
||||
For this issue I was not sure what the correct check would be so I've
|
||||
just commented it out and will update after feedback.
|
||||
|
||||
squash: uncomment check
|
||||
---
|
||||
src/node_http2.cc | 2 +-
|
||||
src/node_http2_core-inl.h | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/node_http2.cc b/src/node_http2.cc
|
||||
index 089423334366c2696b9458ea0aa660ecf3f7ce3e..e10c71e9a84e1ecaf268ef733a2a79ad57c9dc74 100644
|
||||
--- a/src/node_http2.cc
|
||||
+++ b/src/node_http2.cc
|
||||
@@ -87,11 +87,11 @@ ssize_t Http2Session::OnCallbackPadding(size_t frameLen,
|
||||
|
||||
HandleScope handle_scope(isolate);
|
||||
Context::Scope context_scope(context);
|
||||
|
||||
#if defined(DEBUG) && DEBUG
|
||||
- CHECK(object->Has(context, env()->ongetpadding_string()).FromJust());
|
||||
+ CHECK(object()->Has(context, env()->ongetpadding_string()).FromJust());
|
||||
#endif
|
||||
|
||||
AliasedBuffer<uint32_t, v8::Uint32Array>& buffer =
|
||||
env()->http2_state()->padding_buffer;
|
||||
buffer[PADDING_BUF_FRAME_LENGTH] = frameLen;
|
||||
diff --git a/src/node_http2_core-inl.h b/src/node_http2_core-inl.h
|
||||
index 5bfe1dc19a949c9d861ad2d7423a91617feb0649..9735e565b2f0e2585a043054da87d1c81e4e3abf 100644
|
||||
--- a/src/node_http2_core-inl.h
|
||||
+++ b/src/node_http2_core-inl.h
|
||||
@@ -460,11 +460,11 @@ inline void Nghttp2Session::HandlePriorityFrame(const nghttp2_frame* frame) {
|
||||
// Priority frame stream ID should never be <= 0. nghttp2 handles this
|
||||
// as an error condition that terminates the session, so we should be
|
||||
// good here
|
||||
|
||||
#if defined(DEBUG) && DEBUG
|
||||
- CHECK_GT(id, 0)
|
||||
+ CHECK_GT(id, 0);
|
||||
#endif
|
||||
|
||||
nghttp2_priority_spec spec = priority_frame.pri_spec;
|
||||
OnPriority(id, spec.stream_id, spec.weight, spec.exclusive);
|
||||
}
|
||||
--
|
||||
2.14.2
|
||||
|
18
nodejs.spec
18
nodejs.spec
@ -21,8 +21,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 8
|
||||
%global nodejs_minor 8
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 1
|
||||
@ -32,7 +32,7 @@
|
||||
%global v8_major 6
|
||||
%global v8_minor 1
|
||||
%global v8_build 534
|
||||
%global v8_patch 42
|
||||
%global v8_patch 46
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -67,8 +67,8 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 5
|
||||
%global npm_minor 4
|
||||
%global npm_patch 2
|
||||
%global npm_minor 5
|
||||
%global npm_patch 1
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
@ -111,9 +111,6 @@ Patch1: 0001-Disable-running-gyp-files-for-bundled-deps.patch
|
||||
# Follow https://bugs.chromium.org/p/v8/issues/detail?id=6939
|
||||
Patch2: 0001-Fix-aarch64-debug.patch
|
||||
|
||||
# From upstream PR: https://github.com/nodejs/node/pull/16432
|
||||
Patch3: 0001-src-fix-http2-debug-build-errors.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -261,7 +258,6 @@ rm -rf deps/icu-small \
|
||||
deps/zlib
|
||||
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
# build with debugging symbols and add defines from libuv (#892601)
|
||||
@ -457,6 +453,10 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Tue Oct 31 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:8.9.0-1
|
||||
- Update to 8.9.0
|
||||
- Drop upstreamed patch
|
||||
|
||||
* Thu Oct 26 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:8.8.1-1
|
||||
- Update to 8.8.1 to fix a regression
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v8.8.1-stripped.tar.gz) = 2a8a0888401c73dbd30817c21d2709866dde83b85a5af29df4372268bb25f2721bf4ee3a1321f60687e5b2e03d5ce5b9d6d4da4869ae8b1f393e517bd14853af
|
||||
SHA512 (node-v8.9.0-stripped.tar.gz) = b7a2aed662eb6b9dd5029f86fde8658092b8834417e7ccc2f80adf399ccbf7b35932f5afd141c8dd88f2e050ea3418997daabcc8237a59e1af6a2238dc7a384b
|
||||
|
Loading…
Reference in New Issue
Block a user