Update to 16.11.1
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0 https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
99c49fc16f
commit
4c556b450b
@ -1,4 +1,4 @@
|
|||||||
From b67fd1cbe8be07f4f3c2eb2cfa6df4cd78ab6e70 Mon Sep 17 00:00:00 2001
|
From 51f31ab027934c3e7aead556752911e6dee1ea69 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] Disable running gyp on shared deps
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index baae6a3b46bd2680ede8f18166657d3ca6b27027..6b62d40a2ce479e7155a2f23253013b46f11b8b8 100644
|
index e55bd8d70242ace659fa9c7945708156e7770f9d..2959b0a436b10c9ff9b104de5130b751d19cb3a9 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -142,11 +142,11 @@ endif
|
@@ -142,11 +142,11 @@ endif
|
||||||
@ -25,5 +25,5 @@ index baae6a3b46bd2680ede8f18166657d3ca6b27027..6b62d40a2ce479e7155a2f23253013b4
|
|||||||
|
|
||||||
# node_version.h is listed because the N-API version is taken from there
|
# node_version.h is listed because the N-API version is taken from there
|
||||||
--
|
--
|
||||||
2.32.0
|
2.33.0
|
||||||
|
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 7f409cba5389bba6bb10f9a0f05cdf68c4a39338 Mon Sep 17 00:00:00 2001
|
From 62ddf8499747fb1e366477d666c0634ad50039a9 Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||||
@ -14,7 +14,7 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|||||||
2 files changed, 16 insertions(+), 12 deletions(-)
|
2 files changed, 16 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index 9327d6e5f5da064b4476adcc38dfa170ad6c16a2..3c54f419e34cb9f06bb32bc318be2de3cefc4546 100755
|
index 6efb98c2316f089f3167e486282593245373af3f..a6d2ec939e4480dfae703f3978067537abf9f0f0 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -721,10 +721,16 @@ parser.add_argument('--shared',
|
@@ -721,10 +721,16 @@ parser.add_argument('--shared',
|
||||||
@ -87,5 +87,5 @@ index 41cc1cbc60a9480cc08df3aa0ebe582c2becc3a2..11208f9e7166ab60da46d5ace2257c23
|
|||||||
|
|
||||||
# behave similarly for systemtap
|
# behave similarly for systemtap
|
||||||
--
|
--
|
||||||
2.32.0
|
2.33.0
|
||||||
|
|
||||||
|
41
nodejs.spec
41
nodejs.spec
@ -5,7 +5,7 @@
|
|||||||
%define _lto_cflags %{nil}
|
%define _lto_cflags %{nil}
|
||||||
|
|
||||||
# == Master Relase ==
|
# == Master Relase ==
|
||||||
# This is used by both the nodejs package and the npm subpackage thar
|
# This is used by both the nodejs package and the npm subpackage that
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 1
|
%global baserelease 1
|
||||||
@ -19,8 +19,8 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 16
|
%global nodejs_major 16
|
||||||
%global nodejs_minor 10
|
%global nodejs_minor 11
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 1
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
%global nodejs_soversion 93
|
%global nodejs_soversion 93
|
||||||
@ -34,8 +34,8 @@
|
|||||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||||
%global v8_epoch 2
|
%global v8_epoch 2
|
||||||
%global v8_major 9
|
%global v8_major 9
|
||||||
%global v8_minor 3
|
%global v8_minor 4
|
||||||
%global v8_build 345
|
%global v8_build 146
|
||||||
%global v8_patch 19
|
%global v8_patch 19
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||||
@ -50,7 +50,7 @@
|
|||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
%global llhttp_major 6
|
%global llhttp_major 6
|
||||||
%global llhttp_minor 0
|
%global llhttp_minor 0
|
||||||
%global llhttp_patch 2
|
%global llhttp_patch 4
|
||||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
@ -61,8 +61,8 @@
|
|||||||
|
|
||||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||||
%global nghttp2_major 1
|
%global nghttp2_major 1
|
||||||
%global nghttp2_minor 42
|
%global nghttp2_minor 45
|
||||||
%global nghttp2_patch 0
|
%global nghttp2_patch 1
|
||||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||||
|
|
||||||
# ICU - from tools/icu/current_ver.dep
|
# ICU - from tools/icu/current_ver.dep
|
||||||
@ -88,11 +88,17 @@
|
|||||||
|
|
||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_major 7
|
%global npm_major 8
|
||||||
%global npm_minor 24
|
%global npm_minor 0
|
||||||
%global npm_patch 0
|
%global npm_patch 0
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
|
# main package forever, we will just construct one for npm that is guaranteed
|
||||||
|
# to increment safely. Changing this can only be done during an update when the
|
||||||
|
# base npm version number is increasing.
|
||||||
|
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||||
|
|
||||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||||
%global uvwasi_major 0
|
%global uvwasi_major 0
|
||||||
%global uvwasi_minor 0
|
%global uvwasi_minor 0
|
||||||
@ -105,13 +111,6 @@
|
|||||||
%global histogram_patch 7
|
%global histogram_patch 7
|
||||||
%global histogram_version %{histogram_major}.%{histogram_minor}.%{histogram_patch}
|
%global histogram_version %{histogram_major}.%{histogram_minor}.%{histogram_patch}
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
|
||||||
# main package forever, we will just construct one for npm that is guaranteed
|
|
||||||
# to increment safely. Changing this can only be done during an update when the
|
|
||||||
# base npm version number is increasing.
|
|
||||||
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
|
||||||
|
|
||||||
|
|
||||||
# Node.js 16.9.1 and later comes with an experimental package management tool
|
# Node.js 16.9.1 and later comes with an experimental package management tool
|
||||||
%global corepack_version 0.9.0
|
%global corepack_version 0.9.0
|
||||||
|
|
||||||
@ -155,6 +154,7 @@ BuildRequires: zlib-devel
|
|||||||
BuildRequires: brotli-devel
|
BuildRequires: brotli-devel
|
||||||
BuildRequires: gcc >= 6.3.0
|
BuildRequires: gcc >= 6.3.0
|
||||||
BuildRequires: gcc-c++ >= 6.3.0
|
BuildRequires: gcc-c++ >= 6.3.0
|
||||||
|
BuildRequires: jq
|
||||||
# needed to generate bundled provides for npm dependencies
|
# needed to generate bundled provides for npm dependencies
|
||||||
# https://src.fedoraproject.org/rpms/nodejs/pull-request/2
|
# https://src.fedoraproject.org/rpms/nodejs/pull-request/2
|
||||||
# https://pagure.io/nodejs-packaging/pull-request/10
|
# https://pagure.io/nodejs-packaging/pull-request/10
|
||||||
@ -561,7 +561,7 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(
|
|||||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||||
|
|
||||||
# Ensure we have npm and that the version matches
|
# Ensure we have npm and that the version matches
|
||||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/npm version --json |jq '. | select(.npm | contains("7.24.0"))'
|
||||||
|
|
||||||
# Make sure i18n support is working
|
# Make sure i18n support is working
|
||||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node --icu-data-dir=%{buildroot}%{icudatadir} %{SOURCE2}
|
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node --icu-data-dir=%{buildroot}%{icudatadir} %{SOURCE2}
|
||||||
@ -673,6 +673,11 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 13 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.11.1-1
|
||||||
|
- Update to 16.11.1
|
||||||
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0
|
||||||
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.11.0
|
||||||
|
|
||||||
* Thu Sep 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.10.0-1
|
* Thu Sep 23 2021 Stephen Gallagher <sgallagh@redhat.com> - 1:16.10.0-1
|
||||||
- Update to 16.10.0
|
- Update to 16.10.0
|
||||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0
|
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V16.md#16.10.0
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (node-v16.10.0-stripped.tar.gz) = db3e99cd64dc5879be342603affb6b31f674deb7b5e37b08c482d93a862c19c2eb929c20ac5636ad19aeec60693c599466c530f911d48da6e8f4cac5d6c81fe4
|
SHA512 (node-v16.11.1-stripped.tar.gz) = 28bc889637ac8b15b80002b11027ee02d20839ac2262019d6389816221bdf78107a20e51ae439efbb023b3d5b46c183052805b2de53bebee7aa52a66f2040168
|
||||||
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
SHA512 (icu4c-69_1-src.tgz) = d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
|
||||||
|
Loading…
Reference in New Issue
Block a user