Update to Node.js 18.3.0
https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.3.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
cfd6873493
commit
40ffbd5092
@ -1,7 +1,7 @@
|
||||
From 3ac2a9a2ef115a3375162f2abfd26d5cf3f2ee98 Mon Sep 17 00:00:00 2001
|
||||
From 39ca2cee62be0561438f8b422662304458e0d16f Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||
Subject: [PATCH] Disable running gyp on shared deps
|
||||
Subject: [PATCH 1/2] Disable running gyp on shared deps
|
||||
|
||||
Signed-off-by: rpm-build <rpm-build>
|
||||
---
|
||||
@ -10,7 +10,7 @@ Signed-off-by: rpm-build <rpm-build>
|
||||
2 files changed, 1 insertion(+), 18 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 4aace77..0bad864 100644
|
||||
index 9f7ab7129d06471760c707a4bf7764cb2bdff862..78f91cf7f57b0de32961b1d491edf28a4ad375d2 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
|
||||
@ -23,10 +23,10 @@ index 4aace77..0bad864 100644
|
||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
diff --git a/node.gyp b/node.gyp
|
||||
index 86fe9a6..bfa5093 100644
|
||||
index 103178e2ee9a45c436cf630e17025593cf5aaa78..90ae593ca2c153091044674c77e026cad1370ccf 100644
|
||||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -449,23 +449,6 @@
|
||||
@@ -423,23 +423,6 @@
|
||||
],
|
||||
},
|
||||
],
|
||||
@ -51,5 +51,5 @@ index 86fe9a6..bfa5093 100644
|
||||
],
|
||||
}, # node_core_target_name
|
||||
--
|
||||
2.36.1
|
||||
2.35.1
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 6d789d036cf7d997b335d07f19b60c95577ea6e2 Mon Sep 17 00:00:00 2001
|
||||
From b8aad880b037f42d1f5f26e91277dc58f377d01c Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH] Install both binaries and use libdir.
|
||||
Subject: [PATCH 2/2] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
@ -15,7 +15,7 @@ Signed-off-by: rpm-build <rpm-build>
|
||||
2 files changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 17ff53e..ad952f6 100755
|
||||
index 187c381660b369bf4d6f9ce7bfddcf23c5b6c46a..3b948a0ffac6653aad12dfb5565ac703adba5f2a 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -729,6 +729,12 @@ parser.add_argument('--shared',
|
||||
@ -40,7 +40,7 @@ index 17ff53e..ad952f6 100755
|
||||
|
||||
if options.dest_os == 'android':
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index 47e9d8b..c1afbbf 100755
|
||||
index 47e9d8bd7a1ae596a7c6e1d5917f538e81533726..c1afbbf0827ced2e166668e7932504687009bb9e 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -143,7 +143,7 @@ def files(action):
|
||||
@ -53,5 +53,5 @@ index 47e9d8b..c1afbbf 100755
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
|
||||
--
|
||||
2.36.1
|
||||
2.35.1
|
||||
|
||||
|
14
nodejs.spec
14
nodejs.spec
@ -51,7 +51,7 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 18
|
||||
%global nodejs_minor 2
|
||||
%global nodejs_minor 3
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
@ -66,9 +66,9 @@
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 2
|
||||
%global v8_major 10
|
||||
%global v8_minor 1
|
||||
%global v8_build 124
|
||||
%global v8_patch 8
|
||||
%global v8_minor 2
|
||||
%global v8_build 154
|
||||
%global v8_patch 4
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||
|
||||
@ -109,7 +109,7 @@
|
||||
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_version 8.9.0
|
||||
%global npm_version 8.11.0
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
# main package forever, we will just construct one for npm that is guaranteed
|
||||
@ -691,6 +691,10 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 07 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:18.3.0-1
|
||||
- Update to Node.js 18.3.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.3.0
|
||||
|
||||
* Tue May 17 2022 Stephen Gallagher <sgallagh@redhat.com> - 1:18.2.0-1
|
||||
- Update to Node.js 18.2.0
|
||||
- https://github.com/nodejs/node/blob/master/doc/changelogs/CHANGELOG_V18.md#18.2.0
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (node-v18.2.0-stripped.tar.gz) = 1aa760627b56f0da7f4357d7e726cfa0abb66639716717636522dbfa85a8793c15eb3bfea9854b0f80a5e84b68c44ec443beb8d80db4dcbfb1e446331378aa23
|
||||
SHA512 (node-v18.3.0-stripped.tar.gz) = 0ced827fe07b4035ef07f4cfcac35d702b3e671bcbe9099a0952b58d6d6b2c249654a878153d66f7500e194e4087e481e36c4809240c874689fccd21ab2b10e6
|
||||
SHA512 (icu4c-71_1-data-bin-b.zip) = 2bee9b93699c40a53c2e768d4678309fbd49e052e197a80fb76842b4001ee65e548459654ef7e7d154b6289f915fccbcb5b3109edcd61e74f0db289f2bec61fd
|
||||
SHA512 (icu4c-71_1-data-bin-l.zip) = 07a299b1cd37cd7b07c5e1a7c6871c0dbbeabb2dec6e11c89237f41e56fd29e1a65725be102b4e4ab722183c02810a5df3ed47c3b9b4a7c14bc4c72ab127a27e
|
||||
|
Loading…
Reference in New Issue
Block a user