Update to 10.16.0
https://nodejs.org/en/blog/release/v10.16.0/ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
ab8672abf9
commit
3e0c220d1a
@ -1,4 +1,4 @@
|
||||
From 223cfda05cf681b8dfe6f24fbb7d5360d1bfdeee Mon Sep 17 00:00:00 2001
|
||||
From 99ed2ea42371e85b8df10c99bb70ccedbd0c3884 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 4e7263924cf19ac3a3a3670d28d835b21820fd6c..78ffc37bf1a39ad8f8a430a507a2fbffb9029a20 100644
|
||||
index 92d98f0351c4cec030a0725c8f7adbb37a830787..5b1a4816c354b76d1d7240d4cebefa85b28dc532 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -121,14 +121,13 @@ with-code-cache:
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 945b762887c65c2c70024de259e27db8a0a31859 Mon Sep 17 00:00:00 2001
|
||||
From 8cc2464baf61529ddbd7749c8238a89eda6930e3 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||
@ -9,10 +9,10 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
1 file changed, 54 deletions(-)
|
||||
|
||||
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
||||
index 6f76b23828531e7af98a7e3cd7d5abfaac09b40c..98edb6f45fe073e03794a2ae6e7aa7f5500723ee 100755
|
||||
index 705aa472e7e5502311f24767adfb0aebab396772..e8aebe644f610bb09c3748338fd70e6c8c422cea 100755
|
||||
--- a/deps/npm/bin/npm-cli.js
|
||||
+++ b/deps/npm/bin/npm-cli.js
|
||||
@@ -67,69 +67,15 @@
|
||||
@@ -66,69 +66,15 @@
|
||||
if (conf.usage && npm.command !== 'help') {
|
||||
npm.argv.unshift(npm.command)
|
||||
npm.command = 'help'
|
||||
|
@ -1,4 +1,4 @@
|
||||
From ec52fb7c987b3fe68560ae878b4b0f522f01f8a5 Mon Sep 17 00:00:00 2001
|
||||
From c340b54b10858215eaa10fd2775e2c0f3c113dd6 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||
@ -13,7 +13,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 0ad986ab82e29fdc436794b7f24e49afe1239dca..a58420fc618fe9ad79dcdc27bb6758f34ffaa481 100755
|
||||
index cfd4207d32b8b99fda9ec2b2c0f92695f89ef8a3..eb26f7dfe761aa2585252ced28693b9d441b7452 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -550,10 +550,16 @@ parser.add_option('--shared',
|
||||
|
27
nodejs.spec
27
nodejs.spec
@ -12,12 +12,12 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 10
|
||||
%global nodejs_minor 15
|
||||
%global nodejs_patch 3
|
||||
%global nodejs_minor 16
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_soversion 64
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 2
|
||||
%global nodejs_release 1
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
@ -46,8 +46,8 @@
|
||||
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 23
|
||||
%global libuv_patch 2
|
||||
%global libuv_minor 28
|
||||
%global libuv_patch 0
|
||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
@ -57,15 +57,12 @@
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
# ICU - from tools/icu/current_ver.dep
|
||||
%global icu_major 62
|
||||
%global icu_minor 1
|
||||
%global icu_major 64
|
||||
%global icu_minor 2
|
||||
%global icu_version %{icu_major}.%{icu_minor}
|
||||
|
||||
%if 0%{?fedora} >= 29
|
||||
%global icu_flag system-icu
|
||||
%else
|
||||
# No Fedora release has 64.2 yet
|
||||
%global icu_flag small-icu
|
||||
%endif
|
||||
|
||||
|
||||
# punycode - from lib/punycode.js
|
||||
@ -79,8 +76,8 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 6
|
||||
%global npm_minor 4
|
||||
%global npm_patch 1
|
||||
%global npm_minor 9
|
||||
%global npm_patch 0
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
@ -566,6 +563,10 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Fri May 31 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.16.0-1
|
||||
- Update to 10.16.0
|
||||
- https://nodejs.org/en/blog/release/v10.16.0/
|
||||
|
||||
* Wed Apr 24 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.3-2
|
||||
- Fix upgrade bug for v8-devel (BZ #1702609)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v10.15.3-stripped.tar.gz) = 1f7f38e59cfe370855022f9333a89ecfd99152ec901d1cd600c3915fff310b021f7f75dfde8949350edb6af0ab9f191e665b5829d820c29229b7a8dcd0d966df
|
||||
SHA512 (node-v10.16.0-stripped.tar.gz) = 8b753ba18f6e6c8a6a6faa808079ab60c1f06f2da1b73dabf45e066a8ecf21a58f7d91b77e3b7810550f6c043ad5d7cd8cb5f27de05b9fb4e81c4160305276cc
|
||||
|
Loading…
Reference in New Issue
Block a user