Build with a shared library.
This commit is contained in:
parent
f8ff2da483
commit
3dd1c93fd4
87
0001-Install-both-binaries-and-use-libdir.patch
Normal file
87
0001-Install-both-binaries-and-use-libdir.patch
Normal file
@ -0,0 +1,87 @@
|
|||||||
|
From c38964d69ebb93e2273eca4bdcc4370fa26926f8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
|
Subject: [PATCH] Install both binaries and use libdir.
|
||||||
|
|
||||||
|
This allows us to build with a shared library for other users while
|
||||||
|
still providing the normal executable.
|
||||||
|
|
||||||
|
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
|
---
|
||||||
|
configure.py | 7 +++++++
|
||||||
|
tools/install.py | 31 ++++++++++++++-----------------
|
||||||
|
2 files changed, 21 insertions(+), 17 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure.py b/configure.py
|
||||||
|
index b62be2302c..0924fa96dc 100755
|
||||||
|
--- a/configure.py
|
||||||
|
+++ b/configure.py
|
||||||
|
@@ -552,6 +552,12 @@ parser.add_option('--shared',
|
||||||
|
help='compile shared library for embedding node in another project. ' +
|
||||||
|
'(This mode is not officially supported for regular applications)')
|
||||||
|
|
||||||
|
+parser.add_option('--libdir',
|
||||||
|
+ action='store',
|
||||||
|
+ dest='libdir',
|
||||||
|
+ default='lib',
|
||||||
|
+ help='a directory to install the shared library into')
|
||||||
|
+
|
||||||
|
parser.add_option('--without-v8-platform',
|
||||||
|
action='store_true',
|
||||||
|
dest='without_v8_platform',
|
||||||
|
@@ -1094,6 +1100,7 @@ def configure_node(o):
|
||||||
|
if options.code_cache_path:
|
||||||
|
o['variables']['node_code_cache_path'] = options.code_cache_path
|
||||||
|
o['variables']['node_shared'] = b(options.shared)
|
||||||
|
+ o['variables']['libdir'] = options.libdir
|
||||||
|
node_module_version = getmoduleversion.get_version()
|
||||||
|
|
||||||
|
if sys.platform == 'darwin':
|
||||||
|
diff --git a/tools/install.py b/tools/install.py
|
||||||
|
index ce9ceeee1d..5ac67b714e 100755
|
||||||
|
--- a/tools/install.py
|
||||||
|
+++ b/tools/install.py
|
||||||
|
@@ -116,26 +116,23 @@ def subdir_files(path, dest, action):
|
||||||
|
|
||||||
|
def files(action):
|
||||||
|
is_windows = sys.platform == 'win32'
|
||||||
|
- output_file = 'node'
|
||||||
|
output_prefix = 'out/Release/'
|
||||||
|
+ output_libprefix = output_prefix
|
||||||
|
|
||||||
|
- if 'false' == variables.get('node_shared'):
|
||||||
|
- if is_windows:
|
||||||
|
- output_file += '.exe'
|
||||||
|
+ if is_windows:
|
||||||
|
+ output_bin = 'node.exe'
|
||||||
|
+ output_lib = 'node.dll'
|
||||||
|
else:
|
||||||
|
- if is_windows:
|
||||||
|
- output_file += '.dll'
|
||||||
|
- else:
|
||||||
|
- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
|
||||||
|
- # GYP will output to lib.target except on OS X, this is hardcoded
|
||||||
|
- # in its source - see the _InstallableTargetInstallPath function.
|
||||||
|
- if sys.platform != 'darwin':
|
||||||
|
- output_prefix += 'lib.target/'
|
||||||
|
-
|
||||||
|
- if 'false' == variables.get('node_shared'):
|
||||||
|
- action([output_prefix + output_file], 'bin/' + output_file)
|
||||||
|
- else:
|
||||||
|
- action([output_prefix + output_file], 'lib/' + output_file)
|
||||||
|
+ output_bin = 'node'
|
||||||
|
+ output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||||
|
+ # GYP will output to lib.target except on OS X, this is hardcoded
|
||||||
|
+ # in its source - see the _InstallableTargetInstallPath function.
|
||||||
|
+ if sys.platform != 'darwin':
|
||||||
|
+ output_libprefix += 'lib.target/'
|
||||||
|
+
|
||||||
|
+ action([output_prefix + output_bin], 'bin/' + output_bin)
|
||||||
|
+ if 'true' == variables.get('node_shared'):
|
||||||
|
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||||
|
|
||||||
|
if 'true' == variables.get('node_use_dtrace'):
|
||||||
|
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
26
nodejs.spec
26
nodejs.spec
@ -15,6 +15,7 @@
|
|||||||
%global nodejs_minor 15
|
%global nodejs_minor 15
|
||||||
%global nodejs_patch 2
|
%global nodejs_patch 2
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
|
%global nodejs_soversion 64
|
||||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||||
%global nodejs_release 2
|
%global nodejs_release 2
|
||||||
|
|
||||||
@ -120,11 +121,15 @@ Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
|||||||
# Upstream patch to fix debug generation on PowerPC
|
# Upstream patch to fix debug generation on PowerPC
|
||||||
Patch3: 0003-deps-V8-cherry-pick-d0468de.patch
|
Patch3: 0003-deps-V8-cherry-pick-d0468de.patch
|
||||||
|
|
||||||
|
# Patch to install both node and libnode.so, using the correct libdir
|
||||||
|
Patch5: 0001-Install-both-binaries-and-use-libdir.patch
|
||||||
|
|
||||||
BuildRequires: python2-devel
|
BuildRequires: python2-devel
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: gcc >= 4.9.4
|
BuildRequires: gcc >= 4.9.4
|
||||||
BuildRequires: gcc-c++ >= 4.9.4
|
BuildRequires: gcc-c++ >= 4.9.4
|
||||||
|
BuildRequires: chrpath
|
||||||
|
|
||||||
#%if ! 0%%{?bootstrap}
|
#%if ! 0%%{?bootstrap}
|
||||||
%if %{with bootstrap}
|
%if %{with bootstrap}
|
||||||
@ -309,6 +314,8 @@ export LDFLAGS="%{build_ldflags}"
|
|||||||
#%if ! 0%%{?bootstrap}
|
#%if ! 0%%{?bootstrap}
|
||||||
%if %{with bootstrap}
|
%if %{with bootstrap}
|
||||||
./configure --prefix=%{_prefix} \
|
./configure --prefix=%{_prefix} \
|
||||||
|
--shared \
|
||||||
|
--libdir=%{_lib} \
|
||||||
--shared-openssl \
|
--shared-openssl \
|
||||||
--shared-zlib \
|
--shared-zlib \
|
||||||
--without-dtrace \
|
--without-dtrace \
|
||||||
@ -317,6 +324,8 @@ export LDFLAGS="%{build_ldflags}"
|
|||||||
--openssl-use-def-ca-store
|
--openssl-use-def-ca-store
|
||||||
%else
|
%else
|
||||||
./configure --prefix=%{_prefix} \
|
./configure --prefix=%{_prefix} \
|
||||||
|
--shared \
|
||||||
|
--libdir=%{_lib} \
|
||||||
--shared-openssl \
|
--shared-openssl \
|
||||||
--shared-zlib \
|
--shared-zlib \
|
||||||
--shared-libuv \
|
--shared-libuv \
|
||||||
@ -338,6 +347,10 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
# Set the binary permissions properly
|
# Set the binary permissions properly
|
||||||
chmod 0755 %{buildroot}/%{_bindir}/node
|
chmod 0755 %{buildroot}/%{_bindir}/node
|
||||||
|
chrpath --delete %{buildroot}%{_bindir}/node
|
||||||
|
|
||||||
|
# Install library symlink
|
||||||
|
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/libnode.so
|
||||||
|
|
||||||
# own the sitelib directory
|
# own the sitelib directory
|
||||||
mkdir -p %{buildroot}%{_prefix}/lib/node_modules
|
mkdir -p %{buildroot}%{_prefix}/lib/node_modules
|
||||||
@ -402,15 +415,15 @@ chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin
|
|||||||
|
|
||||||
%check
|
%check
|
||||||
# Fail the build if the versions don't match
|
# Fail the build if the versions don't match
|
||||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
||||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
||||||
|
|
||||||
# Ensure we have punycode and that the version matches
|
# Ensure we have punycode and that the version matches
|
||||||
%{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||||
|
|
||||||
# Ensure we have npm and that the version matches
|
# Ensure we have npm and that the version matches
|
||||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||||
|
|
||||||
|
|
||||||
%pretrans -n npm -p <lua>
|
%pretrans -n npm -p <lua>
|
||||||
@ -430,6 +443,7 @@ end
|
|||||||
|
|
||||||
%files
|
%files
|
||||||
%{_bindir}/node
|
%{_bindir}/node
|
||||||
|
%{_libdir}/libnode.so.%{nodejs_soversion}
|
||||||
%dir %{_prefix}/lib/node_modules
|
%dir %{_prefix}/lib/node_modules
|
||||||
%dir %{_datadir}/node
|
%dir %{_datadir}/node
|
||||||
%dir %{_datadir}/systemtap
|
%dir %{_datadir}/systemtap
|
||||||
@ -453,6 +467,7 @@ end
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/node
|
%{_includedir}/node
|
||||||
|
%{_libdir}/libnode.so
|
||||||
%{_datadir}/node/common.gypi
|
%{_datadir}/node/common.gypi
|
||||||
%{_pkgdocdir}/gdbinit
|
%{_pkgdocdir}/gdbinit
|
||||||
|
|
||||||
@ -480,6 +495,7 @@ end
|
|||||||
%changelog
|
%changelog
|
||||||
* Thu Mar 14 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:10.15.2-2
|
* Thu Mar 14 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:10.15.2-2
|
||||||
- Drop debug executable
|
- Drop debug executable
|
||||||
|
- Build with a shared library
|
||||||
|
|
||||||
* Fri Mar 01 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.2-1
|
* Fri Mar 01 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.2-1
|
||||||
- Update to 10.15.2
|
- Update to 10.15.2
|
||||||
|
Loading…
Reference in New Issue
Block a user