Update to 12.7.0
https://nodejs.org/en/blog/release/v12.7.0/ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
41276ef42a
commit
3952fecde8
@ -1,14 +1,14 @@
|
||||
From 238fd4c35942ecd020349325772cbb72f80748da Mon Sep 17 00:00:00 2001
|
||||
From 03ff54a26a47fce13a83094dcfba7840852bf30c Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
Subject: [PATCH 1/4] Disable running gyp on shared deps
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index e14edb2a034173956f69280844a1cbd6dcd63150..6bd2c02928f21b6afcfb5b97e9734165d9aa3907 100644
|
||||
index d7427e578f882034895fc44529d3711c621c06b9..a12edd09252202e98aecaca76cb8457ac98d2ad7 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -139,11 +139,11 @@ with-code-cache:
|
||||
|
@ -1,7 +1,7 @@
|
||||
From c591d631e1a26010e0dfb72f278f8dc2ed85d218 Mon Sep 17 00:00:00 2001
|
||||
From 18ea2d546f5a384d51aad0e7bd39f5b1daaf6471 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||
Subject: [PATCH 2/4] Suppress NPM message to run global update
|
||||
|
||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||
---
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 783d6dbce0c3777568bbf8ea2218bb1e58b66e02 Mon Sep 17 00:00:00 2001
|
||||
From 5cb76403cf796f548ff4a7ed62d6545acb5febe3 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||
Subject: [PATCH 3/4] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
@ -13,10 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index b1a04742f00f2a9f23e3f583f8246ff6ec50c797..a0308c848b2a25f8b5f926aaf6eeccd4ffc7b8a7 100755
|
||||
index a791efebbca128a2138f61713eb2f5d23b8ced98..32eeee090b5248f5236e75f3201177ec446eb41d 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -534,10 +534,16 @@ parser.add_option('--shared',
|
||||
@@ -550,10 +550,16 @@ parser.add_option('--shared',
|
||||
action='store_true',
|
||||
dest='shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
@ -33,11 +33,11 @@ index b1a04742f00f2a9f23e3f583f8246ff6ec50c797..a0308c848b2a25f8b5f926aaf6eeccd4
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1072,10 +1078,11 @@ def configure_node(o):
|
||||
@@ -1096,10 +1102,11 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
||||
if o['variables']['want_separate_host_toolset'] == 0:
|
||||
o['variables']['node_code_cache_path'] = 'yes'
|
||||
o['variables']['node_code_cache'] = 'yes' # For testing
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
+ o['variables']['libdir'] = options.libdir
|
||||
node_module_version = getmoduleversion.get_version()
|
||||
|
35
0004-build-include-stubs-in-shared-library.patch
Normal file
35
0004-build-include-stubs-in-shared-library.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 6d3a39df826c88e4ab12b937bef06c5905c08ab7 Mon Sep 17 00:00:00 2001
|
||||
From: Jeroen Ooms <jeroenooms@gmail.com>
|
||||
Date: Mon, 29 Jul 2019 20:15:14 +0200
|
||||
Subject: [PATCH 4/4] build: include stubs in shared library
|
||||
|
||||
This is needed for external applications that link to shared libnode.
|
||||
Fixes #27431
|
||||
---
|
||||
node.gyp | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/node.gyp b/node.gyp
|
||||
index 55b7da02ccaf1835b5fd986aaa320d72f8b7fbf2..4eae262a61e77bb8a9556e42a241b83eda3f0eba 100644
|
||||
--- a/node.gyp
|
||||
+++ b/node.gyp
|
||||
@@ -684,10 +684,16 @@
|
||||
# - "C4244: conversion from 'type1' to 'type2', possible loss of data"
|
||||
# Ususaly safe. Disable for `dep`, enable for `src`
|
||||
'msvs_disabled_warnings!': [4244],
|
||||
|
||||
'conditions': [
|
||||
+ [ 'node_shared=="true"', {
|
||||
+ 'sources': [
|
||||
+ 'src/node_snapshot_stub.cc',
|
||||
+ 'src/node_code_cache_stub.cc',
|
||||
+ ]
|
||||
+ }],
|
||||
[ 'node_shared=="true" and node_module_version!="" and OS!="win"', {
|
||||
'product_extension': '<(shlib_suffix)',
|
||||
'xcode_settings': {
|
||||
'LD_DYLIB_INSTALL_NAME':
|
||||
'@rpath/lib<(node_core_target_name).<(shlib_suffix)'
|
||||
--
|
||||
2.21.0
|
||||
|
17
nodejs.spec
17
nodejs.spec
@ -8,7 +8,7 @@
|
||||
# This is used by both the nodejs package and the npm subpackage thar
|
||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||
# will bump this rather than adding .1 to the end.
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -19,7 +19,7 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 12
|
||||
%global nodejs_minor 6
|
||||
%global nodejs_minor 7
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
@ -66,8 +66,8 @@
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
%global nghttp2_major 1
|
||||
%global nghttp2_minor 38
|
||||
%global nghttp2_patch 0
|
||||
%global nghttp2_minor 39
|
||||
%global nghttp2_patch 1
|
||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
||||
|
||||
# ICU - from tools/icu/current_ver.dep
|
||||
@ -90,7 +90,7 @@
|
||||
# npm - from deps/npm/package.json
|
||||
%global npm_epoch 1
|
||||
%global npm_major 6
|
||||
%global npm_minor 9
|
||||
%global npm_minor 10
|
||||
%global npm_patch 0
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
@ -133,6 +133,9 @@ Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
||||
# Patch to install both node and libnode.so, using the correct libdir
|
||||
Patch3: 0003-Install-both-binaries-and-use-libdir.patch
|
||||
|
||||
# Upstream patch to include stubs in libnode. Drop in 12.8.0
|
||||
Patch4: 0004-build-include-stubs-in-shared-library.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -588,6 +591,10 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Thu Aug 01 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.7.0-1
|
||||
- Update to 12.7.0
|
||||
- https://nodejs.org/en/blog/release/v12.7.0/
|
||||
|
||||
* Tue Jul 30 2019 Tom Hughes <tom@compton.nu> - 1:12.6.0-2
|
||||
- Bump release to fix dependencies
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v12.6.0-stripped.tar.gz) = b4f9c31d132e6d53a22733c4ab03468f55aeeff959f9fccb908000b093386dcdd46100e483c9999f38b4630cbda68d113fef8d2cfa023c292f0956fd0e3795db
|
||||
SHA512 (node-v12.7.0-stripped.tar.gz) = 267c9a8883b5264d2679dc9306b00533e8cc072e7b59d8b6c9440a6daab0e89fde78f625796f8349210a9b0aafd69ba1f596de32615ae674b8d04f8e185ca311
|
||||
|
Loading…
Reference in New Issue
Block a user