Update to 4.4.1 upstream LTS release
This commit is contained in:
parent
c7bce4c5ec
commit
2a3d08c963
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@
|
||||
/node-v4.2.6-stripped.tar.gz
|
||||
/node-v4.3.0-stripped.tar.gz
|
||||
/node-v4.3.1-stripped.tar.gz
|
||||
/node-v4.4.1-stripped.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 8a53e16138f7fa4371eebde91d3bf216285e75a0 Mon Sep 17 00:00:00 2001
|
||||
From 08ee9476e138421b5f6c4fd928986b125fb82634 Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 Dec 2015 16:35:29 -0500
|
||||
Subject: [PATCH 1/2] disable running gyp files for bundled deps
|
||||
@ -8,10 +8,12 @@ Subject: [PATCH 1/2] disable running gyp files for bundled deps
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 94eb419..a2b682b 100644
|
||||
index ff0098b70d7b2c2b76c6456534013d186ad44f0f..df64f3a90ecf57fb58963b717647d69ffa4fb391 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -49,7 +49,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
|
||||
@@ -47,11 +47,11 @@ $(NODE_EXE): config.gypi out/Makefile
|
||||
|
||||
$(NODE_G_EXE): config.gypi out/Makefile
|
||||
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
|
||||
ln -fs out/Debug/$(NODE_EXE) $@
|
||||
|
||||
@ -20,6 +22,8 @@ index 94eb419..a2b682b 100644
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
config.gypi: configure
|
||||
if [ -f $@ ]; then
|
||||
$(error Stale $@, please re-run ./configure)
|
||||
--
|
||||
2.5.0
|
||||
2.7.3
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 58c110a74377171587a6ef28a6d5dff1f29a7d52 Mon Sep 17 00:00:00 2001
|
||||
From e51cf2ad2627af02e88df48287fe510e885ba1dc Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 Dec 2015 16:29:07 -0500
|
||||
Subject: [PATCH 2/2] Do not bundle CA Certificates
|
||||
@ -17,15 +17,20 @@ correct path for Fedora
|
||||
|
||||
Modified 2015-12-01 by Stephen Gallagher <sgallagh@redhat.com> to update for
|
||||
Node.js 4.2
|
||||
|
||||
Modified 2016-03-04 by Stephen Gallagher <sgallagh@redhat.com> to update for
|
||||
Node.js 5.4.1
|
||||
---
|
||||
src/node_crypto.cc | 31 ++++++++-----------------------
|
||||
1 file changed, 8 insertions(+), 23 deletions(-)
|
||||
src/node_crypto.cc | 28 ++++++++--------------------
|
||||
1 file changed, 8 insertions(+), 20 deletions(-)
|
||||
|
||||
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
|
||||
index 7911ce9..60516ad 100644
|
||||
index 382a42f22727f878b9bf55459e0e3835ac885159..ee90a0fbce017a5af56e10f3f416f86bd27a9d66 100644
|
||||
--- a/src/node_crypto.cc
|
||||
+++ b/src/node_crypto.cc
|
||||
@@ -119,7 +119,7 @@ static X509_NAME *cnnic_ev_name =
|
||||
@@ -119,11 +119,11 @@ static X509_NAME *cnnic_ev_name =
|
||||
sizeof(CNNIC_EV_ROOT_CA_SUBJECT_DATA)-1);
|
||||
|
||||
static uv_mutex_t* locks;
|
||||
|
||||
const char* const root_certs[] = {
|
||||
@ -34,22 +39,23 @@ index 7911ce9..60516ad 100644
|
||||
};
|
||||
|
||||
X509_STORE* root_cert_store;
|
||||
@@ -763,32 +763,17 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
||||
|
||||
// Just to generate static methods
|
||||
@@ -756,33 +756,21 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
||||
(void) &clear_error_on_return; // Silence compiler warning.
|
||||
|
||||
CHECK_EQ(sc->ca_store_, nullptr);
|
||||
|
||||
if (!root_cert_store) {
|
||||
- root_cert_store = X509_STORE_new();
|
||||
-
|
||||
- for (size_t i = 0; i < ARRAY_SIZE(root_certs); i++) {
|
||||
- BIO* bp = NodeBIO::New();
|
||||
-
|
||||
- if (!BIO_write(bp, root_certs[i], strlen(root_certs[i]))) {
|
||||
- BIO_free_all(bp);
|
||||
- BIO* bp = NodeBIO::NewFixed(root_certs[i], strlen(root_certs[i]));
|
||||
- if (bp == nullptr) {
|
||||
- return;
|
||||
- }
|
||||
-
|
||||
- X509 *x509 = PEM_read_bio_X509(bp, nullptr, CryptoPemCallback, nullptr);
|
||||
-
|
||||
- if (x509 == nullptr) {
|
||||
- BIO_free_all(bp);
|
||||
- return;
|
||||
@ -74,6 +80,8 @@ index 7911ce9..60516ad 100644
|
||||
}
|
||||
|
||||
|
||||
void SecureContext::SetCiphers(const FunctionCallbackInfo<Value>& args) {
|
||||
SecureContext* sc = Unwrap<SecureContext>(args.Holder());
|
||||
--
|
||||
2.5.0
|
||||
2.7.3
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
||||
|
||||
# == Node.js Version ==
|
||||
%global nodejs_major 4
|
||||
%global nodejs_minor 3
|
||||
%global nodejs_minor 4
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
@ -84,6 +84,7 @@ Requires: ca-certificates
|
||||
#we need ABI virtual provides where SONAMEs aren't enough/not present so deps
|
||||
#break when binary compatibility is broken
|
||||
Provides: nodejs(abi) = %{nodejs_abi}
|
||||
Provides: nodejs(abi%{nodejs_major}) = %{nodejs_abi}
|
||||
Provides: nodejs(v8-abi) = %{v8_abi}
|
||||
|
||||
#this corresponds to the "engine" requirement in package.json
|
||||
@ -208,7 +209,7 @@ mkdir -p %{buildroot}%{_prefix}/lib/node_modules
|
||||
install -Dpm0644 %{SOURCE7} %{buildroot}%{_rpmconfigdir}/fileattrs/nodejs_native.attr
|
||||
cat << EOF > %{buildroot}%{_rpmconfigdir}/nodejs_native.req
|
||||
#!/bin/sh
|
||||
echo 'nodejs(abi) = %nodejs_abi'
|
||||
echo 'nodejs(abi%{nodejs_major}) >= %nodejs_abi'
|
||||
echo 'nodejs(v8-abi) = %v8_abi'
|
||||
EOF
|
||||
chmod 0755 %{buildroot}%{_rpmconfigdir}/nodejs_native.req
|
||||
@ -264,6 +265,10 @@ mv %{buildroot}/%{_datadir}/doc/node/gdbinit %{buildroot}/%{_pkgdocdir}/gdbinit
|
||||
%{_pkgdocdir}/html
|
||||
|
||||
%changelog
|
||||
* Wed Mar 23 2016 Stephen Gallagher <sgallagh@redhat.com> - 4.4.1-1
|
||||
- Update to 4.4.1 upstream LTS release
|
||||
- Add more versatile ABI checking
|
||||
|
||||
* Tue Feb 23 2016 Tom Hughes <tom@compton.nu> - 4.3.1-1
|
||||
- Update to 4.3.1 upstream LTS release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user