Merge branch 'master' into epel7
This commit is contained in:
commit
1ef8904a34
1
.gitignore
vendored
1
.gitignore
vendored
@ -64,3 +64,4 @@
|
||||
/node-v6.9.4-stripped.tar.gz
|
||||
/node-v6.9.5-stripped.tar.gz
|
||||
/node-v6.10.0-stripped.tar.gz
|
||||
/node-v6.10.1-stripped.tar.gz
|
||||
|
25
0001-Disable-running-gyp-files-for-bundled-deps.patch
Normal file
25
0001-Disable-running-gyp-files-for-bundled-deps.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 54cb96f338bd162dcf1301b7d7a46eea2a56befb Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Wed, 22 Mar 2017 19:13:10 +0100
|
||||
Subject: [PATCH] Disable running gyp files for bundled deps
|
||||
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index a2b64e63b4..7b0847d1d5 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -77,7 +77,7 @@ $(NODE_G_EXE): config.gypi out/Makefile
|
||||
$(MAKE) -C out BUILDTYPE=Debug V=$(V)
|
||||
if [ ! -r $@ -o ! -L $@ ]; then ln -fs out/Debug/$(NODE_EXE) $@; fi
|
||||
|
||||
-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
|
||||
+out/Makefile: common.gypi deps/v8/build/toolchain.gypi deps/v8/build/features.gypi deps/v8/tools/gyp/v8.gyp node.gyp config.gypi
|
||||
$(PYTHON) tools/gyp_node.py -f make
|
||||
|
||||
config.gypi: configure
|
||||
--
|
||||
2.12.0
|
||||
|
15
nodejs.spec
15
nodejs.spec
@ -1,4 +1,4 @@
|
||||
%global with_debug 0
|
||||
%global with_debug 1
|
||||
|
||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
@ -16,7 +16,7 @@
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 6
|
||||
%global nodejs_minor 10
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 1
|
||||
@ -26,7 +26,7 @@
|
||||
%global v8_major 5
|
||||
%global v8_minor 1
|
||||
%global v8_build 281
|
||||
%global v8_patch 93
|
||||
%global v8_patch 95
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -92,7 +92,7 @@ Source100: %{name}-tarball.sh
|
||||
Source7: nodejs_native.attr
|
||||
|
||||
# Disable running gyp on bundled deps we don't use
|
||||
Patch1: 0001-disable-running-gyp-files-for-bundled-deps.patch
|
||||
Patch1: 0001-Disable-running-gyp-files-for-bundled-deps.patch
|
||||
|
||||
# EPEL only has OpenSSL 1.0.1, so we need to carry a patch on that platform
|
||||
Patch2: 0002-Use-openssl-1.0.1.patch
|
||||
@ -240,7 +240,8 @@ The API documentation for the Node.js JavaScript runtime.
|
||||
|
||||
# remove bundled dependencies that we aren't building
|
||||
%patch1 -p1
|
||||
rm -rf deps/uv \
|
||||
rm -rf deps/icu-small \
|
||||
deps/uv \
|
||||
deps/zlib
|
||||
|
||||
# Use system CA certificates
|
||||
@ -411,6 +412,10 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Wed Mar 22 2017 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:6.10.1-1
|
||||
- Update to 6.10.1
|
||||
- remove small-icu from deps
|
||||
|
||||
* Thu Mar 09 2017 Stephen Gallagher <sgallagh@redhat.com> - 1:6.10.0-1
|
||||
- Update to 6.10.0
|
||||
- https://nodejs.org/en/blog/release/v6.10.0/
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v6.10.0-stripped.tar.gz) = 2da288352df3113d59e882aeb7007a956c4ae7d3fa74262f9492dd789c6c299ff299a355b9a55f999ed3e4e78dd3d7ad4e55fece5e93b9e9ef82da8e670d562e
|
||||
SHA512 (node-v6.10.1-stripped.tar.gz) = 365de1f96cb380fbc1a4693edcd5c2c1e48a2ab75378d741614f20ffc9f611e532b9af7273924af773339d852c2873fa77436d30a28580221e8eae8a785e6ce8
|
||||
|
Loading…
Reference in New Issue
Block a user