Update to 6.3.0
This commit is contained in:
parent
a51d9b439e
commit
1bf1b27726
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@
|
|||||||
/node-v6.2.0-stripped.tar.gz
|
/node-v6.2.0-stripped.tar.gz
|
||||||
/node-v6.2.1-stripped.tar.gz
|
/node-v6.2.1-stripped.tar.gz
|
||||||
/node-v6.2.2-stripped.tar.gz
|
/node-v6.2.2-stripped.tar.gz
|
||||||
|
/node-v6.3.0-stripped.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From e0aac817a87c927f70a6f8edb63a4103a4109dfc Mon Sep 17 00:00:00 2001
|
From e51cf2ad2627af02e88df48287fe510e885ba1dc Mon Sep 17 00:00:00 2001
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
Date: Tue, 1 Dec 2015 16:29:07 -0500
|
Date: Tue, 1 Dec 2015 16:29:07 -0500
|
||||||
Subject: [PATCH 2/2] Do not bundle CA Certificates
|
Subject: [PATCH 2/2] Do not bundle CA Certificates
|
||||||
@ -9,7 +9,7 @@ Content-Transfer-Encoding: 8bit
|
|||||||
CA Certificates are provided by Fedora.
|
CA Certificates are provided by Fedora.
|
||||||
|
|
||||||
Forwarded: need some feedback before submitting the matter upstream
|
Forwarded: need some feedback before submitting the matter upstream
|
||||||
Author: Jérémy Lal <kapouer@melix.org>
|
Author: J?r?my Lal <kapouer@melix.org>
|
||||||
Last-Update: 2014-03-02
|
Last-Update: 2014-03-02
|
||||||
|
|
||||||
Modified 2014-05-02 by T.C. Hollingsworth <tchollingsworth@gmail.com> with the
|
Modified 2014-05-02 by T.C. Hollingsworth <tchollingsworth@gmail.com> with the
|
||||||
@ -23,13 +23,14 @@ Node.js 5.7.1
|
|||||||
|
|
||||||
Modified 2016-04-25 by Joseph Wang <joequant@gmail.com> to update for
|
Modified 2016-04-25 by Joseph Wang <joequant@gmail.com> to update for
|
||||||
Node.js 5.11.0
|
Node.js 5.11.0
|
||||||
---
|
|
||||||
diff --git a/src/node_crypto.cc b/src/node_crypto.cc
|
Modified 2016-07-10 by Zuzana Svetlikova <zsvetlik@redhat.com> to update for
|
||||||
index 989110c..a55b69d 100644
|
Node.js 6.3.0
|
||||||
--- a/src/node_crypto.cc
|
|
||||||
+++ b/src/node_crypto.cc
|
--- node/src/node_crypto.cc 2016-07-10 19:03:17.184502913 +0200
|
||||||
@@ -121,7 +121,7 @@ static X509_NAME *cnnic_ev_name =
|
+++ node_crypto.cc 2016-07-10 18:56:28.956440528 +0200
|
||||||
static uv_mutex_t* locks;
|
@@ -118,7 +118,7 @@
|
||||||
|
static Mutex* mutexes;
|
||||||
|
|
||||||
const char* const root_certs[] = {
|
const char* const root_certs[] = {
|
||||||
-#include "node_root_certs.h" // NOLINT(build/include_order)
|
-#include "node_root_certs.h" // NOLINT(build/include_order)
|
||||||
@ -37,7 +38,7 @@ index 989110c..a55b69d 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
X509_STORE* root_cert_store;
|
X509_STORE* root_cert_store;
|
||||||
@@ -750,29 +750,17 @@ void SecureContext::AddRootCerts(const FunctionCallbackInfo<Value>& args) {
|
@@ -752,29 +752,17 @@
|
||||||
CHECK_EQ(sc->ca_store_, nullptr);
|
CHECK_EQ(sc->ca_store_, nullptr);
|
||||||
|
|
||||||
if (!root_cert_store) {
|
if (!root_cert_store) {
|
||||||
@ -74,7 +75,3 @@ index 989110c..a55b69d 100644
|
|||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
--
|
|
||||||
2.7.2
|
|
||||||
|
|
||||||
|
22
nodejs.spec
22
nodejs.spec
@ -12,8 +12,8 @@
|
|||||||
# feature releases that are only supported for nine months, which is shorter
|
# feature releases that are only supported for nine months, which is shorter
|
||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_major 6
|
%global nodejs_major 6
|
||||||
%global nodejs_minor 2
|
%global nodejs_minor 3
|
||||||
%global nodejs_patch 2
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||||
|
|
||||||
@ -41,15 +41,15 @@
|
|||||||
|
|
||||||
# punycode - from lib/punycode.js
|
# punycode - from lib/punycode.js
|
||||||
# Note: this was merged into the mainline since 0.6.x
|
# Note: this was merged into the mainline since 0.6.x
|
||||||
%global punycode_major 1
|
%global punycode_major 2
|
||||||
%global punycode_minor 3
|
%global punycode_minor 0
|
||||||
%global punycode_patch 2
|
%global punycode_patch 0
|
||||||
%global punycode_version %{punycode_major}.%{punycode_minor}.%{punycode_patch}
|
%global punycode_version %{punycode_major}.%{punycode_minor}.%{punycode_patch}
|
||||||
|
|
||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_major 3
|
%global npm_major 3
|
||||||
%global npm_minor 9
|
%global npm_minor 10
|
||||||
%global npm_patch 5
|
%global npm_patch 3
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
# Filter out the NPM bundled dependencies so we aren't providing them
|
# Filter out the NPM bundled dependencies so we aren't providing them
|
||||||
@ -91,6 +91,8 @@ BuildRequires: python-devel
|
|||||||
BuildRequires: libuv-devel >= 1.9.0
|
BuildRequires: libuv-devel >= 1.9.0
|
||||||
Requires: libuv >= 1.9.0
|
Requires: libuv >= 1.9.0
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: gcc >= 4.8.0
|
||||||
|
BuildRequires: gcc-c++ >= 4.8.0
|
||||||
# Node.js requires some features from openssl 1.0.1 for SPDY support
|
# Node.js requires some features from openssl 1.0.1 for SPDY support
|
||||||
BuildRequires: openssl-devel >= 1:1.0.2
|
BuildRequires: openssl-devel >= 1:1.0.2
|
||||||
|
|
||||||
@ -338,6 +340,12 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules %{buildroot}/%{_bindir}/node -
|
|||||||
%{_pkgdocdir}/npm/doc
|
%{_pkgdocdir}/npm/doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 10 2016 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:6.3.0-1
|
||||||
|
- Update node to 6.3.0
|
||||||
|
- update punycode to 2.0.0
|
||||||
|
- add gcc and gcc-c++ as build dependencies
|
||||||
|
- modified system-certs patch
|
||||||
|
|
||||||
* Sat Jun 18 2016 Tom Hughes <tom@compton.nu> - 1:6.2.2-1
|
* Sat Jun 18 2016 Tom Hughes <tom@compton.nu> - 1:6.2.2-1
|
||||||
- Update to latest stable release 6.2.2
|
- Update to latest stable release 6.2.2
|
||||||
- Add check on npm version
|
- Add check on npm version
|
||||||
|
Loading…
Reference in New Issue
Block a user