Update to 12.3.1

https://nodejs.org/en/blog/release/v12.3.1/
https://nodejs.org/en/blog/release/v12.3.0/

Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
Stephen Gallagher 2019-05-25 09:07:39 -04:00
parent 61ea09b3c2
commit 11b4e1cf84
No known key found for this signature in database
GPG Key ID: 7A25556236BAA3A3
5 changed files with 17 additions and 12 deletions

View File

@ -1,4 +1,4 @@
From 716c544b0272c89458ed168f3459f873be2f3035 Mon Sep 17 00:00:00 2001 From f03434acfdb20c85a8e075d71e8b51417dca316a Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com> From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Thu, 27 Apr 2017 14:25:42 +0200 Date: Thu, 27 Apr 2017 14:25:42 +0200
Subject: [PATCH 1/3] Disable running gyp on shared deps Subject: [PATCH 1/3] Disable running gyp on shared deps
@ -8,10 +8,10 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index d41bf1601fb5990ae70e0e13fb105677ef8f9b86..4d9b363c7c0eeb83f34cedf2266e939d4ad140e7 100644 index 5834df883b0c232d2c9187f20e61f35dff4f6cef..ba3cacad0382dc17c4a911ea0c0bb39ced96c650 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -114,11 +114,11 @@ with-code-cache: @@ -139,11 +139,11 @@ with-code-cache:
.PHONY: test-code-cache .PHONY: test-code-cache
test-code-cache: with-code-cache test-code-cache: with-code-cache
echo "'test-code-cache' target is a noop" echo "'test-code-cache' target is a noop"

View File

@ -1,4 +1,4 @@
From f60c5f106a993adee0f66e44f70a1fee562108e0 Mon Sep 17 00:00:00 2001 From a7e02e98e41a9f6d20aea653368080ae2a2970c7 Mon Sep 17 00:00:00 2001
From: Stephen Gallagher <sgallagh@redhat.com> From: Stephen Gallagher <sgallagh@redhat.com>
Date: Tue, 1 May 2018 08:05:30 -0400 Date: Tue, 1 May 2018 08:05:30 -0400
Subject: [PATCH 2/3] Suppress NPM message to run global update Subject: [PATCH 2/3] Suppress NPM message to run global update

View File

@ -1,4 +1,4 @@
From 6be87e48c3b907dfb4c75b7f415b5107189799f0 Mon Sep 17 00:00:00 2001 From e690915a96b568f6550563491a346aacd8b717a5 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com> From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 19 Mar 2019 23:22:40 -0400 Date: Tue, 19 Mar 2019 23:22:40 -0400
Subject: [PATCH 3/3] Install both binaries and use libdir. Subject: [PATCH 3/3] Install both binaries and use libdir.
@ -13,7 +13,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
2 files changed, 20 insertions(+), 16 deletions(-) 2 files changed, 20 insertions(+), 16 deletions(-)
diff --git a/configure.py b/configure.py diff --git a/configure.py b/configure.py
index 1dd6da6d2b997a3fea602c7ad4ab6ce4197bfc18..b0ae741588fa91cb4a0f6bd483ae0c6469cbc114 100755 index 15ea5687cf1cd8e4ebe449ea2fc39eea95fb29b6..a738e300d6098bef4975930422b3fa55b3f5421d 100755
--- a/configure.py --- a/configure.py
+++ b/configure.py +++ b/configure.py
@@ -534,10 +534,16 @@ parser.add_option('--shared', @@ -534,10 +534,16 @@ parser.add_option('--shared',

View File

@ -12,8 +12,8 @@
# than a Fedora release lifecycle. # than a Fedora release lifecycle.
%global nodejs_epoch 1 %global nodejs_epoch 1
%global nodejs_major 12 %global nodejs_major 12
%global nodejs_minor 2 %global nodejs_minor 3
%global nodejs_patch 0 %global nodejs_patch 1
%global nodejs_abi %{nodejs_major}.%{nodejs_minor} %global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h # nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
%global nodejs_soversion 72 %global nodejs_soversion 72
@ -27,7 +27,7 @@
%global v8_major 7 %global v8_major 7
%global v8_minor 4 %global v8_minor 4
%global v8_build 288 %global v8_build 288
%global v8_patch 21 %global v8_patch 27
# V8 presently breaks ABI at least every x.y release while never bumping SONAME # V8 presently breaks ABI at least every x.y release while never bumping SONAME
%global v8_abi %{v8_major}.%{v8_minor} %global v8_abi %{v8_major}.%{v8_minor}
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch} %global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
@ -53,8 +53,8 @@
# libuv - from deps/uv/include/uv/version.h # libuv - from deps/uv/include/uv/version.h
%global libuv_major 1 %global libuv_major 1
%global libuv_minor 28 %global libuv_minor 29
%global libuv_patch 0 %global libuv_patch 1
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch} %global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h # nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
@ -578,6 +578,11 @@ end
%{_pkgdocdir}/npm/doc %{_pkgdocdir}/npm/doc
%changelog %changelog
* Fri May 24 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.3.1-1
- Update to 12.3.1
- https://nodejs.org/en/blog/release/v12.3.1/
- https://nodejs.org/en/blog/release/v12.3.0/
* Wed May 15 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.2.0-1 * Wed May 15 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.2.0-1
- Update to 12.2.0 - Update to 12.2.0
- https://nodejs.org/en/blog/release/v12.2.0/ - https://nodejs.org/en/blog/release/v12.2.0/

View File

@ -1 +1 @@
SHA512 (node-v12.2.0-stripped.tar.gz) = 668b7777e7c369c5eafb741bf9414ede1f30417cec69d82ec3539af0aff42315ece98e84a183044750802d5cf9283498d5783459fb316741a6aedf6f2a1b4f31 SHA512 (node-v12.3.1-stripped.tar.gz) = 405b498b81aa9e8e2d9e6da7b8784a30691abed070b2a1bc333b312dac70488e30d87a1b914a4a63cc50b7d7786794fa4327aa236a6d4f2808ee639f2bf5555a