Merge branch '10'
This commit is contained in:
commit
115810f425
87
0001-Install-both-binaries-and-use-libdir.patch
Normal file
87
0001-Install-both-binaries-and-use-libdir.patch
Normal file
@ -0,0 +1,87 @@
|
||||
From c38964d69ebb93e2273eca4bdcc4370fa26926f8 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH] Install both binaries and use libdir.
|
||||
|
||||
This allows us to build with a shared library for other users while
|
||||
still providing the normal executable.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
configure.py | 7 +++++++
|
||||
tools/install.py | 31 ++++++++++++++-----------------
|
||||
2 files changed, 21 insertions(+), 17 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index b62be2302c..0924fa96dc 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -552,6 +552,12 @@ parser.add_option('--shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
'(This mode is not officially supported for regular applications)')
|
||||
|
||||
+parser.add_option('--libdir',
|
||||
+ action='store',
|
||||
+ dest='libdir',
|
||||
+ default='lib',
|
||||
+ help='a directory to install the shared library into')
|
||||
+
|
||||
parser.add_option('--without-v8-platform',
|
||||
action='store_true',
|
||||
dest='without_v8_platform',
|
||||
@@ -1094,6 +1100,7 @@ def configure_node(o):
|
||||
if options.code_cache_path:
|
||||
o['variables']['node_code_cache_path'] = options.code_cache_path
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
+ o['variables']['libdir'] = options.libdir
|
||||
node_module_version = getmoduleversion.get_version()
|
||||
|
||||
if sys.platform == 'darwin':
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index ce9ceeee1d..5ac67b714e 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -116,26 +116,23 @@ def subdir_files(path, dest, action):
|
||||
|
||||
def files(action):
|
||||
is_windows = sys.platform == 'win32'
|
||||
- output_file = 'node'
|
||||
output_prefix = 'out/Release/'
|
||||
+ output_libprefix = output_prefix
|
||||
|
||||
- if 'false' == variables.get('node_shared'):
|
||||
- if is_windows:
|
||||
- output_file += '.exe'
|
||||
+ if is_windows:
|
||||
+ output_bin = 'node.exe'
|
||||
+ output_lib = 'node.dll'
|
||||
else:
|
||||
- if is_windows:
|
||||
- output_file += '.dll'
|
||||
- else:
|
||||
- output_file = 'lib' + output_file + '.' + variables.get('shlib_suffix')
|
||||
- # GYP will output to lib.target except on OS X, this is hardcoded
|
||||
- # in its source - see the _InstallableTargetInstallPath function.
|
||||
- if sys.platform != 'darwin':
|
||||
- output_prefix += 'lib.target/'
|
||||
-
|
||||
- if 'false' == variables.get('node_shared'):
|
||||
- action([output_prefix + output_file], 'bin/' + output_file)
|
||||
- else:
|
||||
- action([output_prefix + output_file], 'lib/' + output_file)
|
||||
+ output_bin = 'node'
|
||||
+ output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||
+ # GYP will output to lib.target except on OS X, this is hardcoded
|
||||
+ # in its source - see the _InstallableTargetInstallPath function.
|
||||
+ if sys.platform != 'darwin':
|
||||
+ output_libprefix += 'lib.target/'
|
||||
+
|
||||
+ action([output_prefix + output_bin], 'bin/' + output_bin)
|
||||
+ if 'true' == variables.get('node_shared'):
|
||||
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||
|
||||
if 'true' == variables.get('node_use_dtrace'):
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
--
|
||||
2.20.1
|
||||
|
109
nodejs.spec
109
nodejs.spec
@ -1,5 +1,3 @@
|
||||
%global with_debug 1
|
||||
|
||||
# bundle dependencies that are not available as Fedora modules
|
||||
# %%{!?_with_bootstrap: %%global bootstrap 1}
|
||||
# use bcond for building modules
|
||||
@ -17,11 +15,14 @@
|
||||
%global nodejs_minor 15
|
||||
%global nodejs_patch 2
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
%global nodejs_soversion 64
|
||||
%global nodejs_version %{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}
|
||||
%global nodejs_release 1
|
||||
%global nodejs_release 3
|
||||
|
||||
# == Bundled Dependency Versions ==
|
||||
# v8 - from deps/v8/include/v8-version.h
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 1
|
||||
%global v8_major 6
|
||||
%global v8_minor 8
|
||||
%global v8_build 275
|
||||
@ -122,11 +123,15 @@ Patch2: 0002-Suppress-NPM-message-to-run-global-update.patch
|
||||
# Upstream patch to fix debug generation on PowerPC
|
||||
Patch3: 0003-deps-V8-cherry-pick-d0468de.patch
|
||||
|
||||
# Patch to install both node and libnode.so, using the correct libdir
|
||||
Patch5: 0001-Install-both-binaries-and-use-libdir.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: gcc >= 4.9.4
|
||||
BuildRequires: gcc-c++ >= 4.9.4
|
||||
BuildRequires: chrpath
|
||||
|
||||
#%if ! 0%%{?bootstrap}
|
||||
%if %{with bootstrap}
|
||||
@ -154,6 +159,9 @@ BuildRequires: openssl-devel
|
||||
# we need the system certificate store
|
||||
Requires: ca-certificates
|
||||
|
||||
Requires: nodejs-libs%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
||||
|
||||
|
||||
#we need ABI virtual provides where SONAMEs aren't enough/not present so deps
|
||||
#break when binary compatibility is broken
|
||||
Provides: nodejs(abi) = %{nodejs_abi}
|
||||
@ -234,6 +242,36 @@ Requires: libuv-devel%{?_isa}
|
||||
%description devel
|
||||
Development headers for the Node.js JavaScript runtime.
|
||||
|
||||
%package libs
|
||||
Summary: Node.js and v8 libraries
|
||||
|
||||
# Compatibility for obsolete v8 package
|
||||
%if 0%{?__isa_bits} == 64
|
||||
Provides: libv8.so.%{v8_major}()(64bit)
|
||||
Provides: libv8_libbase.so.%{v8_major}()(64bit)
|
||||
Provides: libv8_libplatform.so.%{v8_major}()(64bit)
|
||||
%else # 32-bits
|
||||
Provides: libv8.so.%{v8_major}
|
||||
Provides: libv8_libbase.so.%{v8_major}
|
||||
Provides: libv8_libplatform.so.%{v8_major}
|
||||
%endif
|
||||
|
||||
Provides: v8 = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
||||
Provides: v8%{?_isa} = %{v8_epoch}:%{v8_version}-%{nodejs_release}%{?dist}
|
||||
Obsoletes: v8 < 1:6.7.17-10
|
||||
|
||||
%description libs
|
||||
Libraries to support Node.js and provide stable v8 interfaces.
|
||||
|
||||
%package -n v8-devel
|
||||
Summary: v8 - development headers
|
||||
Epoch: %{v8_epoch}
|
||||
Version: %{v8_version}
|
||||
Requires: %{name}-devel%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}
|
||||
|
||||
%description -n v8-devel
|
||||
Development headers for the v8 runtime.
|
||||
|
||||
%package -n npm
|
||||
Summary: Node.js Package Manager
|
||||
Epoch: %{npm_epoch}
|
||||
@ -311,6 +349,8 @@ export LDFLAGS="%{build_ldflags}"
|
||||
#%if ! 0%%{?bootstrap}
|
||||
%if %{with bootstrap}
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared \
|
||||
--libdir=%{_lib} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--without-dtrace \
|
||||
@ -319,6 +359,8 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--openssl-use-def-ca-store
|
||||
%else
|
||||
./configure --prefix=%{_prefix} \
|
||||
--shared \
|
||||
--libdir=%{_lib} \
|
||||
--shared-openssl \
|
||||
--shared-zlib \
|
||||
--shared-libuv \
|
||||
@ -330,12 +372,7 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--openssl-use-def-ca-store
|
||||
%endif
|
||||
|
||||
%if %{?with_debug} == 1
|
||||
# Setting BUILDTYPE=Debug builds both release and debug binaries
|
||||
make BUILDTYPE=Debug %{?_smp_mflags}
|
||||
%else
|
||||
make BUILDTYPE=Release %{?_smp_mflags}
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
@ -345,11 +382,20 @@ rm -rf %{buildroot}
|
||||
|
||||
# Set the binary permissions properly
|
||||
chmod 0755 %{buildroot}/%{_bindir}/node
|
||||
chrpath --delete %{buildroot}%{_bindir}/node
|
||||
|
||||
%if %{?with_debug} == 1
|
||||
# Install the debug binary and set its permissions
|
||||
install -Dpm0755 out/Debug/node %{buildroot}/%{_bindir}/node_g
|
||||
%endif
|
||||
# Install library symlink
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/libnode.so
|
||||
|
||||
# Install v8 compatibility symlinks
|
||||
for header in %{buildroot}%{_includedir}/node/libplatform %{buildroot}%{_includedir}/node/v8*.h; do
|
||||
header=$(basename ${header})
|
||||
ln -s %{_includedir}/node/${header} %{buildroot}%{_includedir}/${header}
|
||||
done
|
||||
for soname in libv8 libv8_libbase libv8_libplatform; do
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/${soname}.so
|
||||
ln -s %{_libdir}/libnode.so.%{nodejs_soversion} %{buildroot}%{_libdir}/${soname}.so.%{v8_major}
|
||||
done
|
||||
|
||||
# own the sitelib directory
|
||||
mkdir -p %{buildroot}%{_prefix}/lib/node_modules
|
||||
@ -414,15 +460,15 @@ chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin
|
||||
|
||||
%check
|
||||
# Fail the build if the versions don't match
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
||||
%{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.node, '%{nodejs_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.v8.replace(/-node\.\d+$/, ''), '%{v8_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require('assert').equal(process.versions.ares.replace(/-DEV$/, ''), '%{c_ares_version}')"
|
||||
|
||||
# Ensure we have punycode and that the version matches
|
||||
%{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||
LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"punycode\").version, '%{punycode_version}')"
|
||||
|
||||
# Ensure we have npm and that the version matches
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/node_modules/npm/node_modules LD_LIBRARY_PATH=%{buildroot}%{_libdir} %{buildroot}/%{_bindir}/node -e "require(\"assert\").equal(require(\"npm\").version, '%{npm_version}')"
|
||||
|
||||
|
||||
%pretrans -n npm -p <lua>
|
||||
@ -464,14 +510,27 @@ end
|
||||
|
||||
|
||||
%files devel
|
||||
%if %{?with_debug} == 1
|
||||
%{_bindir}/node_g
|
||||
%endif
|
||||
%{_includedir}/node
|
||||
%{_libdir}/libnode.so
|
||||
%{_datadir}/node/common.gypi
|
||||
%{_pkgdocdir}/gdbinit
|
||||
|
||||
|
||||
%files libs
|
||||
%{_libdir}/libnode.so.%{nodejs_soversion}
|
||||
%{_libdir}/libv8.so.%{v8_major}
|
||||
%{_libdir}/libv8_libbase.so.%{v8_major}
|
||||
%{_libdir}/libv8_libplatform.so.%{v8_major}
|
||||
|
||||
|
||||
%files -n v8-devel
|
||||
%{_includedir}/libplatform
|
||||
%{_includedir}/v8*.h
|
||||
%{_libdir}/libv8.so
|
||||
%{_libdir}/libv8_libbase.so
|
||||
%{_libdir}/libv8_libplatform.so
|
||||
|
||||
|
||||
%files -n npm
|
||||
%{_bindir}/npm
|
||||
%{_bindir}/npx
|
||||
@ -493,6 +552,16 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Tue Apr 09 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.2-3
|
||||
- Separate nodejs-libs out to its own subpackage
|
||||
- Clean up compatibility virtual Provides
|
||||
- Set epoch for v8-devel to maintain upgrade path
|
||||
|
||||
* Sun Mar 17 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1:10.15.2-2
|
||||
- Drop debug executable
|
||||
- Build with a shared library
|
||||
- Add v8 compatibility subpackage
|
||||
|
||||
* Fri Mar 01 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:10.15.2-1
|
||||
- Update to 10.15.2
|
||||
- https://nodejs.org/en/blog/release/v10.15.1/
|
||||
|
Loading…
Reference in New Issue
Block a user