56 lines
1.7 KiB
Diff
56 lines
1.7 KiB
Diff
From 142fe30256f96e28b49f55d5c72e604719aaaad8 Mon Sep 17 00:00:00 2001
|
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
|
Subject: [PATCH] Disable running gyp on shared deps
|
|
|
|
Signed-off-by: rpm-build <rpm-build>
|
|
---
|
|
Makefile | 2 +-
|
|
node.gyp | 17 -----------------
|
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 4aace77..0bad864 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
|
|
$(warning '$@' target is a noop)
|
|
|
|
out/Makefile: config.gypi common.gypi node.gyp \
|
|
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
|
+ deps/llhttp/llhttp.gyp \
|
|
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
$(PYTHON) tools/gyp_node.py -f make
|
|
diff --git a/node.gyp b/node.gyp
|
|
index 86fe9a6..bfa5093 100644
|
|
--- a/node.gyp
|
|
+++ b/node.gyp
|
|
@@ -449,23 +449,6 @@
|
|
],
|
|
},
|
|
],
|
|
- }, {
|
|
- 'variables': {
|
|
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
- 'opensslconfig': './deps/openssl/openssl/apps/openssl.cnf',
|
|
- },
|
|
- 'actions': [
|
|
- {
|
|
- 'action_name': 'reset_openssl_cnf',
|
|
- 'inputs': [ '<(opensslconfig)', ],
|
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
|
- 'action': [
|
|
- 'python', 'tools/copyfile.py',
|
|
- './deps/openssl/openssl/apps/openssl.cnf',
|
|
- '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
- ],
|
|
- },
|
|
- ],
|
|
}],
|
|
],
|
|
}, # node_core_target_name
|
|
--
|
|
2.36.1
|
|
|