56 lines
1.6 KiB
Diff
56 lines
1.6 KiB
Diff
From c73e0892eb1d0aa2df805618c019dc5c96b79705 Mon Sep 17 00:00:00 2001
|
|
From: rpm-build <rpm-build>
|
|
Date: Tue, 30 May 2023 13:12:35 +0200
|
|
Subject: [PATCH] Disable running gyp on shared deps
|
|
|
|
Signed-off-by: rpm-build <rpm-build>
|
|
---
|
|
Makefile | 2 +-
|
|
node.gyp | 17 -----------------
|
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 0be0659..3c44201 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -169,7 +169,7 @@ with-code-cache test-code-cache:
|
|
$(warning '$@' target is a noop)
|
|
|
|
out/Makefile: config.gypi common.gypi node.gyp \
|
|
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
|
+ deps/llhttp/llhttp.gyp \
|
|
deps/simdutf/simdutf.gyp deps/ada/ada.gyp \
|
|
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
|
diff --git a/node.gyp b/node.gyp
|
|
index cf52281..c33b57b 100644
|
|
--- a/node.gyp
|
|
+++ b/node.gyp
|
|
@@ -430,23 +430,6 @@
|
|
],
|
|
},
|
|
],
|
|
- }, {
|
|
- 'variables': {
|
|
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
|
- 'opensslconfig': './deps/openssl/nodejs-openssl.cnf',
|
|
- },
|
|
- 'actions': [
|
|
- {
|
|
- 'action_name': 'reset_openssl_cnf',
|
|
- 'inputs': [ '<(opensslconfig)', ],
|
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
|
- 'action': [
|
|
- '<(python)', 'tools/copyfile.py',
|
|
- '<(opensslconfig)',
|
|
- '<(opensslconfig_internal)',
|
|
- ],
|
|
- },
|
|
- ],
|
|
}],
|
|
],
|
|
}, # node_core_target_name
|
|
--
|
|
2.41.0
|
|
|