import nodejs-18.12.1-2.module+el8.7.0+17306+fc023f99
This commit is contained in:
parent
25d6a59673
commit
c22ef8a4bb
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,2 +1,6 @@
|
|||||||
|
SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
||||||
SOURCES/icu4c-71_1-src.tgz
|
SOURCES/icu4c-71_1-src.tgz
|
||||||
SOURCES/node-v18.6.0-stripped.tar.gz
|
SOURCES/node-v18.12.1-stripped.tar.gz
|
||||||
|
SOURCES/undici-5.11.0.tar.gz
|
||||||
|
SOURCES/wasi-sdk-wasi-sdk-11.tar.gz
|
||||||
|
SOURCES/wasi-sdk-wasi-sdk-14.tar.gz
|
||||||
|
@ -1,2 +1,6 @@
|
|||||||
|
6976e77068429bd0b47b573793289e065ceb6b27 SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
||||||
406b0c8635288b772913b6ff646451e69748878a SOURCES/icu4c-71_1-src.tgz
|
406b0c8635288b772913b6ff646451e69748878a SOURCES/icu4c-71_1-src.tgz
|
||||||
a82035bca2c75dd8321015463bd73996a0842a1c SOURCES/node-v18.6.0-stripped.tar.gz
|
816c2656eea956f3fcd0d98562d7d225abd3e95f SOURCES/node-v18.12.1-stripped.tar.gz
|
||||||
|
0ea4e5cfe13969896bf41c0d2d029a621917b944 SOURCES/undici-5.11.0.tar.gz
|
||||||
|
8979d177dd62e3b167a6fd7dc7185adb0128c439 SOURCES/wasi-sdk-wasi-sdk-11.tar.gz
|
||||||
|
900a50a32f0079d53c299db92b88bb3c5d2022b8 SOURCES/wasi-sdk-wasi-sdk-14.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From fe1e9d3f6d87416aa4cd8f8bee186d71a8ea2b0f Mon Sep 17 00:00:00 2001
|
From 2abb9e98751595936ac1c867b3f08695f5bcf22c Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
Subject: [PATCH] Disable running gyp on shared deps
|
Subject: [PATCH] Disable running gyp on shared deps
|
||||||
@ -10,10 +10,10 @@ Signed-off-by: rpm-build <rpm-build>
|
|||||||
2 files changed, 1 insertion(+), 18 deletions(-)
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index e0d756f..c90bfa7 100644
|
index 9c01f8f..133a3d0 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
|
@@ -148,7 +148,7 @@ with-code-cache test-code-cache:
|
||||||
$(warning '$@' target is a noop)
|
$(warning '$@' target is a noop)
|
||||||
|
|
||||||
out/Makefile: config.gypi common.gypi node.gyp \
|
out/Makefile: config.gypi common.gypi node.gyp \
|
||||||
@ -23,7 +23,7 @@ index e0d756f..c90bfa7 100644
|
|||||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||||
$(PYTHON) tools/gyp_node.py -f make
|
$(PYTHON) tools/gyp_node.py -f make
|
||||||
diff --git a/node.gyp b/node.gyp
|
diff --git a/node.gyp b/node.gyp
|
||||||
index 6b3a6d9..5882cef 100644
|
index 8f131ac..dce5fdc 100644
|
||||||
--- a/node.gyp
|
--- a/node.gyp
|
||||||
+++ b/node.gyp
|
+++ b/node.gyp
|
||||||
@@ -429,23 +429,6 @@
|
@@ -429,23 +429,6 @@
|
||||||
@ -51,5 +51,5 @@ index 6b3a6d9..5882cef 100644
|
|||||||
],
|
],
|
||||||
}, # node_core_target_name
|
}, # node_core_target_name
|
||||||
--
|
--
|
||||||
2.36.1
|
2.37.3
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@
|
|||||||
# This is used by both the nodejs package and the npm subpackage that
|
# This is used by both the nodejs package and the npm subpackage that
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 1
|
%global baserelease 2
|
||||||
|
|
||||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -41,8 +41,8 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 18
|
%global nodejs_major 18
|
||||||
%global nodejs_minor 6
|
%global nodejs_minor 12
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 1
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
%global nodejs_soversion 108
|
%global nodejs_soversion 108
|
||||||
@ -58,7 +58,7 @@
|
|||||||
%global v8_major 10
|
%global v8_major 10
|
||||||
%global v8_minor 2
|
%global v8_minor 2
|
||||||
%global v8_build 154
|
%global v8_build 154
|
||||||
%global v8_patch 13
|
%global v8_patch 15
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||||
%global v8_abi %{v8_major}.%{v8_minor}
|
%global v8_abi %{v8_major}.%{v8_minor}
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
@ -74,7 +74,7 @@
|
|||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
%global llhttp_major 6
|
%global llhttp_major 6
|
||||||
%global llhttp_minor 0
|
%global llhttp_minor 0
|
||||||
%global llhttp_patch 7
|
%global llhttp_patch 10
|
||||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
@ -91,14 +91,14 @@
|
|||||||
|
|
||||||
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
||||||
%global nghttp3_major 0
|
%global nghttp3_major 0
|
||||||
%global nghttp3_minor 1
|
%global nghttp3_minor 7
|
||||||
%global nghttp3_patch 0-DEV
|
%global nghttp3_patch 0
|
||||||
%global nghttp3_version %{nghttp3_major}.%{nghttp3_minor}.%{nghttp3_patch}
|
%global nghttp3_version %{nghttp3_major}.%{nghttp3_minor}.%{nghttp3_patch}
|
||||||
|
|
||||||
# ngtcp2 from deps/ngtcp2/ngtcp2/lib/includes/ngtcp2/version.h
|
# ngtcp2 from deps/ngtcp2/ngtcp2/lib/includes/ngtcp2/version.h
|
||||||
%global ngtcp2_major 0
|
%global ngtcp2_major 0
|
||||||
%global ngtcp2_minor 1
|
%global ngtcp2_minor 8
|
||||||
%global ngtcp2_patch 0-DEV
|
%global ngtcp2_patch 1
|
||||||
%global ngtcp2_version %{ngtcp2_major}.%{ngtcp2_minor}.%{ngtcp2_patch}
|
%global ngtcp2_version %{ngtcp2_major}.%{ngtcp2_minor}.%{ngtcp2_patch}
|
||||||
|
|
||||||
# ICU - from tools/icu/current_ver.dep
|
# ICU - from tools/icu/current_ver.dep
|
||||||
@ -134,20 +134,20 @@
|
|||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_major 8
|
%global npm_major 8
|
||||||
%global npm_minor 13
|
%global npm_minor 19
|
||||||
%global npm_patch 2
|
%global npm_patch 2
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||||
%global uvwasi_major 0
|
%global uvwasi_major 0
|
||||||
%global uvwasi_minor 0
|
%global uvwasi_minor 0
|
||||||
%global uvwasi_patch 12
|
%global uvwasi_patch 13
|
||||||
%global uvwasi_version %{uvwasi_major}.%{uvwasi_minor}.%{uvwasi_patch}
|
%global uvwasi_version %{uvwasi_major}.%{uvwasi_minor}.%{uvwasi_patch}
|
||||||
|
|
||||||
# histogram_c - assumed from timestamps
|
# histogram_c - assumed from timestamps
|
||||||
%global histogram_major 0
|
%global histogram_major 0
|
||||||
%global histogram_minor 9
|
%global histogram_minor 11
|
||||||
%global histogram_patch 7
|
%global histogram_patch 2
|
||||||
%global histogram_version %{histogram_major}.%{histogram_minor}.%{histogram_patch}
|
%global histogram_version %{histogram_major}.%{histogram_minor}.%{histogram_patch}
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
@ -184,6 +184,26 @@ Source100: %{name}-tarball.sh
|
|||||||
# nodejs-packaging SRPM.
|
# nodejs-packaging SRPM.
|
||||||
Source7: nodejs_native.attr
|
Source7: nodejs_native.attr
|
||||||
|
|
||||||
|
# These are full sources for dependencies included as WASM blobs in the source of Node itself.
|
||||||
|
# Note: These sources would also include pre-compiled WASM blobs… so they are adjusted not to.
|
||||||
|
# Recipes for creating these blobs are included in the sources.
|
||||||
|
|
||||||
|
# Version: jq '.version' deps/cjs-module-lexer/package.json
|
||||||
|
# Original: https://github.com/nodejs/cjs-module-lexer/archive/refs/tags/1.2.2.tar.gz
|
||||||
|
# Adjustments: rm -f cjs-module-lexer-1.2.2/lib/lexer.wasm
|
||||||
|
Source101: cjs-module-lexer-1.2.2.tar.gz
|
||||||
|
# The WASM blob was made using wasi-sdk v11; compiler libraries are linked in.
|
||||||
|
# Version source: Makefile
|
||||||
|
Source102: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-11/wasi-sdk-wasi-sdk-11.tar.gz
|
||||||
|
|
||||||
|
# Version: jq '.version' deps/undici/src/package.json
|
||||||
|
# Original: https://github.com/nodejs/undici/archive/refs/tags/v5.11.0.tar.gz
|
||||||
|
# Adjustments: rm -f undici-5.11.0/lib/llhttp/llhttp*.wasm*
|
||||||
|
Source111: undici-5.11.0.tar.gz
|
||||||
|
# The WASM blob was made using wasi-sdk v14; compiler libraries are linked in.
|
||||||
|
# Version source: build/Dockerfile
|
||||||
|
Source112: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-14/wasi-sdk-wasi-sdk-14.tar.gz
|
||||||
|
|
||||||
# Disable running gyp on bundled deps we don't use
|
# Disable running gyp on bundled deps we don't use
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||||
|
|
||||||
@ -674,6 +694,7 @@ end
|
|||||||
%doc %{_mandir}/man5/package-lock-json.5*
|
%doc %{_mandir}/man5/package-lock-json.5*
|
||||||
%doc %{_mandir}/man5/npm-shrinkwrap-json.5*
|
%doc %{_mandir}/man5/npm-shrinkwrap-json.5*
|
||||||
%doc %{_mandir}/man7/config.7*
|
%doc %{_mandir}/man7/config.7*
|
||||||
|
%doc %{_mandir}/man7/dependency-selectors.7*
|
||||||
%doc %{_mandir}/man7/developers.7*
|
%doc %{_mandir}/man7/developers.7*
|
||||||
%doc %{_mandir}/man7/logging.7*
|
%doc %{_mandir}/man7/logging.7*
|
||||||
%doc %{_mandir}/man7/orgs.7*
|
%doc %{_mandir}/man7/orgs.7*
|
||||||
@ -693,6 +714,21 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 18 2022 Jan Staněk <jstanek@redhat.com> - 1:18.12.1-2
|
||||||
|
- Update version of bundled histogram
|
||||||
|
|
||||||
|
* Wed Nov 09 2022 Jan Staněk <jstanek@redhat.com> - 1:18.12.1-1
|
||||||
|
- Rebase to version 18.12.1
|
||||||
|
Resolves: rhbz#2125580 CVE-2022-43548 CVE-2022-3517
|
||||||
|
|
||||||
|
* Tue Sep 27 2022 Jan Staněk <jstanek@redhat.com> - 1:18.9.1-1
|
||||||
|
- Rebase to version 18.9.1
|
||||||
|
Resolves: CVE-2022-35255 CVE-2022-35256
|
||||||
|
|
||||||
|
* Fri Aug 26 2022 Jan Staněk <jstanek@redhat.com> - 1:18.8.0-1
|
||||||
|
- Rebase to version 18.8.0
|
||||||
|
- Include sources for WASM blobs
|
||||||
|
|
||||||
* Fri Jul 15 2022 Jan Staněk <jstanek@redhat.com> - 1:18.6.0-1
|
* Fri Jul 15 2022 Jan Staněk <jstanek@redhat.com> - 1:18.6.0-1
|
||||||
- Rebase to version 18.6.0
|
- Rebase to version 18.6.0
|
||||||
Resolves: CVE-2022-32212 CVE-2022-32213 CVE-2022-32214 CVE-2022-32215
|
Resolves: CVE-2022-32212 CVE-2022-32213 CVE-2022-32214 CVE-2022-32215
|
||||||
|
Loading…
Reference in New Issue
Block a user