Replace whole repo with latest content from branch stream-10-rhel-8.8.0
Content corresponds with RHEL dist-git commit 95a5d3a Related: #2211032
This commit is contained in:
parent
9fc5351c8c
commit
a03b9825a0
10
.gitignore
vendored
10
.gitignore
vendored
@ -1,4 +1,10 @@
|
||||
SOURCES/icu4c-64_2-src.tgz
|
||||
SOURCES/node-v10.23.1-stripped.tar.gz
|
||||
/node-v10.7.0-stripped.tar.gz
|
||||
/node-v10.11.0-stripped.tar.gz
|
||||
/node-v10.14.1-stripped.tar.gz
|
||||
/node-v10.16.3-stripped.tar.gz
|
||||
/node-v10.19.0-stripped.tar.gz
|
||||
/node-v10.21.0-stripped.tar.gz
|
||||
/icu4c-64_2-src.tgz
|
||||
/node-v10.22.1-stripped.tar.gz
|
||||
/node-v10.23.1-stripped.tar.gz
|
||||
/node-v10.24.0-stripped.tar.gz
|
||||
|
@ -1,72 +0,0 @@
|
||||
From e2ff0fc92ddbaa5535d684e353c55cefe99eb081 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Tue, 27 Sep 2022 13:48:12 +0200
|
||||
Subject: [PATCH] Install both binaries and use libdir
|
||||
|
||||
Signed-off-by: rpm-build <rpm-build>
|
||||
---
|
||||
configure.py | 7 +++++++
|
||||
tools/install.py | 8 +++++---
|
||||
2 files changed, 12 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index 1a7023d..b16db0c 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -739,6 +739,12 @@ parser.add_argument('--shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
'(This mode is not officially supported for regular applications)')
|
||||
|
||||
+parser.add_argument('--libdir',
|
||||
+ action='store',
|
||||
+ dest='libdir',
|
||||
+ default='lib',
|
||||
+ help='a directory to install the shared library into')
|
||||
+
|
||||
parser.add_argument('--without-v8-platform',
|
||||
action='store_true',
|
||||
dest='without_v8_platform',
|
||||
@@ -1368,6 +1374,7 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
|
||||
o['variables']['node_shared'] = b(options.shared)
|
||||
+ o['variables']['libdir'] = options.libdir
|
||||
node_module_version = getmoduleversion.get_version()
|
||||
|
||||
if options.dest_os == 'android':
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index a6d1f8b..e3ef9d7 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -144,6 +144,7 @@ def files(action):
|
||||
is_windows = sys.platform == 'win32'
|
||||
output_file = 'node'
|
||||
output_prefix = 'out/Release/'
|
||||
+ output_libprefix = output_prefix
|
||||
|
||||
if is_windows:
|
||||
output_file += '.exe'
|
||||
@@ -151,8 +152,8 @@ def files(action):
|
||||
|
||||
if 'true' == variables.get('node_shared'):
|
||||
if is_windows:
|
||||
- action([output_prefix + 'libnode.dll'], 'bin/libnode.dll')
|
||||
- action([output_prefix + 'libnode.lib'], 'lib/libnode.lib')
|
||||
+ action([output_libprefix + 'libnode.dll'], 'bin/libnode.dll')
|
||||
+ action([output_libprefix + 'libnode.lib'], 'lib/libnode.lib')
|
||||
elif sys.platform == 'zos':
|
||||
# GYP will output to lib.target; see _InstallableTargetInstallPath
|
||||
# function in tools/gyp/pylib/gyp/generator/make.py
|
||||
@@ -176,7 +177,8 @@ def files(action):
|
||||
try_symlink(so_name, link_path)
|
||||
else:
|
||||
output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||
- action([output_prefix + output_lib], 'lib/' + output_lib)
|
||||
+ action([output_libprefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||
+
|
||||
if 'true' == variables.get('node_use_dtrace'):
|
||||
action(['out/Release/node.d'], 'lib/dtrace/node.d')
|
||||
|
||||
--
|
||||
2.37.3
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 9872b897d6a9a39e3392c39bca70cfd9dd084558 Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Mon, 26 Sep 2022 16:02:39 +0200
|
||||
Subject: [PATCH] install: keep installing dtrace and systemtap files
|
||||
|
||||
Partly reverts commit e27e709d3ca93b3e7036ddc4f4d28dfde228bfb6.
|
||||
|
||||
Signed-off-by: rpm-build <rpm-build>
|
||||
---
|
||||
tools/install.py | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/tools/install.py b/tools/install.py
|
||||
index 4b01d67..dc16797 100755
|
||||
--- a/tools/install.py
|
||||
+++ b/tools/install.py
|
||||
@@ -178,6 +178,11 @@ def files(action):
|
||||
output_lib = 'libnode.' + variables.get('shlib_suffix')
|
||||
action([output_prefix + output_lib], variables.get('libdir') + '/' + output_lib)
|
||||
|
||||
+ if 'true' == variables.get('node_use_dtrace'):
|
||||
+ action(['out/Release/node.d'], variables.get('libdir') + '/dtrace/node.d')
|
||||
+
|
||||
+ action(['src/node.stp'], 'share/systemtap/tapset/')
|
||||
+
|
||||
action(['deps/v8/tools/gdbinit'], 'share/doc/node/')
|
||||
action(['deps/v8/tools/lldb_commands.py'], 'share/doc/node/')
|
||||
|
||||
--
|
||||
2.37.3
|
||||
|
@ -1,6 +0,0 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: baseos-ci.brew-build.tier1.functional}
|
24
nodejs.spec
24
nodejs.spec
@ -24,8 +24,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 10
|
||||
%global nodejs_minor 23
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 24
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 64
|
||||
@ -94,7 +94,7 @@
|
||||
%global npm_epoch 1
|
||||
%global npm_major 6
|
||||
%global npm_minor 14
|
||||
%global npm_patch 10
|
||||
%global npm_patch 11
|
||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||
|
||||
# In order to avoid needing to keep incrementing the release version for the
|
||||
@ -149,9 +149,7 @@ Patch3: 0003-build-auto-load-ICU-data-from-with-icu-default-data-.patch
|
||||
# CVE-2020-7774
|
||||
Patch4: 0004-CVE-2020-7774-nodejs-y18n-prototype-pollution-vulnerability.patch
|
||||
|
||||
# CVE-2020-7788
|
||||
Patch5: 0005-CVE-2020-7788-ini-do-not-allow-invalid-hazardous-string.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -369,7 +367,6 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--shared-zlib \
|
||||
--without-dtrace \
|
||||
--with-intl=small-icu \
|
||||
--debug-nghttp2 \
|
||||
--openssl-use-def-ca-store
|
||||
%else
|
||||
./configure --prefix=%{_prefix} \
|
||||
@ -381,7 +378,6 @@ export LDFLAGS="%{build_ldflags}"
|
||||
--with-dtrace \
|
||||
--with-intl=small-icu \
|
||||
--with-icu-default-data-dir=%{icudatadir} \
|
||||
--debug-nghttp2 \
|
||||
--openssl-use-def-ca-store
|
||||
%endif
|
||||
|
||||
@ -625,13 +621,19 @@ end
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Feb 24 2021 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:10.24.0-1
|
||||
- Resolves: RHBZ#1934597, RHBZ#1934566
|
||||
- Resolves CVE-2021-22883 and CVE-2021-22884
|
||||
- remove -debug-nghttp2 flag
|
||||
- remove ini patch merged upstream
|
||||
|
||||
* Mon Jan 18 2021 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:10.23.1-1
|
||||
- January Security release
|
||||
- https://nodejs.org/en/blog/vulnerability/january-2021-security-releases/
|
||||
- Rebase to 10.23.1
|
||||
- Resolves: RHBZ#1916461, RHBZ#1914789
|
||||
- Resolves: RHBZ#1914783, RHBZ#1916462, RHBZ#1916395, RHBZ#1916459
|
||||
- Resolves: RHBZ#1916691, RHBZ#1916689, RHBZ#1916388
|
||||
- Resolves: RHBZ#1912999, RHBZ#1912954
|
||||
- Resolves: RHBZ#1912634, RHBZ#1878543, RHBZ#1898764, RHBZ#1893983
|
||||
- Resolves: RHBZ#1857054, RHBZ#1861601, RHBZ#1875686
|
||||
- Remove dot-prop patch, as it is fixed by npm rebase
|
||||
|
||||
* Tue Sep 22 2020 Jan Staněk <jstanek@redhat.com> - 1:10.22.1-1
|
||||
|
@ -1,2 +0,0 @@
|
||||
[koji]
|
||||
targets = master f34 f33
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (node-v10.24.0-stripped.tar.gz) = c6106f16c6a91fcc0b36d733f23f5e6535c7fe215422c9ffae2542e0e572d07e32887053c94249c021f39135dbf828daf9fb19c2d0e7ee3aead8105d1212550e
|
||||
SHA512 (icu4c-64_2-src.tgz) = 5ecb4c230ba45918747a1cf9aef86f555aa07d5b29b1d07ab674e8013f46dfb907a0e9d6945db41155f9dc3012fd94e1152ffc19f61a68b6dfcbabdcb8ae9d78
|
||||
SHA512 (node-v10.23.1-stripped.tar.gz) = 264f2af0b2d930fb6043cb1c1144affb64485f0cf1fc766cad2ec929f4375b1efbe8c48c1be5c21b15c6060ef28f6850a7aa9ba21511943067ab637acb2e0046
|
||||
|
Loading…
Reference in New Issue
Block a user