Rebase to version 18.16.1
This commit is contained in:
parent
38537ff576
commit
7b6fda4224
2
.gitignore
vendored
2
.gitignore
vendored
@ -43,3 +43,5 @@
|
|||||||
/undici-5.20.0.tar.gz
|
/undici-5.20.0.tar.gz
|
||||||
/wasi-sdk-wasi-sdk-11.tar.gz
|
/wasi-sdk-wasi-sdk-11.tar.gz
|
||||||
/wasi-sdk-wasi-sdk-14.tar.gz
|
/wasi-sdk-wasi-sdk-14.tar.gz
|
||||||
|
/node-v18.16.1-stripped.tar.gz
|
||||||
|
/undici-5.21.0.tar.gz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 030bbedf7d79025848122081e13fe94b0324ad88 Mon Sep 17 00:00:00 2001
|
From c73e0892eb1d0aa2df805618c019dc5c96b79705 Mon Sep 17 00:00:00 2001
|
||||||
From: rpm-build <rpm-build>
|
From: rpm-build <rpm-build>
|
||||||
Date: Tue, 30 May 2023 13:12:35 +0200
|
Date: Tue, 30 May 2023 13:12:35 +0200
|
||||||
Subject: [PATCH] Disable running gyp on shared deps
|
Subject: [PATCH] Disable running gyp on shared deps
|
||||||
@ -10,7 +10,7 @@ Signed-off-by: rpm-build <rpm-build>
|
|||||||
2 files changed, 1 insertion(+), 18 deletions(-)
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 9401346..c9d3da2 100644
|
index 0be0659..3c44201 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -169,7 +169,7 @@ with-code-cache test-code-cache:
|
@@ -169,7 +169,7 @@ with-code-cache test-code-cache:
|
||||||
@ -19,14 +19,14 @@ index 9401346..c9d3da2 100644
|
|||||||
out/Makefile: config.gypi common.gypi node.gyp \
|
out/Makefile: config.gypi common.gypi node.gyp \
|
||||||
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
||||||
+ deps/llhttp/llhttp.gyp \
|
+ deps/llhttp/llhttp.gyp \
|
||||||
deps/simdutf/simdutf.gyp \
|
deps/simdutf/simdutf.gyp deps/ada/ada.gyp \
|
||||||
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||||
diff --git a/node.gyp b/node.gyp
|
diff --git a/node.gyp b/node.gyp
|
||||||
index cec24ae..13af00f 100644
|
index cf52281..c33b57b 100644
|
||||||
--- a/node.gyp
|
--- a/node.gyp
|
||||||
+++ b/node.gyp
|
+++ b/node.gyp
|
||||||
@@ -429,23 +429,6 @@
|
@@ -430,23 +430,6 @@
|
||||||
],
|
],
|
||||||
},
|
},
|
||||||
],
|
],
|
||||||
@ -51,5 +51,5 @@ index cec24ae..13af00f 100644
|
|||||||
],
|
],
|
||||||
}, # node_core_target_name
|
}, # node_core_target_name
|
||||||
--
|
--
|
||||||
2.40.1
|
2.41.0
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
54
nodejs.spec
54
nodejs.spec
@ -29,7 +29,7 @@
|
|||||||
# This is used by both the nodejs package and the npm subpackage that
|
# This is used by both the nodejs package and the npm subpackage that
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 3
|
%global baserelease 1
|
||||||
|
|
||||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -40,8 +40,8 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 18
|
%global nodejs_major 18
|
||||||
%global nodejs_minor 14
|
%global nodejs_minor 16
|
||||||
%global nodejs_patch 2
|
%global nodejs_patch 1
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
%global nodejs_soversion 108
|
%global nodejs_soversion 108
|
||||||
@ -68,13 +68,13 @@
|
|||||||
%global c_ares_version 1.19.1
|
%global c_ares_version 1.19.1
|
||||||
|
|
||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
%global llhttp_version 6.0.10
|
%global llhttp_version 6.0.11
|
||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
%global libuv_version 1.44.2
|
%global libuv_version 1.44.2
|
||||||
|
|
||||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||||
%global nghttp2_version 1.51.0
|
%global nghttp2_version 1.52.0
|
||||||
|
|
||||||
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
||||||
%global nghttp3_major 0
|
%global nghttp3_major 0
|
||||||
@ -108,11 +108,14 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# simduft from deps/simdutf/simdutf.h
|
# simduft from deps/simdutf/simdutf.h
|
||||||
%global simduft_major 2
|
%global simduft_major 3
|
||||||
%global simduft_minor 0
|
%global simduft_minor 2
|
||||||
%global simduft_patch 7
|
%global simduft_patch 2
|
||||||
%global simduft_version %{simduft_major}.%{simduft_minor}.%{simduft_patch}
|
%global simduft_version %{simduft_major}.%{simduft_minor}.%{simduft_patch}
|
||||||
|
|
||||||
|
# ada from deps/ada/ada.h
|
||||||
|
%global ada_version 1.0.4
|
||||||
|
|
||||||
# OpenSSL minimum version
|
# OpenSSL minimum version
|
||||||
%global openssl_minimum 1:1.1.1
|
%global openssl_minimum 1:1.1.1
|
||||||
|
|
||||||
@ -123,7 +126,7 @@
|
|||||||
|
|
||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_version 9.5.0
|
%global npm_version 9.5.1
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
# main package forever, we will just construct one for npm that is guaranteed
|
# main package forever, we will just construct one for npm that is guaranteed
|
||||||
@ -132,7 +135,7 @@
|
|||||||
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||||
|
|
||||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||||
%global uvwasi_version 0.0.14
|
%global uvwasi_version 0.0.15
|
||||||
|
|
||||||
# histogram_c - assumed from timestamps
|
# histogram_c - assumed from timestamps
|
||||||
%global histogram_version 0.11.2
|
%global histogram_version 0.11.2
|
||||||
@ -175,16 +178,15 @@ Source101: cjs-module-lexer-1.2.2.tar.gz
|
|||||||
Source111: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-11/wasi-sdk-11.0-linux.tar.gz
|
Source111: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-11/wasi-sdk-11.0-linux.tar.gz
|
||||||
|
|
||||||
# Version: jq '.version' deps/undici/src/package.json
|
# Version: jq '.version' deps/undici/src/package.json
|
||||||
# Original: https://github.com/nodejs/undici/archive/refs/tags/v5.20.0.tar.gz
|
# Original: https://github.com/nodejs/undici/archive/refs/tags/v5.21.0.tar.gz
|
||||||
# Adjustments: rm -f undici-5.20.0/lib/llhttp/llhttp*.wasm
|
# Adjustments: rm -f undici-5.20.0/lib/llhttp/llhttp*.wasm
|
||||||
# wasi-sdk version can be found in Dockerfile
|
# wasi-sdk version can be found in Dockerfile
|
||||||
# https://github.com/nodejs/undici/blob/v5.8.2/build/Dockerfile
|
# https://github.com/nodejs/undici/blob/v5.21.0/build/Dockerfile
|
||||||
Source102: undici-5.20.0.tar.gz
|
Source102: undici-5.21.0.tar.gz
|
||||||
Source112: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-14/wasi-sdk-14.0-linux.tar.gz
|
Source112: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-14/wasi-sdk-14.0-linux.tar.gz
|
||||||
|
|
||||||
# Disable running gyp on bundled deps we don't use
|
# Disable running gyp on bundled deps we don't use
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||||
Patch2: 0002-deps-update-c-ares-to-1.19.1.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
@ -284,6 +286,7 @@ Provides: bundled(icu) = %{icu_version}
|
|||||||
Provides: bundled(uvwasi) = %{uvwasi_version}
|
Provides: bundled(uvwasi) = %{uvwasi_version}
|
||||||
Provides: bundled(histogram) = %{histogram_version}
|
Provides: bundled(histogram) = %{histogram_version}
|
||||||
Provides: bundled(simduft) = %{simduft_version}
|
Provides: bundled(simduft) = %{simduft_version}
|
||||||
|
Provides: bundled(ada) = %{ada_version}
|
||||||
|
|
||||||
# Make sure we keep NPM up to date when we update Node.js
|
# Make sure we keep NPM up to date when we update Node.js
|
||||||
Recommends: npm >= %{npm_epoch}:%{npm_version}-%{npm_release}%{?dist}
|
Recommends: npm >= %{npm_epoch}:%{npm_version}-%{npm_release}%{?dist}
|
||||||
@ -370,6 +373,22 @@ rm -rf deps/v8/third_party/jinja2
|
|||||||
rm -rf tools/inspector_protocol/jinja2
|
rm -rf tools/inspector_protocol/jinja2
|
||||||
|
|
||||||
# Replace any instances of unversioned python' with python3
|
# Replace any instances of unversioned python' with python3
|
||||||
|
# check for correct versions of dependencies we are bundling
|
||||||
|
check_wasm_dep() {
|
||||||
|
local -r name="$1" source="$2" packagejson="$3"
|
||||||
|
local -r expected_version="$(jq -r '.version' "${packagejson}")"
|
||||||
|
|
||||||
|
if ls "${source}"|grep -q --fixed-strings "${expected_version}"; then
|
||||||
|
printf '%s version matches\n' "${name}" >&2
|
||||||
|
else
|
||||||
|
printf '%s version MISMATCH: %s !~ %s\n' "${name}" "${expected_version}" "${source}" >&2
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
check_wasm_dep cjs-module-lexer '%{SOURCE101}' deps/cjs-module-lexer/package.json
|
||||||
|
check_wasm_dep undici '%{SOURCE102}' deps/undici/src/package.json
|
||||||
|
|
||||||
%if %{with python3_fixup}
|
%if %{with python3_fixup}
|
||||||
pathfix.py -i %{__python3} -pn $(find -type f ! -name "*.js")
|
pathfix.py -i %{__python3} -pn $(find -type f ! -name "*.js")
|
||||||
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python3~" {} \;
|
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python3~" {} \;
|
||||||
@ -556,7 +575,7 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/nod
|
|||||||
%{_rpmconfigdir}/fileattrs/nodejs_native.attr
|
%{_rpmconfigdir}/fileattrs/nodejs_native.attr
|
||||||
%{_rpmconfigdir}/nodejs_native.req
|
%{_rpmconfigdir}/nodejs_native.req
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%doc AUTHORS CHANGELOG.md onboarding.md GOVERNANCE.md README.md
|
%doc CHANGELOG.md onboarding.md GOVERNANCE.md README.md
|
||||||
%doc %{_mandir}/man1/node.1*
|
%doc %{_mandir}/man1/node.1*
|
||||||
|
|
||||||
|
|
||||||
@ -609,6 +628,11 @@ NODE_PATH=%{buildroot}%{_prefix}/lib/node_modules:%{buildroot}%{_prefix}/lib/nod
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 12 2023 Jan Staněk <jstanek@redhat.com> - 1:18.16.1-1
|
||||||
|
- Rebase to 18.16.1
|
||||||
|
Resolves: rhbz#2188292 rhbz#2187683
|
||||||
|
Resolves: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590
|
||||||
|
|
||||||
* Tue May 30 2023 Jan Staněk <jstanek@redhat.com> - 1:18.14.2-3
|
* Tue May 30 2023 Jan Staněk <jstanek@redhat.com> - 1:18.14.2-3
|
||||||
- Update bundled c-ares to 1.19.1
|
- Update bundled c-ares to 1.19.1
|
||||||
Resolves: CVE-2023-31124 CVE-2023-31130 CVE-2023-31147 CVE-2023-32067
|
Resolves: CVE-2023-31124 CVE-2023-31130 CVE-2023-31147 CVE-2023-32067
|
||||||
|
4
sources
4
sources
@ -1,6 +1,6 @@
|
|||||||
SHA512 (node-v18.14.2-stripped.tar.gz) = 54d0b463ee429d62ad81ab6da73ac0076c6f9af8a015b9c0c1bf33aa8dc1f32a105ec269e290390e3dfc4f22f454993f579d584541ba8bfcef5d90359345f8cd
|
SHA512 (node-v18.16.1-stripped.tar.gz) = 8548e92504760c8ea3b5d8bf1e745b7577668bd249786247fcbfeafd519c308b7f3974d6692cc98c124482a3e5d6867d4c6e2ad829ada4ec6b7b1b0114194911
|
||||||
SHA512 (icu4c-72_1-src.tgz) = 848c341b37c0ff077e34a95d92c6200d5aaddd0ee5e06134101a74e04deb08256a5e817c8aefab020986abe810b7827dd7b2169a60dacd250c298870518dcae8
|
SHA512 (icu4c-72_1-src.tgz) = 848c341b37c0ff077e34a95d92c6200d5aaddd0ee5e06134101a74e04deb08256a5e817c8aefab020986abe810b7827dd7b2169a60dacd250c298870518dcae8
|
||||||
SHA512 (undici-5.20.0.tar.gz) = 75a4c164081bbc8114aceeb48680db003cb014d7f92f157d03e9a36c775606a4bede5dbba236ba1722a651ab91968cb192eeae671ec1024f826c4b452d4e20ff
|
SHA512 (undici-5.21.0.tar.gz) = 69097b92f7aac8f47207e6e76074b2676ecee8ecbadf8c35e7295cdf550e881e32bce9f0123f612d7a1cb5e7a2c5de798550f5e097ac053e4257e61d025db7d8
|
||||||
SHA512 (cjs-module-lexer-1.2.2.tar.gz) = 2c8e9caf2231ca7d61e71936305389774859aca9b5c86c63489c9a62a81f4736f99477c3f0cbb41077bb7924fdd23e0f24b7bce858e42fb0f87e7c0ffc87afeb
|
SHA512 (cjs-module-lexer-1.2.2.tar.gz) = 2c8e9caf2231ca7d61e71936305389774859aca9b5c86c63489c9a62a81f4736f99477c3f0cbb41077bb7924fdd23e0f24b7bce858e42fb0f87e7c0ffc87afeb
|
||||||
SHA512 (wasi-sdk-11.0-linux.tar.gz) = e3ed4597f7f2290967eef6238e9046f60abbcb8633a4a2a51525d00e7393df8df637a98a5b668217d332dd44fcbf2442ec7efd5e65724e888d90611164451e20
|
SHA512 (wasi-sdk-11.0-linux.tar.gz) = e3ed4597f7f2290967eef6238e9046f60abbcb8633a4a2a51525d00e7393df8df637a98a5b668217d332dd44fcbf2442ec7efd5e65724e888d90611164451e20
|
||||||
SHA512 (wasi-sdk-14.0-linux.tar.gz) = 288a367e051f5b3f5853de97fabaedd3acf2255819d50c24f48f573897518500ea808342fd9aea832b2a5717089807bf1cbcf6d46b156b4eb60cc6b3c02ee997
|
SHA512 (wasi-sdk-14.0-linux.tar.gz) = 288a367e051f5b3f5853de97fabaedd3acf2255819d50c24f48f573897518500ea808342fd9aea832b2a5717089807bf1cbcf6d46b156b4eb60cc6b3c02ee997
|
||||||
|
Loading…
Reference in New Issue
Block a user