import CS nodejs-22.11.0-1.module_el9_5+1123+1f6cfb38
This commit is contained in:
parent
133b954d80
commit
6679bf8258
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
SOURCES/icu4c-64_2-src.tgz
|
SOURCES/icu4c-75_1-data-bin-b.zip
|
||||||
SOURCES/node-v10.24.0-stripped.tar.gz
|
SOURCES/icu4c-75_1-data-bin-l.zip
|
||||||
|
SOURCES/node-v22.11.0-stripped.tar.gz
|
||||||
|
@ -1,2 +1,3 @@
|
|||||||
3127155ecf2b75ab4835f501b7478e39c07bb852 SOURCES/icu4c-64_2-src.tgz
|
6c7291d88272d84fdadf1395166acd40dd12f623 SOURCES/icu4c-75_1-data-bin-b.zip
|
||||||
be0e0b385a852c376f452b3d94727492e05407e4 SOURCES/node-v10.24.0-stripped.tar.gz
|
ef164aa671780d004e304b4c789b05450e912304 SOURCES/icu4c-75_1-data-bin-l.zip
|
||||||
|
17c2b64411adb2127c23324dfceaf52c076e1ab8 SOURCES/node-v22.11.0-stripped.tar.gz
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 2cd4c12776af3da588231d3eb498e6451c30eae5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
|
||||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
|
||||||
Subject: [PATCH] Disable running gyp on shared deps
|
|
||||||
|
|
||||||
Signed-off-by: rpm-build <rpm-build>
|
|
||||||
---
|
|
||||||
Makefile | 7 +++----
|
|
||||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 73feb4c..45bbceb 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -123,10 +123,9 @@ with-code-cache:
|
|
||||||
test-code-cache: with-code-cache
|
|
||||||
$(PYTHON) tools/test.py $(PARALLEL_ARGS) --mode=$(BUILDTYPE_LOWER) code-cache
|
|
||||||
|
|
||||||
-out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
|
|
||||||
- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
|
|
||||||
- deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
|
|
||||||
- config.gypi
|
|
||||||
+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
|
|
||||||
+ deps/v8/gypfiles/toolchain.gypi deps/v8/gypfiles/features.gypi \
|
|
||||||
+ deps/v8/gypfiles/v8.gyp node.gyp config.gypi
|
|
||||||
$(PYTHON) tools/gyp_node.py -f make
|
|
||||||
|
|
||||||
config.gypi: configure configure.py
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
45
SOURCES/0001-Remove-unused-OpenSSL-config.patch
Normal file
45
SOURCES/0001-Remove-unused-OpenSSL-config.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
From 0aaaf4104a1f23f3de105ffdaffc282c4477bb0e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
||||||
|
Subject: [PATCH] Remove unused OpenSSL config
|
||||||
|
|
||||||
|
The build process will try to create these config files, even when
|
||||||
|
using the system OpenSSL and will thus fail since we strip this path
|
||||||
|
from the tarball.
|
||||||
|
|
||||||
|
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
|
---
|
||||||
|
node.gyp | 17 -----------------
|
||||||
|
1 file changed, 17 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/node.gyp b/node.gyp
|
||||||
|
index dc4d77330a811d3448d84318c065a3447b159906..e1824d462ec876a66146092aab4dba3d085f4658 100644
|
||||||
|
--- a/node.gyp
|
||||||
|
+++ b/node.gyp
|
||||||
|
@@ -808,23 +808,6 @@
|
||||||
|
],
|
||||||
|
},
|
||||||
|
],
|
||||||
|
- }, {
|
||||||
|
- 'variables': {
|
||||||
|
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
|
||||||
|
- 'opensslconfig': './deps/openssl/nodejs-openssl.cnf',
|
||||||
|
- },
|
||||||
|
- 'actions': [
|
||||||
|
- {
|
||||||
|
- 'action_name': 'reset_openssl_cnf',
|
||||||
|
- 'inputs': [ '<(opensslconfig)', ],
|
||||||
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
||||||
|
- 'action': [
|
||||||
|
- '<(python)', 'tools/copyfile.py',
|
||||||
|
- '<(opensslconfig)',
|
||||||
|
- '<(opensslconfig_internal)',
|
||||||
|
- ],
|
||||||
|
- },
|
||||||
|
- ],
|
||||||
|
}],
|
||||||
|
],
|
||||||
|
}, # node_core_target_name
|
||||||
|
--
|
||||||
|
2.44.0
|
||||||
|
|
@ -1,84 +0,0 @@
|
|||||||
From e7afb2d6e2a6c8f9c9c32e12a10c3c5c4902a251 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
|
||||||
Subject: [PATCH] Suppress NPM message to run global update
|
|
||||||
|
|
||||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Signed-off-by: rpm-build <rpm-build>
|
|
||||||
---
|
|
||||||
deps/npm/bin/npm-cli.js | 54 -----------------------------------------
|
|
||||||
1 file changed, 54 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
|
||||||
index c0d9be0..0f0892e 100755
|
|
||||||
--- a/deps/npm/bin/npm-cli.js
|
|
||||||
+++ b/deps/npm/bin/npm-cli.js
|
|
||||||
@@ -71,65 +71,11 @@
|
|
||||||
npm.command = 'help'
|
|
||||||
}
|
|
||||||
|
|
||||||
- var isGlobalNpmUpdate = conf.global && ['install', 'update'].includes(npm.command) && npm.argv.includes('npm')
|
|
||||||
-
|
|
||||||
// now actually fire up npm and run the command.
|
|
||||||
// this is how to use npm programmatically:
|
|
||||||
conf._exit = true
|
|
||||||
npm.load(conf, function (er) {
|
|
||||||
if (er) return errorHandler(er)
|
|
||||||
- if (
|
|
||||||
- !isGlobalNpmUpdate &&
|
|
||||||
- npm.config.get('update-notifier') &&
|
|
||||||
- !unsupported.checkVersion(process.version).unsupported
|
|
||||||
- ) {
|
|
||||||
- const pkg = require('../package.json')
|
|
||||||
- let notifier = require('update-notifier')({pkg})
|
|
||||||
- const isCI = require('ci-info').isCI
|
|
||||||
- if (
|
|
||||||
- notifier.update &&
|
|
||||||
- notifier.update.latest !== pkg.version &&
|
|
||||||
- !isCI
|
|
||||||
- ) {
|
|
||||||
- const color = require('ansicolors')
|
|
||||||
- const useColor = npm.config.get('color')
|
|
||||||
- const useUnicode = npm.config.get('unicode')
|
|
||||||
- const old = notifier.update.current
|
|
||||||
- const latest = notifier.update.latest
|
|
||||||
- let type = notifier.update.type
|
|
||||||
- if (useColor) {
|
|
||||||
- switch (type) {
|
|
||||||
- case 'major':
|
|
||||||
- type = color.red(type)
|
|
||||||
- break
|
|
||||||
- case 'minor':
|
|
||||||
- type = color.yellow(type)
|
|
||||||
- break
|
|
||||||
- case 'patch':
|
|
||||||
- type = color.green(type)
|
|
||||||
- break
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
- const changelog = `https://github.com/npm/cli/releases/tag/v${latest}`
|
|
||||||
- notifier.notify({
|
|
||||||
- message: `New ${type} version of ${pkg.name} available! ${
|
|
||||||
- useColor ? color.red(old) : old
|
|
||||||
- } ${useUnicode ? '→' : '->'} ${
|
|
||||||
- useColor ? color.green(latest) : latest
|
|
||||||
- }\n` +
|
|
||||||
- `${
|
|
||||||
- useColor ? color.yellow('Changelog:') : 'Changelog:'
|
|
||||||
- } ${
|
|
||||||
- useColor ? color.cyan(changelog) : changelog
|
|
||||||
- }\n` +
|
|
||||||
- `Run ${
|
|
||||||
- useColor
|
|
||||||
- ? color.green(`npm install -g ${pkg.name}`)
|
|
||||||
- : `npm i -g ${pkg.name}`
|
|
||||||
- } to update!`
|
|
||||||
- })
|
|
||||||
- }
|
|
||||||
- }
|
|
||||||
npm.commands[npm.command](npm.argv, function (err) {
|
|
||||||
// https://genius.com/Lin-manuel-miranda-your-obedient-servant-lyrics
|
|
||||||
if (
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
25
SOURCES/0002-deps-ncrypto-include-openssl-rand.h.patch
Normal file
25
SOURCES/0002-deps-ncrypto-include-openssl-rand.h.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From e79552fdbebb411b8a6f7bc323525f463c1ee7ad Mon Sep 17 00:00:00 2001
|
||||||
|
From: rpm-build <rpm-build>
|
||||||
|
Date: Wed, 30 Oct 2024 15:48:59 +0100
|
||||||
|
Subject: [PATCH] deps(ncrypto): include <openssl/rand.h>
|
||||||
|
|
||||||
|
Signed-off-by: rpm-build <rpm-build>
|
||||||
|
---
|
||||||
|
deps/ncrypto/ncrypto.cc | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/deps/ncrypto/ncrypto.cc b/deps/ncrypto/ncrypto.cc
|
||||||
|
index 457bd2f..a38b4a2 100644
|
||||||
|
--- a/deps/ncrypto/ncrypto.cc
|
||||||
|
+++ b/deps/ncrypto/ncrypto.cc
|
||||||
|
@@ -5,6 +5,7 @@
|
||||||
|
#include <openssl/bn.h>
|
||||||
|
#include <openssl/evp.h>
|
||||||
|
#include <openssl/hmac.h>
|
||||||
|
+#include <openssl/rand.h>
|
||||||
|
#include <openssl/pkcs12.h>
|
||||||
|
#include <openssl/x509v3.h>
|
||||||
|
#if OPENSSL_VERSION_MAJOR >= 3
|
||||||
|
--
|
||||||
|
2.47.0
|
||||||
|
|
@ -1,122 +0,0 @@
|
|||||||
From 0028cc74dac4dd24b8599ade85cb49fdafa9f559 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Date: Fri, 6 Dec 2019 16:40:25 -0500
|
|
||||||
Subject: [PATCH] build: auto-load ICU data from --with-icu-default-data-dir
|
|
||||||
|
|
||||||
When compiled with `--with-intl=small` and
|
|
||||||
`--with-icu-default-data-dir=PATH`, Node.js will use PATH as a
|
|
||||||
fallback location for the ICU data.
|
|
||||||
|
|
||||||
We will first perform an access check using fopen(PATH, 'r') to
|
|
||||||
ensure that the file is readable. If it is, we'll set the
|
|
||||||
icu_data_directory and proceed. There's a slight overhead for the
|
|
||||||
fopen() check, but it should be barely measurable.
|
|
||||||
|
|
||||||
This will be useful for Linux distribution packagers who want to
|
|
||||||
be able to ship a minimal node binary in a container image but
|
|
||||||
also be able to add on the full i18n support where needed. With
|
|
||||||
this patch, it becomes possible to ship the interpreter as
|
|
||||||
/usr/bin/node in one package for the distribution and to ship the
|
|
||||||
data files in another package (without a strict dependency
|
|
||||||
between the two). This means that users of the distribution will
|
|
||||||
not need to explicitly direct Node.js to locate the ICU data. It
|
|
||||||
also means that in environments where full internationalization is
|
|
||||||
not required, they do not need to carry the extra content (with
|
|
||||||
the associated storage costs).
|
|
||||||
|
|
||||||
Refs: https://github.com/nodejs/node/issues/3460
|
|
||||||
|
|
||||||
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|
||||||
Signed-off-by: rpm-build <rpm-build>
|
|
||||||
---
|
|
||||||
configure.py | 9 +++++++++
|
|
||||||
node.gypi | 7 +++++++
|
|
||||||
src/node.cc | 20 ++++++++++++++++++++
|
|
||||||
3 files changed, 36 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
|
||||||
index 89f7bf5..d611a88 100755
|
|
||||||
--- a/configure.py
|
|
||||||
+++ b/configure.py
|
|
||||||
@@ -433,6 +433,14 @@ intl_optgroup.add_option('--with-icu-source',
|
|
||||||
'the icu4c source archive. '
|
|
||||||
'v%d.x or later recommended.' % icu_versions['minimum_icu'])
|
|
||||||
|
|
||||||
+intl_optgroup.add_option('--with-icu-default-data-dir',
|
|
||||||
+ action='store',
|
|
||||||
+ dest='with_icu_default_data_dir',
|
|
||||||
+ help='Path to the icuXXdt{lb}.dat file. If unspecified, ICU data will '
|
|
||||||
+ 'only be read if the NODE_ICU_DATA environment variable or the '
|
|
||||||
+ '--icu-data-dir runtime argument is used. This option has effect '
|
|
||||||
+ 'only when Node.js is built with --with-intl=small-icu.')
|
|
||||||
+
|
|
||||||
parser.add_option('--with-ltcg',
|
|
||||||
action='store_true',
|
|
||||||
dest='with_ltcg',
|
|
||||||
@@ -1359,6 +1367,7 @@ def configure_intl(o):
|
|
||||||
locs.add('root') # must have root
|
|
||||||
o['variables']['icu_locales'] = string.join(locs,',')
|
|
||||||
# We will check a bit later if we can use the canned deps/icu-small
|
|
||||||
+ o['variables']['icu_default_data'] = options.with_icu_default_data_dir or ''
|
|
||||||
elif with_intl == 'full-icu':
|
|
||||||
# full ICU
|
|
||||||
o['variables']['v8_enable_i18n_support'] = 1
|
|
||||||
diff --git a/node.gypi b/node.gypi
|
|
||||||
index 466a174..65b97d6 100644
|
|
||||||
--- a/node.gypi
|
|
||||||
+++ b/node.gypi
|
|
||||||
@@ -113,6 +113,13 @@
|
|
||||||
'conditions': [
|
|
||||||
[ 'icu_small=="true"', {
|
|
||||||
'defines': [ 'NODE_HAVE_SMALL_ICU=1' ],
|
|
||||||
+ 'conditions': [
|
|
||||||
+ [ 'icu_default_data!=""', {
|
|
||||||
+ 'defines': [
|
|
||||||
+ 'NODE_ICU_DEFAULT_DATA_DIR="<(icu_default_data)"',
|
|
||||||
+ ],
|
|
||||||
+ }],
|
|
||||||
+ ],
|
|
||||||
}]],
|
|
||||||
}],
|
|
||||||
[ 'node_use_bundled_v8=="true" and \
|
|
||||||
diff --git a/src/node.cc b/src/node.cc
|
|
||||||
index 7c01187..c9840e3 100644
|
|
||||||
--- a/src/node.cc
|
|
||||||
+++ b/src/node.cc
|
|
||||||
@@ -92,6 +92,7 @@
|
|
||||||
|
|
||||||
#if defined(NODE_HAVE_I18N_SUPPORT)
|
|
||||||
#include <unicode/uvernum.h>
|
|
||||||
+#include <unicode/utypes.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(LEAK_SANITIZER)
|
|
||||||
@@ -2643,6 +2644,25 @@ void Init(std::vector<std::string>* argv,
|
|
||||||
// If the parameter isn't given, use the env variable.
|
|
||||||
if (per_process_opts->icu_data_dir.empty())
|
|
||||||
SafeGetenv("NODE_ICU_DATA", &per_process_opts->icu_data_dir);
|
|
||||||
+
|
|
||||||
+#ifdef NODE_ICU_DEFAULT_DATA_DIR
|
|
||||||
+ // If neither the CLI option nor the environment variable was specified,
|
|
||||||
+ // fall back to the configured default
|
|
||||||
+ if (per_process_opts->icu_data_dir.empty()) {
|
|
||||||
+ // Check whether the NODE_ICU_DEFAULT_DATA_DIR contains the right data
|
|
||||||
+ // file and can be read.
|
|
||||||
+ static const char full_path[] =
|
|
||||||
+ NODE_ICU_DEFAULT_DATA_DIR "/" U_ICUDATA_NAME ".dat";
|
|
||||||
+
|
|
||||||
+ FILE* f = fopen(full_path, "rb");
|
|
||||||
+
|
|
||||||
+ if (f != nullptr) {
|
|
||||||
+ fclose(f);
|
|
||||||
+ per_process_opts->icu_data_dir = NODE_ICU_DEFAULT_DATA_DIR;
|
|
||||||
+ }
|
|
||||||
+ }
|
|
||||||
+#endif // NODE_ICU_DEFAULT_DATA_DIR
|
|
||||||
+
|
|
||||||
// Initialize ICU.
|
|
||||||
// If icu_data_dir is empty here, it will load the 'minimal' data.
|
|
||||||
if (!i18n::InitializeICUDirectory(per_process_opts->icu_data_dir)) {
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/deps/npm/node_modules/y18n/index.js b/deps/npm/node_modules/y18n/index.js
|
|
||||||
index d720681628..727362aac0 100644
|
|
||||||
--- a/deps/npm/node_modules/y18n/index.js
|
|
||||||
+++ b/deps/npm/node_modules/y18n/index.js
|
|
||||||
@@ -11,7 +11,7 @@ function Y18N (opts) {
|
|
||||||
this.fallbackToLanguage = typeof opts.fallbackToLanguage === 'boolean' ? opts.fallbackToLanguage : true
|
|
||||||
|
|
||||||
// internal stuff.
|
|
||||||
- this.cache = {}
|
|
||||||
+ this.cache = Object.create(null)
|
|
||||||
this.writeQueue = []
|
|
||||||
}
|
|
||||||
|
|
@ -119,69 +119,128 @@ tar -zxf node-v${version}.tar.gz
|
|||||||
rm -rf node-v${version}/deps/openssl
|
rm -rf node-v${version}/deps/openssl
|
||||||
tar -zcf node-v${version}-stripped.tar.gz node-v${version}
|
tar -zcf node-v${version}-stripped.tar.gz node-v${version}
|
||||||
|
|
||||||
# Download the matching version of ICU
|
# Download the ICU binary data files
|
||||||
rm -f icu4c*-src.tgz icu.md5
|
ICU_MAJOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\1/g')
|
||||||
ICUMD5=$(cat node-v${version}/tools/icu/current_ver.dep |jq -r '.[0].md5')
|
ICU_MINOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\2/g')
|
||||||
wget $(cat node-v${version}/tools/icu/current_ver.dep |jq -r '.[0].url')
|
rm -Rf icu4c-${ICU_MAJOR}_${ICU_MINOR}-data-bin-*.zip
|
||||||
ICUTARBALL=$(ls -1 icu4c*-src.tgz)
|
wget $(grep Source3 nodejs.spec | sed --expression="s/.*http/http/g" --expression="s/\(\%{icu_major}\)/${ICU_MAJOR}/g" --expression="s/\(\%{icu_minor}\)/${ICU_MINOR}/g")
|
||||||
echo "$ICUMD5 $ICUTARBALL" > icu.md5
|
wget $(grep Source4 nodejs.spec | sed --expression="s/.*http/http/g" --expression="s/\(\%{icu_major}\)/${ICU_MAJOR}/g" --expression="s/\(\%{icu_minor}\)/${ICU_MINOR}/g")
|
||||||
md5sum -c icu.md5
|
|
||||||
rm -f icu.md5 SHASUMS256.txt
|
|
||||||
|
|
||||||
rhpkg new-sources node-v${version}-stripped.tar.gz icu4c*-src.tgz
|
#fedpkg new-sources node-v${version}-stripped.tar.gz icu4c*-src.tgz
|
||||||
|
|
||||||
rm -f node-v${version}.tar.gz
|
rm -f node-v${version}.tar.gz
|
||||||
|
|
||||||
set +e
|
set +e
|
||||||
|
|
||||||
# Determine the bundled versions of the various packages
|
# Determine the bundled versions of the various packages
|
||||||
|
echo "Included software versions"
|
||||||
|
echo "-------------------------"
|
||||||
|
echo
|
||||||
|
echo "Node.js version"
|
||||||
|
echo "========================="
|
||||||
|
echo "${version}"
|
||||||
|
echo
|
||||||
echo "Bundled software versions"
|
echo "Bundled software versions"
|
||||||
echo "-------------------------"
|
echo "-------------------------"
|
||||||
echo
|
echo
|
||||||
echo "libnode shared object version"
|
echo "libnode shared object version (nodejs_soversion)"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NODE_MODULE_VERSION" node-v${version}/src/node_version.h
|
NODE_SOVERSION=$(grep -oP '(?<=#define NODE_MODULE_VERSION )\d+' node-v${version}/src/node_version.h)
|
||||||
|
echo "${NODE_SOVERSION}"
|
||||||
echo
|
echo
|
||||||
echo "V8"
|
echo "V8"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define V8_MAJOR_VERSION" node-v${version}/deps/v8/include/v8-version.h
|
V8_MAJOR=$(grep -oP '(?<=#define V8_MAJOR_VERSION )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_MINOR_VERSION" node-v${version}/deps/v8/include/v8-version.h
|
V8_MINOR=$(grep -oP '(?<=#define V8_MINOR_VERSION )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_BUILD_NUMBER" node-v${version}/deps/v8/include/v8-version.h
|
V8_BUILD=$(grep -oP '(?<=#define V8_BUILD_NUMBER )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_PATCH_LEVEL" node-v${version}/deps/v8/include/v8-version.h
|
V8_PATCH=$(grep -oP '(?<=#define V8_PATCH_LEVEL )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
|
echo "${V8_MAJOR}.${V8_MINOR}.${V8_BUILD}.${V8_PATCH}"
|
||||||
echo
|
echo
|
||||||
echo "c-ares"
|
echo "c-ares"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define ARES_VERSION_MAJOR" node-v${version}/deps/cares/include/ares_version.h
|
C_ARES_VERSION=$(grep -oP '(?<=#define ARES_VERSION_STR ).*\"' node-v${version}/deps/cares/include/ares_version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
grep "define ARES_VERSION_MINOR" node-v${version}/deps/cares/include/ares_version.h
|
echo $C_ARES_VERSION
|
||||||
grep "define ARES_VERSION_PATCH" node-v${version}/deps/cares/include/ares_version.h
|
|
||||||
echo
|
echo
|
||||||
echo "http-parser"
|
echo "llhttp"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define HTTP_PARSER_VERSION_MAJOR" node-v${version}/deps/http_parser/http_parser.h
|
LLHTTP_MAJOR=$(grep -oP '(?<=#define LLHTTP_VERSION_MAJOR )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
grep "define HTTP_PARSER_VERSION_MINOR" node-v${version}/deps/http_parser/http_parser.h
|
LLHTTP_MINOR=$(grep -oP '(?<=#define LLHTTP_VERSION_MINOR )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
grep "define HTTP_PARSER_VERSION_PATCH" node-v${version}/deps/http_parser/http_parser.h
|
LLHTTP_PATCH=$(grep -oP '(?<=#define LLHTTP_VERSION_PATCH )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
|
LLHTTP_VERSION="${LLHTTP_MAJOR}.${LLHTTP_MINOR}.${LLHTTP_PATCH}"
|
||||||
|
echo $LLHTTP_VERSION
|
||||||
echo
|
echo
|
||||||
echo "libuv"
|
echo "libuv"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define UV_VERSION_MAJOR" node-v${version}/deps/uv/include/uv/version.h
|
UV_MAJOR=$(grep -oP '(?<=#define UV_VERSION_MAJOR )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
grep "define UV_VERSION_MINOR" node-v${version}/deps/uv/include/uv/version.h
|
UV_MINOR=$(grep -oP '(?<=#define UV_VERSION_MINOR )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
grep "define UV_VERSION_PATCH" node-v${version}/deps/uv/include/uv/version.h
|
UV_PATCH=$(grep -oP '(?<=#define UV_VERSION_PATCH )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
|
LIBUV_VERSION="${UV_MAJOR}.${UV_MINOR}.${UV_PATCH}"
|
||||||
|
echo $LIBUV_VERSION
|
||||||
echo
|
echo
|
||||||
echo "nghttp2"
|
echo "nghttp2"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NGHTTP2_VERSION " node-v${version}/deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
NGHTTP2_VERSION=$(grep -oP '(?<=#define NGHTTP2_VERSION ).*\"' node-v${version}/deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGHTTP2_VERSION
|
||||||
|
echo
|
||||||
|
echo "nghttp3"
|
||||||
|
echo "========================="
|
||||||
|
NGHTTP3_VERSION=$(grep -oP '(?<=#define NGHTTP3_VERSION ).*\"' node-v${version}/deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGHTTP3_VERSION
|
||||||
|
echo
|
||||||
|
echo "ngtcp2"
|
||||||
|
echo "========================="
|
||||||
|
NGTCP2_VERSION=$(grep -oP '(?<=#define NGTCP2_VERSION ).*\"' node-v${version}/deps/ngtcp2/ngtcp2/lib/includes/ngtcp2/version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGTCP2_VERSION
|
||||||
echo
|
echo
|
||||||
echo "ICU"
|
echo "ICU"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "url" node-v${version}/tools/icu/current_ver.dep
|
ICU_MAJOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\1/g')
|
||||||
|
ICU_MINOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\2/g')
|
||||||
|
echo "${ICU_MAJOR}.${ICU_MINOR}"
|
||||||
|
echo
|
||||||
|
echo "simdutf"
|
||||||
|
echo "========================="
|
||||||
|
SIMDUTF_VERSION=$(grep -oP '(?<=#define SIMDUTF_VERSION ).*\"' node-v${version}/deps/simdutf/simdutf.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $SIMDUTF_VERSION
|
||||||
|
echo
|
||||||
|
echo "ada"
|
||||||
|
echo "========================="
|
||||||
|
ADA_VERSION=$(grep -osP '(?<=#define ADA_VERSION ).*\"' node-v${version}/deps/ada/ada.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
ADA_VERSION=${ADA_VERSION:-0}
|
||||||
|
echo "${ADA_VERSION}"
|
||||||
echo
|
echo
|
||||||
echo "punycode"
|
echo "punycode"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "'version'" node-v${version}/lib/punycode.js
|
PUNYCODE_VERSION=$(grep -oP "'version': '\K[^']+" ./node-v${version}/lib/punycode.js)
|
||||||
|
echo $PUNYCODE_VERSION
|
||||||
echo
|
echo
|
||||||
echo "npm"
|
echo "npm"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "\"version\":" node-v${version}/deps/npm/package.json
|
NPM_VERSION=$(jq -r .version ./node-v${version}/deps/npm/package.json)
|
||||||
|
echo $NPM_VERSION
|
||||||
|
echo
|
||||||
|
echo "corepack"
|
||||||
|
echo "========================="
|
||||||
|
COREPACK_VERSION=$(jq -r .version ./node-v${version}/deps/corepack/package.json)
|
||||||
|
echo $COREPACK_VERSION
|
||||||
|
echo
|
||||||
|
echo "uvwasi"
|
||||||
|
echo "========================="
|
||||||
|
UVWASI_MAJOR=$(grep -oP '(?<=#define UVWASI_VERSION_MAJOR )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_MINOR=$(grep -oP '(?<=#define UVWASI_VERSION_MINOR )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_PATCH=$(grep -oP '(?<=#define UVWASI_VERSION_PATCH )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_VERSION="${UVWASI_MAJOR}.${UVWASI_MINOR}.${UVWASI_PATCH}"
|
||||||
|
echo $UVWASI_VERSION
|
||||||
|
echo
|
||||||
|
echo "histogram_c"
|
||||||
|
echo "========================="
|
||||||
|
HISTOGRAM_VERSION=$(grep -oP '(?<=#define HDR_HISTOGRAM_VERSION ).*\"' node-v${version}/deps/histogram/include/hdr/hdr_histogram_version.h|sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $HISTOGRAM_VERSION
|
||||||
|
echo
|
||||||
|
echo "sqlite"
|
||||||
|
echo "========================="
|
||||||
|
SQLITE_VERSION="$(grep -osP '(?<=#define SQLITE_VERSION ).*\"' node-v${version}/deps/sqlite/sqlite3.h |sed -e 's/^\s*"//' -e 's/"\s*$//')"
|
||||||
|
echo "${SQLITE_VERSION}"
|
||||||
echo
|
echo
|
||||||
echo "Make sure these versions match what is in the RPM spec file"
|
echo "Make sure these versions match what is in the RPM spec file"
|
||||||
|
|
||||||
|
9
SOURCES/nodejs.pc.in
Normal file
9
SOURCES/nodejs.pc.in
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
prefix=@PREFIX@
|
||||||
|
includedir=@INCLUDEDIR@
|
||||||
|
libdir=@LIBDIR@
|
||||||
|
|
||||||
|
Name: @PKGCONFNAME@
|
||||||
|
Description: JavaScript Runtime
|
||||||
|
Version: @NODEJS_VERSION@
|
||||||
|
Libs: -L${libdir} -lnodejs
|
||||||
|
Cflags: -I${includedir}/node
|
@ -1,2 +0,0 @@
|
|||||||
%__nodejs_native_requires %{_rpmconfigdir}/nodejs_native.req
|
|
||||||
%__nodejs_native_path ^/usr/lib.*/node_modules/.*\\.node$
|
|
@ -1 +1,2 @@
|
|||||||
prefix=/usr/local
|
prefix=/usr/local
|
||||||
|
python=/usr/bin/python3
|
||||||
|
5
SOURCES/npmrc.builtin.in
Normal file
5
SOURCES/npmrc.builtin.in
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
# This is the distibution-level configuration file for npm.
|
||||||
|
# To configure NPM on a system level, use the globalconfig below (defaults to @SYSCONFDIR@/npmrc).
|
||||||
|
# vim:set filetype=dosini:
|
||||||
|
|
||||||
|
globalconfig=@SYSCONFDIR@/npmrc
|
9
SOURCES/v8.pc.in
Normal file
9
SOURCES/v8.pc.in
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
prefix=@PREFIX@
|
||||||
|
includedir=@INCLUDEDIR@
|
||||||
|
libdir=@LIBDIR@
|
||||||
|
|
||||||
|
Name: v8-@PKGCONFVERSION@
|
||||||
|
Description: JavaScript Runtime
|
||||||
|
Version: @V8_VERSION@
|
||||||
|
Libs: -L${libdir} -lv8
|
||||||
|
Cflags: -I${includedir}
|
1154
SPECS/nodejs.spec
1154
SPECS/nodejs.spec
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user