import CS nodejs-18.19.1-1.module_el8+987+2c53b1e4
This commit is contained in:
parent
c22ef8a4bb
commit
0cfeff8d6e
9
.gitignore
vendored
9
.gitignore
vendored
@ -1,6 +1,5 @@
|
|||||||
SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
||||||
SOURCES/icu4c-71_1-src.tgz
|
SOURCES/icu4c-73_2-src.tgz
|
||||||
SOURCES/node-v18.12.1-stripped.tar.gz
|
SOURCES/node-v18.19.1-stripped.tar.gz
|
||||||
SOURCES/undici-5.11.0.tar.gz
|
SOURCES/undici-5.28.3.tar.gz
|
||||||
SOURCES/wasi-sdk-wasi-sdk-11.tar.gz
|
SOURCES/wasi-sdk-11.0-linux.tar.gz
|
||||||
SOURCES/wasi-sdk-wasi-sdk-14.tar.gz
|
|
||||||
|
@ -1,6 +1,5 @@
|
|||||||
6976e77068429bd0b47b573793289e065ceb6b27 SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
164f7f39841415284b0280a648c43bd7ea1615ac SOURCES/cjs-module-lexer-1.2.2.tar.gz
|
||||||
406b0c8635288b772913b6ff646451e69748878a SOURCES/icu4c-71_1-src.tgz
|
3d94969b097189bf5479c312d9593d2d252f5a73 SOURCES/icu4c-73_2-src.tgz
|
||||||
816c2656eea956f3fcd0d98562d7d225abd3e95f SOURCES/node-v18.12.1-stripped.tar.gz
|
7962d96e7c1517cf7b34395fc582b32b8acebe3a SOURCES/node-v18.19.1-stripped.tar.gz
|
||||||
0ea4e5cfe13969896bf41c0d2d029a621917b944 SOURCES/undici-5.11.0.tar.gz
|
b598f79f4706fe75c31ff2a214e50acc04c4725a SOURCES/undici-5.28.3.tar.gz
|
||||||
8979d177dd62e3b167a6fd7dc7185adb0128c439 SOURCES/wasi-sdk-wasi-sdk-11.tar.gz
|
ff114dd45b4efeeae7afe4621bfc6f886a475b4b SOURCES/wasi-sdk-11.0-linux.tar.gz
|
||||||
900a50a32f0079d53c299db92b88bb3c5d2022b8 SOURCES/wasi-sdk-wasi-sdk-14.tar.gz
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
From 2abb9e98751595936ac1c867b3f08695f5bcf22c Mon Sep 17 00:00:00 2001
|
From c73e0892eb1d0aa2df805618c019dc5c96b79705 Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: rpm-build <rpm-build>
|
||||||
Date: Fri, 17 Apr 2020 12:59:44 +0200
|
Date: Tue, 30 May 2023 13:12:35 +0200
|
||||||
Subject: [PATCH] Disable running gyp on shared deps
|
Subject: [PATCH] Disable running gyp on shared deps
|
||||||
|
|
||||||
Signed-off-by: rpm-build <rpm-build>
|
Signed-off-by: rpm-build <rpm-build>
|
||||||
@ -10,23 +10,23 @@ Signed-off-by: rpm-build <rpm-build>
|
|||||||
2 files changed, 1 insertion(+), 18 deletions(-)
|
2 files changed, 1 insertion(+), 18 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 9c01f8f..133a3d0 100644
|
index 0be0659..3c44201 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -148,7 +148,7 @@ with-code-cache test-code-cache:
|
@@ -169,7 +169,7 @@ with-code-cache test-code-cache:
|
||||||
$(warning '$@' target is a noop)
|
$(warning '$@' target is a noop)
|
||||||
|
|
||||||
out/Makefile: config.gypi common.gypi node.gyp \
|
out/Makefile: config.gypi common.gypi node.gyp \
|
||||||
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
- deps/uv/uv.gyp deps/llhttp/llhttp.gyp deps/zlib/zlib.gyp \
|
||||||
+ deps/llhttp/llhttp.gyp \
|
+ deps/llhttp/llhttp.gyp \
|
||||||
|
deps/simdutf/simdutf.gyp deps/ada/ada.gyp \
|
||||||
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
|
||||||
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
|
||||||
$(PYTHON) tools/gyp_node.py -f make
|
|
||||||
diff --git a/node.gyp b/node.gyp
|
diff --git a/node.gyp b/node.gyp
|
||||||
index 8f131ac..dce5fdc 100644
|
index cf52281..c33b57b 100644
|
||||||
--- a/node.gyp
|
--- a/node.gyp
|
||||||
+++ b/node.gyp
|
+++ b/node.gyp
|
||||||
@@ -429,23 +429,6 @@
|
@@ -430,23 +430,6 @@
|
||||||
],
|
],
|
||||||
},
|
},
|
||||||
],
|
],
|
||||||
@ -41,7 +41,7 @@ index 8f131ac..dce5fdc 100644
|
|||||||
- 'inputs': [ '<(opensslconfig)', ],
|
- 'inputs': [ '<(opensslconfig)', ],
|
||||||
- 'outputs': [ '<(opensslconfig_internal)', ],
|
- 'outputs': [ '<(opensslconfig_internal)', ],
|
||||||
- 'action': [
|
- 'action': [
|
||||||
- 'python', 'tools/copyfile.py',
|
- '<(python)', 'tools/copyfile.py',
|
||||||
- '<(opensslconfig)',
|
- '<(opensslconfig)',
|
||||||
- '<(opensslconfig_internal)',
|
- '<(opensslconfig_internal)',
|
||||||
- ],
|
- ],
|
||||||
@ -51,5 +51,5 @@ index 8f131ac..dce5fdc 100644
|
|||||||
],
|
],
|
||||||
}, # node_core_target_name
|
}, # node_core_target_name
|
||||||
--
|
--
|
||||||
2.37.3
|
2.41.0
|
||||||
|
|
||||||
|
@ -135,67 +135,109 @@ rm -f node-v${version}.tar.gz
|
|||||||
set +e
|
set +e
|
||||||
|
|
||||||
# Determine the bundled versions of the various packages
|
# Determine the bundled versions of the various packages
|
||||||
|
echo "Included software versions"
|
||||||
|
echo "-------------------------"
|
||||||
|
echo
|
||||||
|
echo "Node.js version"
|
||||||
|
echo "========================="
|
||||||
|
echo "${version}"
|
||||||
|
echo
|
||||||
echo "Bundled software versions"
|
echo "Bundled software versions"
|
||||||
echo "-------------------------"
|
echo "-------------------------"
|
||||||
echo
|
echo
|
||||||
echo "libnode shared object version"
|
echo "libnode shared object version (nodejs_soversion)"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NODE_MODULE_VERSION" node-v${version}/src/node_version.h
|
NODE_SOVERSION=$(grep -oP '(?<=#define NODE_MODULE_VERSION )\d+' node-v${version}/src/node_version.h)
|
||||||
|
echo "${NODE_SOVERSION}"
|
||||||
echo
|
echo
|
||||||
echo "V8"
|
echo "V8"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define V8_MAJOR_VERSION" node-v${version}/deps/v8/include/v8-version.h
|
V8_MAJOR=$(grep -oP '(?<=#define V8_MAJOR_VERSION )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_MINOR_VERSION" node-v${version}/deps/v8/include/v8-version.h
|
V8_MINOR=$(grep -oP '(?<=#define V8_MINOR_VERSION )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_BUILD_NUMBER" node-v${version}/deps/v8/include/v8-version.h
|
V8_BUILD=$(grep -oP '(?<=#define V8_BUILD_NUMBER )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
grep "define V8_PATCH_LEVEL" node-v${version}/deps/v8/include/v8-version.h
|
V8_PATCH=$(grep -oP '(?<=#define V8_PATCH_LEVEL )\d+' node-v${version}/deps/v8/include/v8-version.h)
|
||||||
|
echo "${V8_MAJOR}.${V8_MINOR}.${V8_BUILD}.${V8_PATCH}"
|
||||||
echo
|
echo
|
||||||
echo "c-ares"
|
echo "c-ares"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define ARES_VERSION_MAJOR" node-v${version}/deps/cares/include/ares_version.h
|
C_ARES_VERSION=$(grep -oP '(?<=#define ARES_VERSION_STR ).*\"' node-v${version}/deps/cares/include/ares_version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
grep "define ARES_VERSION_MINOR" node-v${version}/deps/cares/include/ares_version.h
|
echo $C_ARES_VERSION
|
||||||
grep "define ARES_VERSION_PATCH" node-v${version}/deps/cares/include/ares_version.h
|
|
||||||
echo
|
echo
|
||||||
echo "llhttp"
|
echo "llhttp"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define LLHTTP_VERSION_MAJOR" node-v${version}/deps/llhttp/include/llhttp.h
|
LLHTTP_MAJOR=$(grep -oP '(?<=#define LLHTTP_VERSION_MAJOR )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
grep "define LLHTTP_VERSION_MINOR" node-v${version}/deps/llhttp/include/llhttp.h
|
LLHTTP_MINOR=$(grep -oP '(?<=#define LLHTTP_VERSION_MINOR )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
grep "define LLHTTP_VERSION_PATCH" node-v${version}/deps/llhttp/include/llhttp.h
|
LLHTTP_PATCH=$(grep -oP '(?<=#define LLHTTP_VERSION_PATCH )\d+' node-v${version}/deps/llhttp/include/llhttp.h)
|
||||||
|
LLHTTP_VERSION="${LLHTTP_MAJOR}.${LLHTTP_MINOR}.${LLHTTP_PATCH}"
|
||||||
|
echo $LLHTTP_VERSION
|
||||||
echo
|
echo
|
||||||
echo "libuv"
|
echo "libuv"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define UV_VERSION_MAJOR" node-v${version}/deps/uv/include/uv/version.h
|
UV_MAJOR=$(grep -oP '(?<=#define UV_VERSION_MAJOR )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
grep "define UV_VERSION_MINOR" node-v${version}/deps/uv/include/uv/version.h
|
UV_MINOR=$(grep -oP '(?<=#define UV_VERSION_MINOR )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
grep "define UV_VERSION_PATCH" node-v${version}/deps/uv/include/uv/version.h
|
UV_PATCH=$(grep -oP '(?<=#define UV_VERSION_PATCH )\d+' node-v${version}/deps/uv/include/uv/version.h)
|
||||||
|
LIBUV_VERSION="${UV_MAJOR}.${UV_MINOR}.${UV_PATCH}"
|
||||||
|
echo $LIBUV_VERSION
|
||||||
echo
|
echo
|
||||||
echo "nghttp2"
|
echo "nghttp2"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NGHTTP2_VERSION " node-v${version}/deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
NGHTTP2_VERSION=$(grep -oP '(?<=#define NGHTTP2_VERSION ).*\"' node-v${version}/deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGHTTP2_VERSION
|
||||||
echo
|
echo
|
||||||
echo "nghttp3"
|
echo "nghttp3"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NGHTTP3_VERSION " node-v${version}/deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
NGHTTP3_VERSION=$(grep -oP '(?<=#define NGHTTP3_VERSION ).*\"' node-v${version}/deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGHTTP3_VERSION
|
||||||
echo
|
echo
|
||||||
echo "ngtcp2"
|
echo "ngtcp2"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "define NGTCP2_VERSION " node-v${version}/deps/ngtcp2/ngtcp2/lib/includes/ngtcp2/version.h
|
NGTCP2_VERSION=$(grep -oP '(?<=#define NGTCP2_VERSION ).*\"' node-v${version}/deps/ngtcp2/ngtcp2/lib/includes/ngtcp2/version.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $NGTCP2_VERSION
|
||||||
echo
|
echo
|
||||||
echo "ICU"
|
echo "ICU"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "url" node-v${version}/tools/icu/current_ver.dep
|
ICU_MAJOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\1/g')
|
||||||
|
ICU_MINOR=$(jq -r '.[0].url' node-v${version}/tools/icu/current_ver.dep | sed --expression='s/.*release-\([[:digit:]]\+\)-\([[:digit:]]\+\).*/\2/g')
|
||||||
|
echo "${ICU_MAJOR}.${ICU_MINOR}"
|
||||||
|
echo
|
||||||
|
echo "simdutf"
|
||||||
|
echo "========================="
|
||||||
|
SIMDUTF_VERSION=$(grep -oP '(?<=#define SIMDUTF_VERSION ).*\"' node-v${version}/deps/simdutf/simdutf.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $SIMDUTF_VERSION
|
||||||
|
echo
|
||||||
|
echo "ada"
|
||||||
|
echo "========================="
|
||||||
|
ADA_VERSION=$(grep -osP '(?<=#define ADA_VERSION ).*\"' node-v${version}/deps/ada/ada.h |sed -e 's/^"//' -e 's/"$//')
|
||||||
|
ADA_VERSION=${ADA_VERSION:-0}
|
||||||
|
echo "${ADA_VERSION}"
|
||||||
echo
|
echo
|
||||||
echo "punycode"
|
echo "punycode"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "'version'" node-v${version}/lib/punycode.js
|
PUNYCODE_VERSION=$(grep -oP "'version': '\K[^']+" ./node-v${version}/lib/punycode.js)
|
||||||
echo
|
echo $PUNYCODE_VERSION
|
||||||
echo "uvwasi"
|
|
||||||
echo "========================="
|
|
||||||
grep "define UVWASI_VERSION_MAJOR" node-v${version}/deps/uvwasi/include/uvwasi.h
|
|
||||||
grep "define UVWASI_VERSION_MINOR" node-v${version}/deps/uvwasi/include/uvwasi.h
|
|
||||||
grep "define UVWASI_VERSION_PATCH" node-v${version}/deps/uvwasi/include/uvwasi.h
|
|
||||||
echo
|
echo
|
||||||
echo "npm"
|
echo "npm"
|
||||||
echo "========================="
|
echo "========================="
|
||||||
grep "\"version\":" node-v${version}/deps/npm/package.json
|
NPM_VERSION=$(jq -r .version ./node-v${version}/deps/npm/package.json)
|
||||||
|
echo $NPM_VERSION
|
||||||
|
echo
|
||||||
|
echo "corepack"
|
||||||
|
echo "========================="
|
||||||
|
COREPACK_VERSION=$(jq -r .version ./node-v${version}/deps/corepack/package.json)
|
||||||
|
echo $COREPACK_VERSION
|
||||||
|
echo
|
||||||
|
echo "uvwasi"
|
||||||
|
echo "========================="
|
||||||
|
UVWASI_MAJOR=$(grep -oP '(?<=#define UVWASI_VERSION_MAJOR )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_MINOR=$(grep -oP '(?<=#define UVWASI_VERSION_MINOR )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_PATCH=$(grep -oP '(?<=#define UVWASI_VERSION_PATCH )\d+' node-v${version}/deps/uvwasi/include/uvwasi.h)
|
||||||
|
UVWASI_VERSION="${UVWASI_MAJOR}.${UVWASI_MINOR}.${UVWASI_PATCH}"
|
||||||
|
echo $UVWASI_VERSION
|
||||||
|
echo
|
||||||
|
echo "histogram_c"
|
||||||
|
echo "========================="
|
||||||
|
HISTOGRAM_VERSION=$(grep -oP '(?<=#define HDR_HISTOGRAM_VERSION ).*\"' node-v${version}/deps/histogram/include/hdr/hdr_histogram_version.h|sed -e 's/^"//' -e 's/"$//')
|
||||||
|
echo $HISTOGRAM_VERSION
|
||||||
echo
|
echo
|
||||||
echo "Make sure these versions match what is in the RPM spec file"
|
echo "Make sure these versions match what is in the RPM spec file"
|
||||||
|
|
||||||
|
5
SOURCES/npmrc.builtin.in
Normal file
5
SOURCES/npmrc.builtin.in
Normal file
@ -0,0 +1,5 @@
|
|||||||
|
# This is the distibution-level configuration file for npm.
|
||||||
|
# To configure NPM on a system level, use the globalconfig below (defaults to @SYSCONFDIR@/npmrc).
|
||||||
|
# vim:set filetype=dosini:
|
||||||
|
|
||||||
|
globalconfig=@SYSCONFDIR@/npmrc
|
@ -17,7 +17,7 @@
|
|||||||
#
|
#
|
||||||
# create bootstrapping build with bundled deps and extra release suffix
|
# create bootstrapping build with bundled deps and extra release suffix
|
||||||
%bcond_with bootstrap
|
%bcond_with bootstrap
|
||||||
# bundle dependencies that are not available as Fedora modules
|
# bundle dependencies that are not available in CentOS
|
||||||
%if %{with bootstrap}
|
%if %{with bootstrap}
|
||||||
%bcond_without bundled
|
%bcond_without bundled
|
||||||
%else
|
%else
|
||||||
@ -30,7 +30,7 @@
|
|||||||
# This is used by both the nodejs package and the npm subpackage that
|
# This is used by both the nodejs package and the npm subpackage that
|
||||||
# has a separate version - the name is special so that rpmdev-bumpspec
|
# has a separate version - the name is special so that rpmdev-bumpspec
|
||||||
# will bump this rather than adding .1 to the end.
|
# will bump this rather than adding .1 to the end.
|
||||||
%global baserelease 2
|
%global baserelease 1
|
||||||
|
|
||||||
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{?!_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
@ -41,7 +41,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 18
|
%global nodejs_major 18
|
||||||
%global nodejs_minor 12
|
%global nodejs_minor 19
|
||||||
%global nodejs_patch 1
|
%global nodejs_patch 1
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
@ -58,36 +58,26 @@
|
|||||||
%global v8_major 10
|
%global v8_major 10
|
||||||
%global v8_minor 2
|
%global v8_minor 2
|
||||||
%global v8_build 154
|
%global v8_build 154
|
||||||
%global v8_patch 15
|
%global v8_patch 26
|
||||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||||
%global v8_abi %{v8_major}.%{v8_minor}
|
%global v8_abi %{v8_major}.%{v8_minor}
|
||||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||||
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
%global v8_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||||
|
|
||||||
# c-ares - from deps/cares/include/ares_version.h
|
# c-ares - from deps/cares/include/ares_version.h
|
||||||
# https://github.com/nodejs/node/pull/9332
|
%global c_ares_version 1.20.1
|
||||||
%global c_ares_major 1
|
|
||||||
%global c_ares_minor 18
|
|
||||||
%global c_ares_patch 1
|
|
||||||
%global c_ares_version %{c_ares_major}.%{c_ares_minor}.%{c_ares_patch}
|
|
||||||
|
|
||||||
# llhttp - from deps/llhttp/include/llhttp.h
|
# llhttp - from deps/llhttp/include/llhttp.h
|
||||||
%global llhttp_major 6
|
%global llhttp_version 6.1.0
|
||||||
%global llhttp_minor 0
|
|
||||||
%global llhttp_patch 10
|
|
||||||
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
|
|
||||||
|
|
||||||
# libuv - from deps/uv/include/uv/version.h
|
# libuv - from deps/uv/include/uv/version.h
|
||||||
%global libuv_major 1
|
%global libuv_major 1
|
||||||
%global libuv_minor 43
|
%global libuv_minor 44
|
||||||
%global libuv_patch 0
|
%global libuv_patch 2
|
||||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||||
|
|
||||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||||
%global nghttp2_major 1
|
%global nghttp2_version 1.57.0
|
||||||
%global nghttp2_minor 47
|
|
||||||
%global nghttp2_patch 0
|
|
||||||
%global nghttp2_version %{nghttp2_major}.%{nghttp2_minor}.%{nghttp2_patch}
|
|
||||||
|
|
||||||
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
# nghttp3 - from deps/ngtcp2/nghttp3/lib/includes/nghttp3/version.h
|
||||||
%global nghttp3_major 0
|
%global nghttp3_major 0
|
||||||
@ -102,8 +92,8 @@
|
|||||||
%global ngtcp2_version %{ngtcp2_major}.%{ngtcp2_minor}.%{ngtcp2_patch}
|
%global ngtcp2_version %{ngtcp2_major}.%{ngtcp2_minor}.%{ngtcp2_patch}
|
||||||
|
|
||||||
# ICU - from tools/icu/current_ver.dep
|
# ICU - from tools/icu/current_ver.dep
|
||||||
%global icu_major 71
|
%global icu_major 73
|
||||||
%global icu_minor 1
|
%global icu_minor 2
|
||||||
%global icu_version %{icu_major}.%{icu_minor}
|
%global icu_version %{icu_major}.%{icu_minor}
|
||||||
|
|
||||||
%global icudatadir %{nodejs_datadir}/icudata
|
%global icudatadir %{nodejs_datadir}/icudata
|
||||||
@ -120,6 +110,15 @@
|
|||||||
%global icu_flag full-icu
|
%global icu_flag full-icu
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# simduft from deps/simdutf/simdutf.h
|
||||||
|
%global simduft_major 3
|
||||||
|
%global simduft_minor 2
|
||||||
|
%global simduft_patch 18
|
||||||
|
%global simduft_version %{simduft_major}.%{simduft_minor}.%{simduft_patch}
|
||||||
|
|
||||||
|
# ada from deps/ada/ada.h
|
||||||
|
%global ada_version 2.7.2
|
||||||
|
|
||||||
# OpenSSL minimum version
|
# OpenSSL minimum version
|
||||||
%global openssl_minimum 1:1.1.1
|
%global openssl_minimum 1:1.1.1
|
||||||
|
|
||||||
@ -133,22 +132,7 @@
|
|||||||
|
|
||||||
# npm - from deps/npm/package.json
|
# npm - from deps/npm/package.json
|
||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_major 8
|
%global npm_version 10.2.4
|
||||||
%global npm_minor 19
|
|
||||||
%global npm_patch 2
|
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
|
||||||
|
|
||||||
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
|
||||||
%global uvwasi_major 0
|
|
||||||
%global uvwasi_minor 0
|
|
||||||
%global uvwasi_patch 13
|
|
||||||
%global uvwasi_version %{uvwasi_major}.%{uvwasi_minor}.%{uvwasi_patch}
|
|
||||||
|
|
||||||
# histogram_c - assumed from timestamps
|
|
||||||
%global histogram_major 0
|
|
||||||
%global histogram_minor 11
|
|
||||||
%global histogram_patch 2
|
|
||||||
%global histogram_version %{histogram_major}.%{histogram_minor}.%{histogram_patch}
|
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
# main package forever, we will just construct one for npm that is guaranteed
|
# main package forever, we will just construct one for npm that is guaranteed
|
||||||
@ -157,7 +141,13 @@
|
|||||||
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
%global npm_release %{nodejs_epoch}.%{nodejs_major}.%{nodejs_minor}.%{nodejs_patch}.%{nodejs_release}
|
||||||
|
|
||||||
# Node.js 16.9.1 and later comes with an experimental package management tool
|
# Node.js 16.9.1 and later comes with an experimental package management tool
|
||||||
%global corepack_version 0.10.0
|
%global corepack_version 0.22.0
|
||||||
|
|
||||||
|
# uvwasi - from deps/uvwasi/include/uvwasi.h
|
||||||
|
%global uvwasi_version 0.0.19
|
||||||
|
|
||||||
|
# histogram_c - assumed from timestamps
|
||||||
|
%global histogram_version 0.11.8
|
||||||
|
|
||||||
Name: nodejs
|
Name: nodejs
|
||||||
Epoch: %{nodejs_epoch}
|
Epoch: %{nodejs_epoch}
|
||||||
@ -184,6 +174,9 @@ Source100: %{name}-tarball.sh
|
|||||||
# nodejs-packaging SRPM.
|
# nodejs-packaging SRPM.
|
||||||
Source7: nodejs_native.attr
|
Source7: nodejs_native.attr
|
||||||
|
|
||||||
|
# Configure npm to look into /etc for configuration
|
||||||
|
Source8: npmrc.builtin.in
|
||||||
|
|
||||||
# These are full sources for dependencies included as WASM blobs in the source of Node itself.
|
# These are full sources for dependencies included as WASM blobs in the source of Node itself.
|
||||||
# Note: These sources would also include pre-compiled WASM blobs… so they are adjusted not to.
|
# Note: These sources would also include pre-compiled WASM blobs… so they are adjusted not to.
|
||||||
# Recipes for creating these blobs are included in the sources.
|
# Recipes for creating these blobs are included in the sources.
|
||||||
@ -194,25 +187,29 @@ Source7: nodejs_native.attr
|
|||||||
Source101: cjs-module-lexer-1.2.2.tar.gz
|
Source101: cjs-module-lexer-1.2.2.tar.gz
|
||||||
# The WASM blob was made using wasi-sdk v11; compiler libraries are linked in.
|
# The WASM blob was made using wasi-sdk v11; compiler libraries are linked in.
|
||||||
# Version source: Makefile
|
# Version source: Makefile
|
||||||
Source102: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-11/wasi-sdk-wasi-sdk-11.tar.gz
|
Source102: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-11/wasi-sdk-11.0-linux.tar.gz
|
||||||
|
|
||||||
# Version: jq '.version' deps/undici/src/package.json
|
# Version: jq '.version' deps/undici/src/package.json
|
||||||
# Original: https://github.com/nodejs/undici/archive/refs/tags/v5.11.0.tar.gz
|
# Original: https://github.com/nodejs/undici/archive/refs/tags/v5.28.3.tar.gz
|
||||||
# Adjustments: rm -f undici-5.11.0/lib/llhttp/llhttp*.wasm*
|
# Adjustments: rm -f undici-5.28.3/lib/llhttp/llhttp*.wasm
|
||||||
Source111: undici-5.11.0.tar.gz
|
# Build uses alpine image, see alpine for sources for wasi-sdk
|
||||||
# The WASM blob was made using wasi-sdk v14; compiler libraries are linked in.
|
Source111: undici-5.28.3.tar.gz
|
||||||
# Version source: build/Dockerfile
|
|
||||||
Source112: https://github.com/WebAssembly/wasi-sdk/archive/wasi-sdk-14/wasi-sdk-wasi-sdk-14.tar.gz
|
|
||||||
|
|
||||||
# Disable running gyp on bundled deps we don't use
|
# Disable running gyp on bundled deps we don't use
|
||||||
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
Patch1: 0001-Disable-running-gyp-on-shared-deps.patch
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-setuptools
|
||||||
|
BuildRequires: python3-jinja2
|
||||||
|
%if !%{with python3_fixup}
|
||||||
|
BuildRequires: python-unversioned-command
|
||||||
|
%endif
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: brotli-devel
|
BuildRequires: brotli-devel
|
||||||
BuildRequires: gcc >= 8.3.0
|
BuildRequires: gcc >= 8.3.0
|
||||||
BuildRequires: gcc-c++ >= 8.3.0
|
BuildRequires: gcc-c++ >= 8.3.0
|
||||||
|
BuildRequires: jq
|
||||||
# needed to generate bundled provides for npm dependencies
|
# needed to generate bundled provides for npm dependencies
|
||||||
# https://src.fedoraproject.org/rpms/nodejs/pull-request/2
|
# https://src.fedoraproject.org/rpms/nodejs/pull-request/2
|
||||||
# https://pagure.io/nodejs-packaging/pull-request/10
|
# https://pagure.io/nodejs-packaging/pull-request/10
|
||||||
@ -299,6 +296,8 @@ Provides: bundled(icu) = %{icu_version}
|
|||||||
Provides: bundled(uvwasi) = %{uvwasi_version}
|
Provides: bundled(uvwasi) = %{uvwasi_version}
|
||||||
Provides: bundled(histogram) = %{histogram_version}
|
Provides: bundled(histogram) = %{histogram_version}
|
||||||
Provides: bundled(corepack) = %{corepack_version}
|
Provides: bundled(corepack) = %{corepack_version}
|
||||||
|
Provides: bundled(simduft) = %{simduft_version}
|
||||||
|
Provides: bundled(ada) = %{ada_version}
|
||||||
|
|
||||||
# Make sure we keep NPM up to date when we update Node.js
|
# Make sure we keep NPM up to date when we update Node.js
|
||||||
%if 0%{?rhel} < 8
|
%if 0%{?rhel} < 8
|
||||||
@ -388,8 +387,26 @@ The API documentation for the Node.js JavaScript runtime.
|
|||||||
# remove bundled dependencies that we aren't building
|
# remove bundled dependencies that we aren't building
|
||||||
rm -rf deps/zlib
|
rm -rf deps/zlib
|
||||||
rm -rf deps/brotli
|
rm -rf deps/brotli
|
||||||
|
rm -rf deps/v8/third_party/jinja2
|
||||||
|
rm -rf tools/inspector_protocol/jinja2
|
||||||
|
|
||||||
# Replace any instances of unversioned python' with python3
|
# Replace any instances of unversioned python' with python3
|
||||||
|
# check for correct versions of dependencies we are bundling
|
||||||
|
check_wasm_dep() {
|
||||||
|
local -r name="$1" source="$2" packagejson="$3"
|
||||||
|
local -r expected_version="$(jq -r '.version' "${packagejson}")"
|
||||||
|
|
||||||
|
if ls "${source}"|grep -q --fixed-strings "${expected_version}"; then
|
||||||
|
printf '%s version matches\n' "${name}" >&2
|
||||||
|
else
|
||||||
|
printf '%s version MISMATCH: %s !~ %s\n' "${name}" "${expected_version}" "${source}" >&2
|
||||||
|
return 1
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
||||||
|
check_wasm_dep cjs-module-lexer '%{SOURCE101}' deps/cjs-module-lexer/package.json
|
||||||
|
check_wasm_dep undici '%{SOURCE111}' deps/undici/src/package.json
|
||||||
|
|
||||||
%if %{with python3_fixup}
|
%if %{with python3_fixup}
|
||||||
pathfix.py -i %{__python3} -pn $(find -type f ! -name "*.js")
|
pathfix.py -i %{__python3} -pn $(find -type f ! -name "*.js")
|
||||||
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python3~" {} \;
|
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python3~" {} \;
|
||||||
@ -424,7 +441,7 @@ export CFLAGS="%{optflags} ${extra_cflags[*]}" CXXFLAGS="%{optflags} ${extra_cfl
|
|||||||
export LDFLAGS="%{build_ldflags}"
|
export LDFLAGS="%{build_ldflags}"
|
||||||
|
|
||||||
%{__python3} configure.py --prefix=%{_prefix} --verbose \
|
%{__python3} configure.py --prefix=%{_prefix} --verbose \
|
||||||
--shared-openssl \
|
--shared-openssl --openssl-conf-name=openssl_conf \
|
||||||
--shared-zlib \
|
--shared-zlib \
|
||||||
--shared-brotli \
|
--shared-brotli \
|
||||||
%{!?with_bundled:--shared-libuv} \
|
%{!?with_bundled:--shared-libuv} \
|
||||||
@ -444,7 +461,7 @@ make BUILDTYPE=Release %{?_smp_mflags}
|
|||||||
|
|
||||||
# Extract the ICU data and convert it to the appropriate endianness
|
# Extract the ICU data and convert it to the appropriate endianness
|
||||||
pushd deps/
|
pushd deps/
|
||||||
tar xfz %SOURCE3
|
tar xfz %{SOURCE3}
|
||||||
|
|
||||||
pushd icu/source
|
pushd icu/source
|
||||||
|
|
||||||
@ -548,15 +565,14 @@ chmod 0755 %{buildroot}%{_prefix}/lib/node_modules/npm/node_modules/node-gyp/bin
|
|||||||
# automatic dependency on /usr/bin/pwsh that we cannot satisfy.
|
# automatic dependency on /usr/bin/pwsh that we cannot satisfy.
|
||||||
chmod -x %{buildroot}%{_prefix}/lib/node_modules/corepack/shims/*.ps1
|
chmod -x %{buildroot}%{_prefix}/lib/node_modules/corepack/shims/*.ps1
|
||||||
|
|
||||||
|
# Drop the NPM builtin configuration in place
|
||||||
|
sed -e 's#@SYSCONFDIR@#%{_sysconfdir}#g' \
|
||||||
|
%{SOURCE8} > %{buildroot}%{_prefix}/lib/node_modules/npm/npmrc
|
||||||
|
|
||||||
# Drop the NPM default configuration in place
|
# Drop the NPM default configuration in place
|
||||||
mkdir -p %{buildroot}%{_sysconfdir}
|
mkdir -p %{buildroot}%{_sysconfdir}
|
||||||
cp %{SOURCE1} %{buildroot}%{_sysconfdir}/npmrc
|
cp %{SOURCE1} %{buildroot}%{_sysconfdir}/npmrc
|
||||||
|
|
||||||
# NPM upstream expects it to be in /usr/etc/npmrc, so we'll put a symlink here
|
|
||||||
# This is done in the interests of keeping /usr read-only.
|
|
||||||
mkdir -p %{buildroot}%{_prefix}/etc
|
|
||||||
ln -s %{_sysconfdir}/npmrc %{buildroot}%{_prefix}/etc/npmrc
|
|
||||||
|
|
||||||
# Install the full-icu data files
|
# Install the full-icu data files
|
||||||
install -Dpm0644 -t %{buildroot}%{icudatadir} deps/icu/source/converted/*
|
install -Dpm0644 -t %{buildroot}%{icudatadir} deps/icu/source/converted/*
|
||||||
|
|
||||||
@ -660,7 +676,7 @@ end
|
|||||||
%{_rpmconfigdir}/fileattrs/nodejs_native.attr
|
%{_rpmconfigdir}/fileattrs/nodejs_native.attr
|
||||||
%{_rpmconfigdir}/nodejs_native.req
|
%{_rpmconfigdir}/nodejs_native.req
|
||||||
%license LICENSE
|
%license LICENSE
|
||||||
%doc AUTHORS CHANGELOG.md onboarding.md GOVERNANCE.md README.md
|
%doc CHANGELOG.md onboarding.md GOVERNANCE.md README.md
|
||||||
%doc %{_mandir}/man1/node.1*
|
%doc %{_mandir}/man1/node.1*
|
||||||
|
|
||||||
|
|
||||||
@ -683,7 +699,6 @@ end
|
|||||||
%{_bindir}/npx
|
%{_bindir}/npx
|
||||||
%{_prefix}/lib/node_modules/npm
|
%{_prefix}/lib/node_modules/npm
|
||||||
%config(noreplace) %{_sysconfdir}/npmrc
|
%config(noreplace) %{_sysconfdir}/npmrc
|
||||||
%{_prefix}/etc/npmrc
|
|
||||||
%ghost %{_sysconfdir}/npmignore
|
%ghost %{_sysconfdir}/npmignore
|
||||||
%doc %{_mandir}/man1/npm*.1*
|
%doc %{_mandir}/man1/npm*.1*
|
||||||
%doc %{_mandir}/man1/npx.1*
|
%doc %{_mandir}/man1/npx.1*
|
||||||
@ -693,6 +708,8 @@ end
|
|||||||
%doc %{_mandir}/man5/package-json.5*
|
%doc %{_mandir}/man5/package-json.5*
|
||||||
%doc %{_mandir}/man5/package-lock-json.5*
|
%doc %{_mandir}/man5/package-lock-json.5*
|
||||||
%doc %{_mandir}/man5/npm-shrinkwrap-json.5*
|
%doc %{_mandir}/man5/npm-shrinkwrap-json.5*
|
||||||
|
%doc %{_mandir}/man5/npm-global.5.*
|
||||||
|
%doc %{_mandir}/man5/npm-json.5.*
|
||||||
%doc %{_mandir}/man7/config.7*
|
%doc %{_mandir}/man7/config.7*
|
||||||
%doc %{_mandir}/man7/dependency-selectors.7*
|
%doc %{_mandir}/man7/dependency-selectors.7*
|
||||||
%doc %{_mandir}/man7/developers.7*
|
%doc %{_mandir}/man7/developers.7*
|
||||||
@ -714,6 +731,42 @@ end
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 21 2024 Lukas Javorsky <ljavorsk@redhat.com> - 1:18.19.1-1
|
||||||
|
- Rebase to version 18.19.1
|
||||||
|
- Fixes: CVE-2024-21892 CVE-2024-22019 (high)
|
||||||
|
- Fixes: CVE-2023-46809 (medium)
|
||||||
|
|
||||||
|
* Fri Jan 19 2024 Lukas Javorsky <ljavorsk@redhat.com> - 1:18.19.0-1
|
||||||
|
- Rebase to version 18.19.0
|
||||||
|
- Resolves: RHEL-21439
|
||||||
|
|
||||||
|
* Wed Aug 23 2023 Jan Staněk <jstanek@redhat.com> - 1:18.17.1-1
|
||||||
|
- Rebase to version 18.17.1
|
||||||
|
Resolves: rhbz#2228939
|
||||||
|
Resolves: CVE-2023-32002 CVE-2023-32006 CVE-2023-32559
|
||||||
|
- Specify proper OpenSSL configuration section build
|
||||||
|
|
||||||
|
* Wed Jul 12 2023 Jan Staněk <jstanek@redhat.com> - 1:18.16.1-1
|
||||||
|
- Rebase to 18.16.1
|
||||||
|
Resolves: rhbz#2188290 rhbz#2166926
|
||||||
|
Resolves: CVE-2023-30581 CVE-2023-30588 CVE-2023-30589 CVE-2023-30590
|
||||||
|
- Replace /usr/etc/npmrc symlink with builtin configuration
|
||||||
|
Resolves: rhbz#2222287
|
||||||
|
|
||||||
|
* Tue May 30 2023 Jan Staněk <jstanek@redhat.com> - 1:18.14.2-3
|
||||||
|
- Update bundled c-ares to 1.19.1
|
||||||
|
Resolves: CVE-2022-4904
|
||||||
|
Resolves: CVE-2023-31124 CVE-2023-31130 CVE-2023-31147 CVE-2023-32067
|
||||||
|
|
||||||
|
* Tue Mar 21 2023 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:18.14.2-2
|
||||||
|
- Provide simduft
|
||||||
|
|
||||||
|
* Tue Mar 21 2023 Zuzana Svetlikova <zsvetlik@redhat.com> - 1:18.14.2-1
|
||||||
|
- Rebase to 18.14.2
|
||||||
|
- Resolves: #2178086
|
||||||
|
- Resolves: CVE-2022-25881, CVE-2023-23936, CVE-2023-24807
|
||||||
|
- Resolves: CVE-2023-23918, CVE-2023-23919, CVE-2023-23920
|
||||||
|
|
||||||
* Fri Nov 18 2022 Jan Staněk <jstanek@redhat.com> - 1:18.12.1-2
|
* Fri Nov 18 2022 Jan Staněk <jstanek@redhat.com> - 1:18.12.1-2
|
||||||
- Update version of bundled histogram
|
- Update version of bundled histogram
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user