import nodejs-18.6.0-1.module+el8.7.0+16061+0a247725

This commit is contained in:
CentOS Sources 2022-08-02 20:37:39 +00:00 committed by Stepan Oksanichenko
parent 509824398c
commit 083ff151ab
4 changed files with 24 additions and 18 deletions

2
.gitignore vendored
View File

@ -1,2 +1,2 @@
SOURCES/icu4c-71_1-src.tgz
SOURCES/node-v18.2.0-stripped.tar.gz
SOURCES/node-v18.6.0-stripped.tar.gz

View File

@ -1,2 +1,2 @@
406b0c8635288b772913b6ff646451e69748878a SOURCES/icu4c-71_1-src.tgz
4526d7fcdd06ec712ebbdfd01468be65e06b458f SOURCES/node-v18.2.0-stripped.tar.gz
a82035bca2c75dd8321015463bd73996a0842a1c SOURCES/node-v18.6.0-stripped.tar.gz

View File

@ -1,4 +1,4 @@
From 142fe30256f96e28b49f55d5c72e604719aaaad8 Mon Sep 17 00:00:00 2001
From fe1e9d3f6d87416aa4cd8f8bee186d71a8ea2b0f Mon Sep 17 00:00:00 2001
From: Zuzana Svetlikova <zsvetlik@redhat.com>
Date: Fri, 17 Apr 2020 12:59:44 +0200
Subject: [PATCH] Disable running gyp on shared deps
@ -10,7 +10,7 @@ Signed-off-by: rpm-build <rpm-build>
2 files changed, 1 insertion(+), 18 deletions(-)
diff --git a/Makefile b/Makefile
index 4aace77..0bad864 100644
index e0d756f..c90bfa7 100644
--- a/Makefile
+++ b/Makefile
@@ -147,7 +147,7 @@ with-code-cache test-code-cache:
@ -23,17 +23,17 @@ index 4aace77..0bad864 100644
tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make
diff --git a/node.gyp b/node.gyp
index 86fe9a6..bfa5093 100644
index 6b3a6d9..5882cef 100644
--- a/node.gyp
+++ b/node.gyp
@@ -449,23 +449,6 @@
@@ -429,23 +429,6 @@
],
},
],
- }, {
- 'variables': {
- 'opensslconfig_internal': '<(obj_dir)/deps/openssl/openssl.cnf',
- 'opensslconfig': './deps/openssl/openssl/apps/openssl.cnf',
- 'opensslconfig': './deps/openssl/nodejs-openssl.cnf',
- },
- 'actions': [
- {
@ -42,8 +42,8 @@ index 86fe9a6..bfa5093 100644
- 'outputs': [ '<(opensslconfig_internal)', ],
- 'action': [
- 'python', 'tools/copyfile.py',
- './deps/openssl/openssl/apps/openssl.cnf',
- '<(obj_dir)/deps/openssl/openssl.cnf',
- '<(opensslconfig)',
- '<(opensslconfig_internal)',
- ],
- },
- ],

View File

@ -41,7 +41,7 @@
# than a Fedora release lifecycle.
%global nodejs_epoch 1
%global nodejs_major 18
%global nodejs_minor 2
%global nodejs_minor 6
%global nodejs_patch 0
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
@ -56,9 +56,9 @@
# Epoch is set to ensure clean upgrades from the old v8 package
%global v8_epoch 2
%global v8_major 10
%global v8_minor 1
%global v8_build 124
%global v8_patch 8
%global v8_minor 2
%global v8_build 154
%global v8_patch 13
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
%global v8_abi %{v8_major}.%{v8_minor}
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
@ -74,7 +74,7 @@
# llhttp - from deps/llhttp/include/llhttp.h
%global llhttp_major 6
%global llhttp_minor 0
%global llhttp_patch 6
%global llhttp_patch 7
%global llhttp_version %{llhttp_major}.%{llhttp_minor}.%{llhttp_patch}
# libuv - from deps/uv/include/uv/version.h
@ -134,8 +134,8 @@
# npm - from deps/npm/package.json
%global npm_epoch 1
%global npm_major 8
%global npm_minor 9
%global npm_patch 0
%global npm_minor 13
%global npm_patch 2
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
# uvwasi - from deps/uvwasi/include/uvwasi.h
@ -375,7 +375,7 @@ pathfix.py -i %{__python3} -pn $(find -type f ! -name "*.js")
find . -type f -exec sed -i "s~/usr\/bin\/env python~/usr/bin/python3~" {} \;
find . -type f -exec sed -i "s~/usr\/bin\/python\W~/usr/bin/python3~" {} \;
sed -i "s~usr\/bin\/python2~usr\/bin\/python3~" ./deps/v8/tools/gen-inlining-tests.py
sed -i "s~usr\/bin\/python.*$~usr\/bin\/python3~" ./deps/v8/tools/mb/mb_unittest.py
sed -i "s~usr\/bin\/python.*$~usr\/bin\/python3~" ./deps/v8/tools/mb/mb_test.py
find . -type f -exec sed -i "s~python -c~python3 -c~" {} \;
%endif
@ -675,8 +675,9 @@ end
%doc %{_mandir}/man5/npm-shrinkwrap-json.5*
%doc %{_mandir}/man7/config.7*
%doc %{_mandir}/man7/developers.7*
%doc %{_mandir}/man7/orgs.7*
%doc %{_mandir}/man7/logging.7*
%doc %{_mandir}/man7/orgs.7*
%doc %{_mandir}/man7/package-spec.7*
%doc %{_mandir}/man7/registry.7*
%doc %{_mandir}/man7/removal.7*
%doc %{_mandir}/man7/scope.7*
@ -692,6 +693,11 @@ end
%changelog
* Fri Jul 15 2022 Jan Staněk <jstanek@redhat.com> - 1:18.6.0-1
- Rebase to version 18.6.0
Resolves: CVE-2022-32212 CVE-2022-32213 CVE-2022-32214 CVE-2022-32215
Resolves: CVE-2022-29244
* Tue May 31 2022 Jan Staněk <jstanek@redhat.com> - 1:18.2.0-1
- Rebase to version 18.2.0