Upgrade to 2.2.21

Signed-off-by: Gris Ge <fge@redhat.com>
This commit is contained in:
Gris Ge 2023-12-15 19:19:27 +08:00
parent fc7f70b406
commit d2c17fdc30
4 changed files with 27 additions and 36 deletions

3
.gitignore vendored
View File

@ -106,3 +106,6 @@
/nmstate-2.2.15.tar.gz
/nmstate-2.2.15.tar.gz.asc
/nmstate-vendor-2.2.15.tar.xz
/nmstate-2.2.21.tar.gz
/nmstate-2.2.21.tar.gz.asc
/nmstate-vendor-2.2.21.tar.xz

View File

@ -1,33 +1,11 @@
From a78d7610a7a3adc4cd80433bdded7d37e738eb12 Mon Sep 17 00:00:00 2001
From: Gris Ge <fge@redhat.com>
Date: Mon, 16 Jan 2023 11:56:16 +0800
Subject: [PATCH] Workaround for Fedora rust packaging
Signed-off-by: Gris Ge <fge@redhat.com>
---
rust/src/lib/Cargo.toml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/rust/src/lib/Cargo.toml b/rust/src/lib/Cargo.toml
index 801b3e33..67c7f3dd 100644
--- a/rust/src/lib/Cargo.toml
+++ b/rust/src/lib/Cargo.toml
@@ -9,7 +9,7 @@ documentation = "https://nmstate.io"
repository = "https://github.com/nmstate/nmstate"
keywords = ["network", "linux"]
categories = ["network-programming", "os::linux-apis"]
-rust-version = "1.58"
+rust-version = "1.60"
edition = "2018"
[lib]
@@ -62,5 +62,5 @@ serde_yaml = "0.9"
diff -Nur nmstate-2.2.21.orig/rust/src/lib/Cargo.toml nmstate-2.2.21/rust/src/lib/Cargo.toml
--- nmstate-2.2.21.orig/rust/src/lib/Cargo.toml 2023-12-14 19:21:53.000000000 +0800
+++ nmstate-2.2.21/rust/src/lib/Cargo.toml 2023-12-15 19:04:02.936926574 +0800
@@ -61,6 +61,6 @@
[features]
default = ["query_apply", "gen_conf"]
default = ["query_apply", "gen_conf", "gen_revert"]
-query_apply = ["nispor", "nix", "zbus"]
+query_apply = ["dep:nispor", "dep:nix", "dep:zbus"]
gen_conf = []
--
2.39.0
gen_revert = []

View File

@ -2,7 +2,7 @@
%define libname libnmstate
Name: nmstate
Version: 2.2.15
Version: 2.2.21
Release: %autorelease
Summary: Declarative network manager API
License: Apache-2.0 AND LGPL-2.1-or-later
@ -11,9 +11,7 @@ Source0: %{url}/releases/download/v%{version}/%{srcname}-%{version}.tar.g
Source1: %{url}/releases/download/v%{version}/%{srcname}-%{version}.tar.gz.asc
Source2: https://nmstate.io/nmstate.gpg
Source3: %{url}/releases/download/v%{version}/%{srcname}-vendor-%{version}.tar.xz
# We use `dep: dep_name` to prevent rust packaging generate incorect dependency
# https://bugzilla.redhat.com/show_bug.cgi?id=2161128
# but list Requires manually
# https://github.com/nmstate/nmstate/pull/2497
Patch1: 0001-Workaround-for-Fedora-rust-packaging.patch
BuildRequires: patchelf
BuildRequires: python3-devel
@ -130,7 +128,7 @@ This package contains library source intended for building other packages
which use "%{name}" crate with gen_conf feature.
%package -n rust-%{name}+query_apply-devel
Summary: Rust crate of nmstate with default feature
Summary: Rust crate of nmstate with query_apply feature
BuildArch: noarch
License: Apache-2.0
# https://bugzilla.redhat.com/show_bug.cgi?id=2161128
@ -141,6 +139,15 @@ Requires: (crate(zbus/default) >= 1.9 with crate(zbus/default) < 2.0)
%description -n rust-%{name}+query_apply-devel
This package contains library source intended for building other packages
which use "%{name}" crate with query_apply feature.
%package -n rust-%{name}+gen_revert-devel
Summary: Rust crate of nmstate with gen_revert feature
BuildArch: noarch
License: Apache-2.0
%description -n rust-%{name}+gen_revert-devel
This package contains library source intended for building other packages
which use "%{name}" crate with gen_revert feature.
%endif
%prep
@ -231,6 +238,9 @@ popd
%files -n rust-%{name}+query_apply-devel
%ghost %{cargo_registry}/%{name}-%{version}/Cargo.toml
%files -n rust-%{name}+gen_revert-devel
%ghost %{cargo_registry}/%{name}-%{version}/Cargo.toml
%endif
%changelog

View File

@ -1,4 +1,4 @@
SHA512 (nmstate-2.2.15.tar.gz) = 692d2414352d6346d2cfd3f008d6cc36955ec328d574b5d94c536b8d5a9baa125ceaa5bf9b84632252df9fe5ef48409fdd3bd9296ff50d387b93b2dbe4963e9e
SHA512 (nmstate-2.2.15.tar.gz.asc) = d5da10e6b14c43536ef88f1e38c7142e74d7a13b5d07af4e3a46ff50fed359f762ee737004ad5203a01f56704c70ccab3fe035c9cc215598d7025058834e9e8e
SHA512 (nmstate-2.2.21.tar.gz) = 5b367547064eba4f76bb1ccccab517bf67bf8b9f6d1afd9041ccba075863e168b2f29719276f4cc8eaf6e1fe6e1ce941828f79d2f7bd08b187e09c1eb3156d22
SHA512 (nmstate-2.2.21.tar.gz.asc) = 9dc40cc990fdd12ec5f776a36c99c75a84dfc961207b8080de43e7564f38e9f0cada8d8e786e6ff4b8ca291446dc70920b6c966734d510e2293c259d68d3fa5d
SHA512 (nmstate.gpg) = bfbf3620045f3c1f15eaf6877fd7407834a75d2650976f2327abd02ddb910aa34500f07a774dd17023c43dcba42a0ffc66f23cd6816fd9694acad2c5eed9e8d3
SHA512 (nmstate-vendor-2.2.15.tar.xz) = f20c2ff65c27bcf2dac0e1acb4dc4a55b76787d3532c0385a2aa5105d32b01c875b1a0024f79a8e696dea1dac0d430ee3a57b8d5ee7f2bb26c97765681319681
SHA512 (nmstate-vendor-2.2.21.tar.xz) = 9da67a516657b87d82318775ed47b826089cd970f00c1e62aa7a9a5898cd66c54cec400561f2c9704916e5c618bb6a63a41abacc33c5d0d2c647c86eef116294