Upgrade to 2.1.4 and remove rust devel package

Signed-off-by: Gris Ge <fge@redhat.com>
This commit is contained in:
Gris Ge 2022-08-23 14:17:31 +08:00
parent f07139dbc1
commit 8f29f16edd
4 changed files with 7 additions and 98 deletions

2
.gitignore vendored
View File

@ -75,3 +75,5 @@
/nmstate-2.1.0.tar.gz.asc
/nmstate-2.1.2.tar.gz
/nmstate-2.1.2.tar.gz.asc
/nmstate-2.1.4.tar.gz
/nmstate-2.1.4.tar.gz.asc

View File

@ -2,15 +2,14 @@
%define libname libnmstate
Name: nmstate
Version: 2.1.2
Release: 2%{?dist}
Version: 2.1.4
Release: 1%{?dist}
Summary: Declarative network manager API
License: LGPLv2+
URL: https://github.com/%{srcname}/%{srcname}
Source0: %{url}/releases/download/v%{version}/%{srcname}-%{version}.tar.gz
Source1: %{url}/releases/download/v%{version}/%{srcname}-%{version}.tar.gz.asc
Source2: https://nmstate.io/nmstate.gpg
Patch1: use_uuid_1_1.patch
BuildRequires: patchelf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@ -18,6 +17,7 @@ BuildRequires: gnupg2
BuildRequires: systemd-devel
BuildRequires: systemd-rpm-macros
BuildRequires: rust-packaging
BuildRequires: (crate(ipnet/default) >= 2.5 with crate(ipnet/default) < 3.0)
BuildRequires: (crate(serde/default) >= 1.0 with crate(serde/default) < 2.0)
BuildRequires: (crate(serde/derive) >= 1.0 with crate(serde/derive) < 2.0)
BuildRequires: (crate(serde_json/default) >= 1.0 with crate(serde_json/default) < 2.0)
@ -89,22 +89,6 @@ Obsoletes: nmstate-plugin-ovsdb < 2.0-1
%description -n python3-%{libname}
This package contains the Python 3 library for Nmstate.
%package -n rust-%{name}-devel
Summary: Rust crate of nmstate
BuildArch: noarch
%description -n rust-%{name}-devel
This package contains library source intended for building other packages
which use "%{name}" crate.
%package -n rust-%{name}+default-devel
Summary: Rust crate of nmstate with default feature
BuildArch: noarch
%description -n rust-%{name}+default-devel
This package contains library source intended for building other packages
which use "%{name}" crate with default feature.
%prep
gpg2 --import --import-options import-export,import-minimal \
%{SOURCE2} > ./gpgkey-mantainers.gpg
@ -167,18 +151,8 @@ popd
%{python3_sitelib}/%{libname}
%{python3_sitelib}/%{srcname}-*.egg-info/
%files -n rust-%{name}-devel
%license LICENSE
%{cargo_registry}/%{name}-%{version}/
%files -n rust-%{name}+default-devel
%ghost %{cargo_registry}/%{name}-%{version}/Cargo.toml
%files static
%{_libdir}/libnmstate.a
%changelog
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
%autochangelog

View File

@ -1,3 +1,3 @@
SHA512 (nmstate-2.1.2.tar.gz) = 4c50350f3e9a26420ec90b476230ea2702545666c005cf0d7e95f912f6586248df07fb85e5f8f4972ae1704e5bc104d94377c58f47435c636e04638432c75da2
SHA512 (nmstate-2.1.2.tar.gz.asc) = a05e158ea6c2cebf8453efeaca30cf4cc0e518a065cb392fb49ade6d89df9d804aff3a09a769e77378b1013f70b1b355fc980934d06d217637dcab59f688aedc
SHA512 (nmstate-2.1.4.tar.gz) = 698aa3f2d4ac68fe8d00ca1d984ce23f1ab8433885dcea8835d9023d4bc5313620c9064fd9c59d4bd46f111cf7ac14364ae29aa8817d553cba732e23ee4bd1e2
SHA512 (nmstate-2.1.4.tar.gz.asc) = 3ada247852b7236111f57e70e9dd597f8df0c954d2da4a36496639aa55fc65805b3fd6fcfa006ee60d21d9de4f9c1eee9c72abb217fc8da459500d6effd8f1ce
SHA512 (nmstate.gpg) = 91c6b1d8aef4944520d4bdd4e90121bbbbaf772444f5eb6081cee81e17b21b66798437cdc09a117c6fc77c54d798aaa30400857aa090cb2102b47841f45cf6eb

View File

@ -1,67 +0,0 @@
From 56dae17862eb284900439d2af21a715678f3e45a Mon Sep 17 00:00:00 2001
From: Gris Ge <fge@redhat.com>
Date: Mon, 11 Jul 2022 20:51:46 +0800
Subject: [PATCH] nm: Upgrade to uuid 1.1 crate
The uuid crate is upgrade from 0.8 to 1.1. Per Fedora request, we should
upgrade to latest version.
Signed-off-by: Gris Ge <fge@redhat.com>
---
rust/src/cli/Cargo.toml | 2 +-
rust/src/lib/Cargo.toml | 2 +-
rust/src/lib/nm/connection.rs | 2 +-
rust/src/lib/nm/nm_dbus/nm_api.rs | 2 +-
4 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/rust/src/cli/Cargo.toml b/rust/src/cli/Cargo.toml
index 50d8305b..34bd8fdd 100644
--- a/rust/src/cli/Cargo.toml
+++ b/rust/src/cli/Cargo.toml
@@ -17,4 +17,4 @@ env_logger = "0.9.0"
log = "0.4.14"
serde_json = "1.0.75"
ctrlc = "3.2.1"
-uuid = { version = "0.8", features = ["v4"] }
+uuid = { version = "1.1", features = ["v4"] }
diff --git a/rust/src/lib/Cargo.toml b/rust/src/lib/Cargo.toml
index 718e6e64..767235e2 100644
--- a/rust/src/lib/Cargo.toml
+++ b/rust/src/lib/Cargo.toml
@@ -21,7 +21,7 @@ nispor = "1.2.7"
nix = "0.24.1"
serde = { version = "1.0.132", features = ["derive"] }
serde_json = "1.0.68"
-uuid = { version = "0.8.2", features = ["v4", "v5"] }
+uuid = { version = "1.1", features = ["v4", "v5"] }
zbus = "1.9.2"
zvariant = "2.10.0"
diff --git a/rust/src/lib/nm/connection.rs b/rust/src/lib/nm/connection.rs
index 3a49a9f8..2b85af39 100644
--- a/rust/src/lib/nm/connection.rs
+++ b/rust/src/lib/nm/connection.rs
@@ -509,6 +509,6 @@ fn uuid_from_name_and_type(
&uuid::Uuid::NAMESPACE_URL,
format!("{}://{}", iface_type, iface_name).as_bytes(),
)
- .to_hyphenated()
+ .hyphenated()
.to_string()
}
diff --git a/rust/src/lib/nm/nm_dbus/nm_api.rs b/rust/src/lib/nm/nm_dbus/nm_api.rs
index eb999b78..9b14d342 100644
--- a/rust/src/lib/nm/nm_dbus/nm_api.rs
+++ b/rust/src/lib/nm/nm_dbus/nm_api.rs
@@ -205,7 +205,7 @@ impl<'a> NmApi<'a> {
pub fn uuid_gen() -> String {
// Use Linux random number generator (RNG) to generate UUID
- uuid::Uuid::new_v4().to_hyphenated().to_string()
+ uuid::Uuid::new_v4().hyphenated().to_string()
}
pub fn active_connections_get(
--
2.37.0