New version v7.91 (#1884838)
This commit is contained in:
parent
32adb9432b
commit
f0bb953f1a
@ -1,32 +0,0 @@
|
||||
From 33f421fd6e68fcb8ed50071661d9704717c81b2b Mon Sep 17 00:00:00 2001
|
||||
From: dmiller <dmiller@e0a8ed71-7df4-0310-8962-fdc924857419>
|
||||
Date: Tue, 3 Dec 2019 17:04:13 +0000
|
||||
Subject: [PATCH] Avoid assertion failure when unsolicited ARP response
|
||||
received
|
||||
|
||||
We probably want a more explicit handling of the case where we get an
|
||||
ARP response to a request that we did not send (system's own, or another
|
||||
Nmap scan running at the same time). In any case, this ought to solve
|
||||
the crashes reported as #1797 and #1764.
|
||||
---
|
||||
scan_engine.cc | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scan_engine.cc b/scan_engine.cc
|
||||
index bd73cc8ead..7a4766da26 100644
|
||||
--- a/scan_engine.cc
|
||||
+++ b/scan_engine.cc
|
||||
@@ -1275,7 +1275,12 @@ int UltraScanInfo::removeCompletedHosts() {
|
||||
}
|
||||
if (timedout)
|
||||
gstats->num_hosts_timedout++;
|
||||
- hss->target->stopTimeOutClock(&now);
|
||||
+ /* We may have received an ARP response before we sent a probe, which
|
||||
+ * would mean the timeout clock is not running. Avoid an assertion
|
||||
+ * failure here by checking first. */
|
||||
+ if (hss->target->timeOutClockRunning()) {
|
||||
+ hss->target->stopTimeOutClock(&now);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
return hostsRemoved;
|
10
nmap.spec
10
nmap.spec
@ -5,9 +5,9 @@
|
||||
|
||||
Name: nmap
|
||||
Epoch: 2
|
||||
Version: 7.80
|
||||
Version: 7.91
|
||||
#global prerelease TEST5
|
||||
Release: 6%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Network exploration tool and security scanner
|
||||
URL: http://nmap.org/
|
||||
# Uses combination of licenses based on GPL license, but with extra modification
|
||||
@ -25,8 +25,6 @@ Patch2: nmap-4.52-noms.patch
|
||||
# upstream provided patch for rhbz#845005, not yet in upstream repository
|
||||
Patch3: ncat_reg_stdin.diff
|
||||
Patch4: nmap-6.25-displayerror.patch
|
||||
# https://github.com/nmap/nmap/commit/33f421fd6e68fcb8ed50071661d9704717c81b2b.patch
|
||||
Patch5: nmap-unsolicited_arp_assert.patch
|
||||
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
@ -117,7 +115,7 @@ ln -s ncat %{buildroot}%{_bindir}/nc
|
||||
%find_lang nmap --with-man
|
||||
|
||||
%files -f nmap.lang
|
||||
%license COPYING*
|
||||
%license LICENSE
|
||||
%doc docs/README
|
||||
%doc docs/nmap.usage.txt
|
||||
%{_bindir}/nmap
|
||||
@ -127,7 +125,7 @@ ln -s ncat %{buildroot}%{_bindir}/nc
|
||||
%{_datadir}/nmap
|
||||
|
||||
%files ncat
|
||||
%license COPYING
|
||||
%license LICENSE
|
||||
%doc ncat/docs/AUTHORS ncat/docs/README ncat/docs/THANKS ncat/docs/examples
|
||||
%{_bindir}/nc
|
||||
%{_bindir}/ncat
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (nmap-7.80.tar.bz2) = d4384d3ebf4f3abf3588eed5433f733874ecdceb9342a718dc36db19634b0cc819d73399974eb0a9a9c9dd9e5c88473e07644ec91db28b0c072552b54430be6b
|
||||
SHA512 (nmap-7.91.tar.bz2) = 9d59f031b5f748311e9f9a0b9d05ad4a7a70fc6ac17598d7c4c81a4825c95d53817d74435d839e67b9379a052f2d37889fd634f9c75301a851f465d60fb9974d
|
||||
|
Loading…
Reference in New Issue
Block a user