finally got rid of gtk+-devel dependency

This commit is contained in:
Harald Hoyer 2005-08-03 13:02:01 +00:00
parent 0592d96e1c
commit b56cc66421
2 changed files with 93 additions and 13 deletions

View File

@ -1,6 +1,5 @@
diff -ur nmap-3.78/nmapfe/aclocal.m4 nmap-3.78-gtk2/nmapfe/aclocal.m4
--- nmap-3.78/nmapfe/aclocal.m4 2004-10-07 23:59:47.000000000 +0200
+++ nmap-3.78-gtk2/nmapfe/aclocal.m4 2005-02-02 15:18:11.000000000 +0100
--- nmap-3.81/nmapfe/aclocal.m4.gtk2 2004-10-07 23:59:47.000000000 +0200
+++ nmap-3.81/nmapfe/aclocal.m4 2005-08-03 14:41:02.000000000 +0200
@@ -1,6 +1,6 @@
-# aclocal.m4 generated automatically by aclocal 1.6.3 -*- Autoconf -*-
+# generated automatically by aclocal 1.9.2 -*- Autoconf -*-
@ -227,9 +226,8 @@ diff -ur nmap-3.78/nmapfe/aclocal.m4 nmap-3.78-gtk2/nmapfe/aclocal.m4
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
fi
diff -ur nmap-3.78/nmapfe/configure nmap-3.78-gtk2/nmapfe/configure
--- nmap-3.78/nmapfe/configure 2004-10-07 23:59:48.000000000 +0200
+++ nmap-3.78-gtk2/nmapfe/configure 2005-02-02 15:18:12.000000000 +0100
--- nmap-3.81/nmapfe/configure.gtk2 2004-10-07 23:59:48.000000000 +0200
+++ nmap-3.81/nmapfe/configure 2005-08-03 14:41:02.000000000 +0200
@@ -272,7 +272,7 @@
PACKAGE_BUGREPORT=
@ -526,9 +524,8 @@ diff -ur nmap-3.78/nmapfe/configure nmap-3.78-gtk2/nmapfe/configure
s,@GTK_CFLAGS@,$GTK_CFLAGS,;t t
s,@GTK_LIBS@,$GTK_LIBS,;t t
s,@build@,$build,;t t
diff -ur nmap-3.78/nmapfe/configure.ac nmap-3.78-gtk2/nmapfe/configure.ac
--- nmap-3.78/nmapfe/configure.ac 2004-10-07 23:57:46.000000000 +0200
+++ nmap-3.78-gtk2/nmapfe/configure.ac 2005-02-02 15:18:01.000000000 +0100
--- nmap-3.81/nmapfe/configure.ac.gtk2 2004-10-07 23:57:46.000000000 +0200
+++ nmap-3.81/nmapfe/configure.ac 2005-08-03 14:41:02.000000000 +0200
@@ -9,8 +9,8 @@
#AM_PATH_GTK(1.0.0,
# [LIBS="$LIBS $GTK_LIBS" CFLAGS="$CFLAGS $GTK_CFLAGS"],
@ -540,10 +537,8 @@ diff -ur nmap-3.78/nmapfe/configure.ac nmap-3.78-gtk2/nmapfe/configure.ac
AC_DEFINE(MISSING_GTK) \
AC_MSG_WARN(NMAPFE WILL NOT BE BUILT -- BUT NMAP SHOULD STILL WORK ))
Nur in nmap-3.78-gtk2/nmapfe: Makefile.
diff -ur nmap-3.78/nmapfe/nmapfe.c nmap-3.78-gtk2/nmapfe/nmapfe.c
--- nmap-3.78/nmapfe/nmapfe.c 2004-08-29 11:12:04.000000000 +0200
+++ nmap-3.78-gtk2/nmapfe/nmapfe.c 2005-02-02 16:10:37.000000000 +0100
--- nmap-3.81/nmapfe/nmapfe.c.gtk2 2004-08-29 11:12:04.000000000 +0200
+++ nmap-3.81/nmapfe/nmapfe.c 2005-08-03 14:41:02.000000000 +0200
@@ -349,7 +349,7 @@
/* Exit button (rightmost in hbox) */
@ -976,3 +971,87 @@ diff -ur nmap-3.78/nmapfe/nmapfe.c nmap-3.78-gtk2/nmapfe/nmapfe.c
return(helpDialog);
}
--- nmap-3.81/configure.gtk2 2004-10-17 05:49:33.000000000 +0200
+++ nmap-3.81/configure 2005-08-03 14:51:15.000000000 +0200
@@ -7601,80 +7601,8 @@
if test "${with_nmapfe}" = "yes"; then
-# Extract the first word of "gtk-config", so it can be a program name with args.
-set dummy gtk-config; ac_word=$2
-echo "$as_me:$LINENO: checking for $ac_word" >&5
-echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-if test "${ac_cv_path_GTK_CONFIG+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
- case $GTK_CONFIG in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_GTK_CONFIG="$GTK_CONFIG" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_GTK_CONFIG="$as_dir/$ac_word$ac_exec_ext"
- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
-done
-
- test -z "$ac_cv_path_GTK_CONFIG" && ac_cv_path_GTK_CONFIG="no"
- ;;
-esac
+ nmap_cfg_subdirs="$nmap_cfg_subdirs nmapfe"
fi
-GTK_CONFIG=$ac_cv_path_GTK_CONFIG
-
-if test -n "$GTK_CONFIG"; then
- echo "$as_me:$LINENO: result: $GTK_CONFIG" >&5
-echo "${ECHO_T}$GTK_CONFIG" >&6
-else
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
-fi
-
-echo "$as_me:$LINENO: checking If you have GTK+ installed" >&5
-echo $ECHO_N "checking If you have GTK+ installed... $ECHO_C" >&6
-if test "$GTK_CONFIG" = "no" ; then
- echo "$as_me:$LINENO: result: no" >&5
-echo "${ECHO_T}no" >&6
- { echo "$as_me:$LINENO: WARNING: Gtk+ has not been installed -> nmapfe will not be made" >&5
-echo "$as_me: WARNING: Gtk+ has not been installed -> nmapfe will not be made" >&2;}
-else
- GTK_NEEDED_MAJOR=1
- GTK_NEEDED_MINOR=2
- GTK_NEEDED_MICRO=7
- GTK_MINVERSION=$GTK_NEEDED_MAJOR.$GTK_NEEDED_MINOR.$GTK_NEEDED_MICRO
- ver=`gtk-config --version`
- major=`echo $ver|sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- minor=`echo $ver|sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- micro=`echo $ver|sed 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
- echo "$as_me:$LINENO: result: $ver" >&5
-echo "${ECHO_T}$ver" >&6
- if test $major -lt $GTK_NEEDED_MAJOR -o $major -eq $GTK_NEEDED_MAJOR \
- -a $minor -lt $GTK_NEEDED_MINOR -o $minor -eq $GTK_NEEDED_MINOR \
- -a $micro -lt $GTK_NEEDED_MICRO; then
- { echo "$as_me:$LINENO: WARNING: An old version of GTK+ ($major.$minor.$micro) was found.\n \
- You need at least version $GTK_MINVERSION.\n Subdir X-windows \
- will not be made" >&5
-echo "$as_me: WARNING: An old version of GTK+ ($major.$minor.$micro) was found.\n \
- You need at least version $GTK_MINVERSION.\n Subdir X-windows \
- will not be made" >&2;}
- else
- nmap_cfg_subdirs="$nmap_cfg_subdirs nmapfe"
- fi
-fi
-fi
-
-
subdirs="$subdirs $nmap_cfg_subdirs "

View File

@ -91,6 +91,7 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Aug 03 2005 Harald Hoyer <harald@redhat.com> - 2:3.81-4
- removed references how to scan microsoft.com (bz #164962)
- finally got rid of gtk+-devel dependency
* Thu Apr 21 2005 Harald Hoyer <harald@redhat.com> - 2:3.81-3
- removed gtk+ requirement