- new upstream version
This commit is contained in:
parent
01395c5787
commit
a36200cc74
@ -1 +1,4 @@
|
||||
nmap-4.20.tar.bz2
|
||||
nmap-4.52.tar.bz2
|
||||
nmapfe-32.png
|
||||
nmapfe-48.png
|
||||
zenmap.desktop
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- nmap-2.53/tcpip.h.orig Tue May 16 18:21:58 2000
|
||||
+++ nmap-2.53/tcpip.h Tue May 16 18:22:09 2000
|
||||
@@ -354,9 +354,9 @@
|
||||
/* Hex dump */
|
||||
int get_link_offset(char *device);
|
||||
char *readip_pcap(pcap_t *pd, unsigned int *len, long to_usec);
|
||||
-#ifndef HAVE_INET_ATON
|
||||
+/*#ifndef HAVE_INET_ATON
|
||||
int inet_aton(register const char *, struct in_addr *);
|
||||
-#endif
|
||||
+#endif*/
|
||||
|
||||
|
||||
#endif /*TCPIP_H*/
|
||||
--- nmap-2.53/nmap.h.orig Tue May 16 18:18:00 2000
|
||||
+++ nmap-2.53/nmap.h Tue May 16 18:18:30 2000
|
||||
@@ -362,9 +362,9 @@
|
||||
void skid_output(unsigned char *s);
|
||||
|
||||
/* From glibc 2.0.6 because Solaris doesn't seem to have this function */
|
||||
-#ifndef HAVE_INET_ATON
|
||||
+/*#ifndef HAVE_INET_ATON
|
||||
int inet_aton(register const char *, struct in_addr *);
|
||||
-#endif
|
||||
+#endif*/
|
||||
#ifndef HAVE_SNPRINTF
|
||||
int snprintf ( char *str, size_t n, const char *format, ... );
|
||||
#endif
|
@ -1,12 +0,0 @@
|
||||
--- nmap-2.53/Makefile.in.tim Thu Jun 8 17:41:49 2000
|
||||
+++ nmap-2.53/Makefile.in Thu Jun 8 17:43:24 2000
|
||||
@@ -7,7 +7,8 @@
|
||||
sbindir = @sbindir@
|
||||
mandir = @mandir@
|
||||
srcdir = @srcdir@
|
||||
-nmapdatadir = @datadir@/nmap
|
||||
+datadir = @datadir@
|
||||
+nmapdatadir = $(datadir)/nmap
|
||||
deskdir = $(prefix)/share/gnome/apps/Utilities
|
||||
|
||||
CC = @CC@
|
1057
nmap-3.78-gtk2.patch
1057
nmap-3.78-gtk2.patch
File diff suppressed because it is too large
Load Diff
@ -1,22 +0,0 @@
|
||||
--- nmap-3.95/docs/nmap.usage.txt.noms 2005-12-08 09:20:22.000000000 +0100
|
||||
+++ nmap-3.95/docs/nmap.usage.txt 2005-12-19 11:44:03.000000000 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
Usage: nmap [Scan Type(s)] [Options] {target specification}
|
||||
TARGET SPECIFICATION:
|
||||
Can pass hostnames, IP addresses, networks, etc.
|
||||
- Ex: scanme.nmap.org, microsoft.com/24, 192.168.0.1; 10.0.0-255.1-254
|
||||
+ Ex: scanme.nmap.org, 192.168.0.1; 10.0.0-255.1-254
|
||||
-iL <inputfilename>: Input from list of hosts/networks
|
||||
-iR <num hosts>: Choose random targets
|
||||
--exclude <host1[,host2][,host3],...>: Exclude hosts/networks
|
||||
--- nmap-3.95/docs/nmap.1.noms 2005-12-08 09:20:29.000000000 +0100
|
||||
+++ nmap-3.95/docs/nmap.1 2005-12-19 11:43:01.000000000 +0100
|
||||
@@ -94,7 +94,7 @@
|
||||
Usage: nmap [Scan Type(s)] [Options] {target specification}
|
||||
TARGET SPECIFICATION:
|
||||
Can pass hostnames, IP addresses, networks, etc.
|
||||
- Ex: scanme.nmap.org, microsoft.com/24, 192.168.0.1; 10.0.0\-255.1\-254
|
||||
+ Ex: scanme.nmap.org, 192.168.0.1; 10.0.0\-255.1\-254
|
||||
\-iL <inputfilename>: Input from list of hosts/networks
|
||||
\-iR <num hosts>: Choose random targets
|
||||
\-\-exclude <host1[,host2][,host3],...>: Exclude hosts/networks
|
@ -1,20 +0,0 @@
|
||||
--- nmap-4.20/Makefile.in.lr 2007-01-30 14:19:01.000000000 +0100
|
||||
+++ nmap-4.20/Makefile.in 2007-01-30 14:19:38.000000000 +0100
|
||||
@@ -152,7 +152,7 @@
|
||||
|
||||
install-nmap: $(TARGET)
|
||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
|
||||
- $(INSTALL) -c -m 755 -s nmap $(DESTDIR)$(bindir)/nmap
|
||||
+ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
|
||||
$(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
|
||||
$(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
|
||||
$(INSTALL) -c -m 644 docs/nmap.dtd $(DESTDIR)$(nmapdatadir)/
|
||||
@@ -167,7 +167,7 @@
|
||||
install-nmapfe: $(TARGETNMAPFE)
|
||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir) $(DESTDIR)$(deskdir)
|
||||
@echo "If the next command fails -- you cannot use the X front end"
|
||||
- -test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 -s nmapfe/nmapfe $(DESTDIR)$(bindir)/nmapfe && rm -f $(DESTDIR)$(bindir)/xnmap && $(SHTOOL) mkln -f -s $(DESTDIR)$(bindir)/nmapfe $(DESTDIR)$(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(DESTDIR)$(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(DESTDIR)$(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(DESTDIR)$(mandir)/man1/xnmap.1
|
||||
+ -test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 nmapfe/nmapfe $(DESTDIR)$(bindir)/nmapfe && rm -f $(DESTDIR)$(bindir)/xnmap && $(SHTOOL) mkln -f -s $(DESTDIR)$(bindir)/nmapfe $(DESTDIR)$(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(DESTDIR)$(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(DESTDIR)$(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(DESTDIR)$(mandir)/man1/xnmap.1
|
||||
|
||||
install: install-nmap $(INSTALLNMAPFE)
|
||||
|
64
nmap.spec
64
nmap.spec
@ -1,22 +1,26 @@
|
||||
Summary: Network exploration tool and security scanner
|
||||
Name: nmap
|
||||
Version: 4.20
|
||||
Release: 6.1%{?dist}
|
||||
Version: 4.52
|
||||
Release: 1%{?dist}
|
||||
License: BSD with advertising, BSD, GPLv2
|
||||
Group: Applications/System
|
||||
Source0: http://download.insecure.org/nmap/dist/%{name}-%{version}.tar.bz2
|
||||
Source1: nmapfe.desktop
|
||||
Source1: zenmap.desktop
|
||||
Source2: nmapfe-32.png
|
||||
Source3: nmapfe-48.png
|
||||
Patch3: nmap-3.81-noms.patch
|
||||
Patch4: nmap-4.03-mktemp.patch
|
||||
Patch5: nmap-4.20-nostrip.patch
|
||||
Patch1: nmap-4.03-mktemp.patch
|
||||
Patch2: nmap-4.52-noms.patch
|
||||
Patch3: nmap-4.52-nostrip.patch
|
||||
Patch4: nmap-4.52-pixmaps.patch
|
||||
URL: http://www.insecure.org/nmap/
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Epoch: 2
|
||||
BuildRequires: openssl-devel, gtk2-devel, pcre-devel, libpcap-devel
|
||||
BuildRequires: openssl-devel, gtk2-devel
|
||||
BuildRequires: /usr/bin/desktop-file-install
|
||||
|
||||
%define pixmap_srcdir zenmap/share/pixmaps
|
||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
|
||||
%description
|
||||
Nmap is a utility for network exploration or security auditing. It supports
|
||||
ping scanning (determine which hosts are up), many port scanning techniques
|
||||
@ -26,19 +30,25 @@ and port specification, decoy scanning, determination of TCP sequence
|
||||
predictability characteristics, reverse-identd scanning, and more.
|
||||
|
||||
%package frontend
|
||||
Summary: Gtk+ frontend for nmap
|
||||
Summary: the GTK+ frontend for nmap
|
||||
Group: Applications/System
|
||||
Requires: nmap = %{epoch}:%{version}, gtk2
|
||||
BuildRequires: gtk2-devel libpng-devel
|
||||
Requires: nmap = %{epoch}:%{version} gtk2 python >= 2.5 pygtk2 python-sqlite2
|
||||
BuildRequires: python >= 2.5 pygtk2-devel libpng-devel
|
||||
%description frontend
|
||||
This package includes nmapfe, a Gtk+ frontend for nmap. The nmap package must
|
||||
This package includes zenmap, a GTK+ frontend for nmap. The nmap package must
|
||||
be installed before installing nmap-frontend.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch3 -p1 -b .noms
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch1 -p1 -b .mktemp
|
||||
%patch2 -p1 -b .noms
|
||||
%patch3 -p1 -b .nostrip
|
||||
%patch4 -p1 -b .pixmaps
|
||||
|
||||
# we want pixmaps in /usr/share/pixmaps/zenmap/
|
||||
mkdir %{pixmap_srcdir}/zenmap
|
||||
mv %{pixmap_srcdir}/*.svg %{pixmap_srcdir}/zenmap
|
||||
mv %{pixmap_srcdir}/*.png %{pixmap_srcdir}/zenmap
|
||||
|
||||
%build
|
||||
%configure --with-libpcap=/usr
|
||||
@ -48,8 +58,13 @@ make %{?_smp_mflags}
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
|
||||
#rm -f $RPM_BUILD_ROOT%{_datadir}/applications/nmapfe.desktop
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/uninstall_zenmap
|
||||
cp docs/zenmap.1 $RPM_BUILD_ROOT%{_mandir}/man1/
|
||||
gzip $RPM_BUILD_ROOT%{_mandir}/man1/* || :
|
||||
pushd $RPM_BUILD_ROOT%{_mandir}/man1
|
||||
ln -s zenmap.1.gz nmapfe.1.gz
|
||||
ln -s zenmap.1.gz xnmap.1.gz
|
||||
popd
|
||||
|
||||
desktop-file-install --vendor nmap \
|
||||
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||
@ -59,9 +74,9 @@ desktop-file-install --vendor nmap \
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
|
||||
install -m 0644 %{SOURCE2} \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/nmapfe.png
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/zenmap.png
|
||||
install -m 0644 %{SOURCE3} \
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/nmapfe.png
|
||||
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/zenmap.png
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
@ -75,18 +90,27 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc docs/nmap.usage.txt
|
||||
%{_bindir}/nmap
|
||||
%{_datadir}/nmap
|
||||
%{_libexecdir}/nmap
|
||||
%{_mandir}/man1/nmap.1.gz
|
||||
|
||||
%files frontend
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/zenmap
|
||||
%{_bindir}/nmapfe
|
||||
%{_bindir}/xnmap
|
||||
%{_datadir}/applications/nmapfe.desktop
|
||||
%{_datadir}/icons/hicolor/*/apps/nmapfe.png
|
||||
%{python_sitelib}/*
|
||||
%{_datadir}/applications/nmap-zenmap.desktop
|
||||
%{_datadir}/icons/*
|
||||
%{_datadir}/pixmaps/zenmap
|
||||
%{_datadir}/zenmap
|
||||
%{_mandir}/man1/zenmap.1.gz
|
||||
%{_mandir}/man1/nmapfe.1.gz
|
||||
%{_mandir}/man1/xnmap.1.gz
|
||||
|
||||
%changelog
|
||||
* Mon Jan 07 2008 Tomas Smetana <tsmetana@redhat.com> - 2:4.52-1
|
||||
- new upstream version
|
||||
|
||||
* Wed Dec 05 2007 Tomas Smetana <tsmetana@redhat.com> - 2:4.20-6.1
|
||||
- rebuild
|
||||
|
||||
|
@ -1,12 +0,0 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=NmapFE
|
||||
GenericName=Nmap Security Scanner
|
||||
Comment=GUI frontend for Nmap security/port scanner
|
||||
Version=1.0
|
||||
TryExec=nmapfe
|
||||
Exec=nmapfe
|
||||
Icon=nmapfe
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Application;System;Security;GTK
|
Loading…
Reference in New Issue
Block a user