Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/nmap.git#29fdaff88f7f7d6bb4b2e3dce8f086a08c2f03db
This commit is contained in:
parent
66971bc1ca
commit
741f2c3028
31
nmap.spec
31
nmap.spec
@ -7,7 +7,7 @@ Name: nmap
|
|||||||
Epoch: 3
|
Epoch: 3
|
||||||
Version: 7.80
|
Version: 7.80
|
||||||
#global prerelease TEST5
|
#global prerelease TEST5
|
||||||
Release: 9%{?dist}
|
Release: 11%{?dist}
|
||||||
Summary: Network exploration tool and security scanner
|
Summary: Network exploration tool and security scanner
|
||||||
URL: http://nmap.org/
|
URL: http://nmap.org/
|
||||||
# Uses combination of licenses based on GPL license, but with extra modification
|
# Uses combination of licenses based on GPL license, but with extra modification
|
||||||
@ -31,6 +31,8 @@ Patch4: nmap-6.25-displayerror.patch
|
|||||||
# https://github.com/nmap/nmap/commit/33f421fd6e68fcb8ed50071661d9704717c81b2b.patch
|
# https://github.com/nmap/nmap/commit/33f421fd6e68fcb8ed50071661d9704717c81b2b.patch
|
||||||
Patch5: nmap-unsolicited_arp_assert.patch
|
Patch5: nmap-unsolicited_arp_assert.patch
|
||||||
Patch6: nmap-safe_fd_functions.patch
|
Patch6: nmap-safe_fd_functions.patch
|
||||||
|
# https://github.com/nmap/nmap/pull/2247
|
||||||
|
Patch7: nmap_resolve_config.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: automake make
|
BuildRequires: automake make
|
||||||
@ -68,6 +70,8 @@ analysis tool (nping).
|
|||||||
|
|
||||||
%package ncat
|
%package ncat
|
||||||
Summary: Nmap's Netcat replacement
|
Summary: Nmap's Netcat replacement
|
||||||
|
Requires(post): %{_sbindir}/alternatives
|
||||||
|
Requires(preun): %{_sbindir}/alternatives
|
||||||
Obsoletes: nc < 1.109.20120711-2
|
Obsoletes: nc < 1.109.20120711-2
|
||||||
Obsoletes: nc6 < 1.00-22
|
Obsoletes: nc6 < 1.00-22
|
||||||
Provides: nc nc6
|
Provides: nc nc6
|
||||||
@ -118,12 +122,21 @@ make DESTDIR=%{buildroot} STRIP=true install
|
|||||||
rm -f %{buildroot}%{_datadir}/ncat/ca-bundle.crt
|
rm -f %{buildroot}%{_datadir}/ncat/ca-bundle.crt
|
||||||
rmdir %{buildroot}%{_datadir}/ncat
|
rmdir %{buildroot}%{_datadir}/ncat
|
||||||
|
|
||||||
#we provide 'nc' replacement
|
#we provide 'nc' replacement (#1653119)
|
||||||
ln -s ncat.1.gz %{buildroot}%{_mandir}/man1/nc.1.gz
|
touch %{buildroot}%{_mandir}/man1/nc.1.gz
|
||||||
ln -s ncat %{buildroot}%{_bindir}/nc
|
touch %{buildroot}%{_bindir}/nc
|
||||||
|
|
||||||
%find_lang nmap --with-man
|
%find_lang nmap --with-man
|
||||||
|
|
||||||
|
%post ncat
|
||||||
|
%{_sbindir}/alternatives --install %{_bindir}/nc nc %{_bindir}/ncat 10 \
|
||||||
|
--slave %{_mandir}/man1/nc.1.gz nc-man %{_mandir}/man1/ncat.1.gz
|
||||||
|
|
||||||
|
%preun ncat
|
||||||
|
if [ $1 -eq 0 ]; then
|
||||||
|
%{_sbindir}/alternatives --remove nc %{_bindir}/ncat
|
||||||
|
fi
|
||||||
|
|
||||||
%files -f nmap.lang
|
%files -f nmap.lang
|
||||||
%license COPYING*
|
%license COPYING*
|
||||||
%doc docs/README
|
%doc docs/README
|
||||||
@ -137,12 +150,18 @@ ln -s ncat %{buildroot}%{_bindir}/nc
|
|||||||
%files ncat
|
%files ncat
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%doc ncat/docs/AUTHORS ncat/docs/README ncat/docs/THANKS ncat/docs/examples
|
%doc ncat/docs/AUTHORS ncat/docs/README ncat/docs/THANKS ncat/docs/examples
|
||||||
%{_bindir}/nc
|
%ghost %{_bindir}/nc
|
||||||
%{_bindir}/ncat
|
%{_bindir}/ncat
|
||||||
%{_mandir}/man1/nc.1.gz
|
%ghost %{_mandir}/man1/nc.1.gz
|
||||||
%{_mandir}/man1/ncat.1.gz
|
%{_mandir}/man1/ncat.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Mar 07 2021 Robert Scheck <robert@fedoraproject.org> - 3:7.80-11
|
||||||
|
- Manage nc symlink using alternatives (#1653119)
|
||||||
|
|
||||||
|
* Wed Feb 10 2021 Pavel Zhukov <pzhukov@redhat.com> - 3:7.80-10
|
||||||
|
- Do not listen on ipv6 if it's disabled
|
||||||
|
|
||||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3:7.80-9
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3:7.80-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
12
nmap_resolve_config.patch
Normal file
12
nmap_resolve_config.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/ncat/ncat_core.c b/ncat/ncat_core.c
|
||||||
|
index b76d5ea..9f0b0cf 100644
|
||||||
|
--- a/ncat/ncat_core.c
|
||||||
|
+++ b/ncat/ncat_core.c
|
||||||
|
@@ -289,6 +289,7 @@ int resolve(const char *hostname, unsigned short port,
|
||||||
|
int result;
|
||||||
|
|
||||||
|
flags = 0;
|
||||||
|
+ flags |= AI_ADDRCONFIG;
|
||||||
|
if (o.nodns)
|
||||||
|
flags |= AI_NUMERICHOST;
|
||||||
|
|
Loading…
Reference in New Issue
Block a user