Fix build failure on incorrect Makefile version

Signed-off-by: Gris Ge <fge@redhat.com>
This commit is contained in:
Gris Ge 2023-07-21 21:33:52 +08:00
parent e150bb6d53
commit bee51a6eb1
2 changed files with 38 additions and 0 deletions

View File

@ -0,0 +1,37 @@
From 06bcfbceaff833478afd5a9d0ec0afa3dd70137c Mon Sep 17 00:00:00 2001
From: Gris Ge <fge@redhat.com>
Date: Fri, 21 Jul 2023 21:32:35 +0800
Subject: [PATCH] Makefile: Fix version 1.2.12
Signed-off-by: Gris Ge <fge@redhat.com>
---
Makefile.inc | 2 +-
src/python/setup.py | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.inc b/Makefile.inc
index 94766c6..4dfbcd1 100644
--- a/Makefile.inc
+++ b/Makefile.inc
@@ -1,4 +1,4 @@
-CLIB_VERSION=1.2.11
+CLIB_VERSION=1.2.12
CLIB_VERSION_MAJOR=$(shell echo $(CLIB_VERSION) | cut -f1 -d.)
CLIB_VERSION_MINOR=$(shell echo $(CLIB_VERSION) | cut -f2 -d.)
CLIB_VERSION_MICRO=$(shell echo $(CLIB_VERSION) | cut -f3 -d.)
diff --git a/src/python/setup.py b/src/python/setup.py
index c3d4356..f51ca67 100644
--- a/src/python/setup.py
+++ b/src/python/setup.py
@@ -4,7 +4,7 @@ import setuptools
setuptools.setup(
name="nispor",
- version="1.2.11",
+ version="1.2.12",
author="Gris Ge",
author_email="fge@redhat.com",
description="Python binding of Nispor",
--
2.41.0

View File

@ -9,6 +9,7 @@ License: ASL 2.0
URL: https://github.com/nispor/nispor URL: https://github.com/nispor/nispor
Source: https://github.com/nispor/nispor/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz Source: https://github.com/nispor/nispor/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
Source1: https://github.com/nispor/nispor/releases/download/v%{version}/nispor-vendor-%{version}.tar.xz Source1: https://github.com/nispor/nispor/releases/download/v%{version}/nispor-vendor-%{version}.tar.xz
Patch1: 0001-Makefile-Fix-version-1.2.12.patch
BuildRequires: make BuildRequires: make
BuildRequires: pkg-config BuildRequires: pkg-config
BuildRequires: python3-devel BuildRequires: python3-devel