import nispor-1.0.1-3.el8
This commit is contained in:
commit
71a22f872f
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/nispor-1.0.1-vendor.tar.xz
|
||||||
|
SOURCES/nispor-1.0.1.tar.gz
|
2
.nispor.metadata
Normal file
2
.nispor.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
2af16151bd7a523bb228c3e0bb3462bf71b4a740 SOURCES/nispor-1.0.1-vendor.tar.xz
|
||||||
|
4a9585f8dd2ca52248dd8a26881b21e0cd104493 SOURCES/nispor-1.0.1.tar.gz
|
@ -0,0 +1,47 @@
|
|||||||
|
From 32e5d0a2e217322e144fe1ffe916e217133c2b74 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fernando Fernandez Mancera <ffmancera@riseup.net>
|
||||||
|
Date: Mon, 25 Jan 2021 13:59:40 +0100
|
||||||
|
Subject: [PATCH] bond: add support to vlan+srcmac tx hashing option
|
||||||
|
|
||||||
|
The new vlan+srcmac tx hashing option is now available at kernel
|
||||||
|
upstream. Nispor should support it.
|
||||||
|
|
||||||
|
Ref: https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net-next.git/commit/?id=7b8fc0103bb51d1d3e1fb5fd67958612e709f883
|
||||||
|
|
||||||
|
Signed-off-by: Fernando Fernandez Mancera <ffmancera@riseup.net>
|
||||||
|
---
|
||||||
|
src/lib/ifaces/bond.rs | 4 ++++
|
||||||
|
1 file changed, 4 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/lib/ifaces/bond.rs b/src/lib/ifaces/bond.rs
|
||||||
|
index d3a3b6c..63fafeb 100644
|
||||||
|
--- a/src/lib/ifaces/bond.rs
|
||||||
|
+++ b/src/lib/ifaces/bond.rs
|
||||||
|
@@ -171,6 +171,7 @@ const BOND_XMIT_POLICY_LAYER34: u8 = 1;
|
||||||
|
const BOND_XMIT_POLICY_LAYER23: u8 = 2;
|
||||||
|
const BOND_XMIT_POLICY_ENCAP23: u8 = 3;
|
||||||
|
const BOND_XMIT_POLICY_ENCAP34: u8 = 4;
|
||||||
|
+const BOND_XMIT_POLICY_VLAN_SRCMAC: u8 = 5;
|
||||||
|
|
||||||
|
#[derive(Serialize, Deserialize, Debug, PartialEq, Clone)]
|
||||||
|
#[serde(rename_all = "lowercase")]
|
||||||
|
@@ -185,6 +186,8 @@ pub enum BondXmitHashPolicy {
|
||||||
|
Encap23,
|
||||||
|
#[serde(rename = "encap3+4")]
|
||||||
|
Encap34,
|
||||||
|
+ #[serde(rename = "vlan+srcmac")]
|
||||||
|
+ VlanSrcMac,
|
||||||
|
Other(u8),
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -196,6 +199,7 @@ impl From<u8> for BondXmitHashPolicy {
|
||||||
|
BOND_XMIT_POLICY_LAYER23 => Self::Layer23,
|
||||||
|
BOND_XMIT_POLICY_ENCAP23 => Self::Encap23,
|
||||||
|
BOND_XMIT_POLICY_ENCAP34 => Self::Encap34,
|
||||||
|
+ BOND_XMIT_POLICY_VLAN_SRCMAC => Self::VlanSrcMac,
|
||||||
|
_ => Self::Other(d),
|
||||||
|
}
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
151
SPECS/nispor.spec
Normal file
151
SPECS/nispor.spec
Normal file
@ -0,0 +1,151 @@
|
|||||||
|
Name: nispor
|
||||||
|
Version: 1.0.1
|
||||||
|
Release: 3%{?dist}
|
||||||
|
Summary: API for network status querying
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://github.com/nispor/nispor
|
||||||
|
Source: https://github.com/nispor/nispor/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
|
Source1: %{name}-%{version}-vendor.tar.xz
|
||||||
|
Patch0: BZ_1919986-bond-add-support-to-vlan-srcmac-tx-hashing-option.patch
|
||||||
|
BuildRequires: pkg-config
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: rust-toolset
|
||||||
|
BuildRequires: systemd-rpm-macros
|
||||||
|
BuildRequires: systemd-devel
|
||||||
|
|
||||||
|
%description
|
||||||
|
Unified interface for Linux network state querying.
|
||||||
|
|
||||||
|
%package -n python3-%{name}
|
||||||
|
Summary: %{summary}
|
||||||
|
Requires: nispor = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n python3-%{name}
|
||||||
|
|
||||||
|
This package contains python3 binding of %{name}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
Requires: nispor%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
|
||||||
|
This package contains C binding of %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1
|
||||||
|
|
||||||
|
# Source1 is vendored dependencies
|
||||||
|
%cargo_prep -V 1
|
||||||
|
|
||||||
|
# The cargo_prep will create `.cargo/config` which take precedence over
|
||||||
|
# `.cargo/config.toml` shipped by upstream which fix the SONAME of cdylib.
|
||||||
|
# To workaround that, merge upstream rustflags into cargo_prep created one.
|
||||||
|
_FLAGS=`sed -ne 's/rustflags = "\(.\+\)"/\1/p' .cargo/config.toml`
|
||||||
|
sed -i -e "s/rustflags = \[\(.\+\), \]$/rustflags = [\1, \"$_FLAGS\"]/" \
|
||||||
|
.cargo/config
|
||||||
|
|
||||||
|
%build
|
||||||
|
make
|
||||||
|
pushd src/python
|
||||||
|
%py3_build
|
||||||
|
popd
|
||||||
|
|
||||||
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
|
%systemd_post nispor.service
|
||||||
|
|
||||||
|
%preun
|
||||||
|
%systemd_preun nispor.service
|
||||||
|
|
||||||
|
%postun
|
||||||
|
/sbin/ldconfig
|
||||||
|
%systemd_postun_with_restart nispor.service
|
||||||
|
|
||||||
|
%install
|
||||||
|
env SKIP_PYTHON_INSTALL=1 PREFIX=%{_prefix} LIBDIR=%{_libdir} %make_install
|
||||||
|
|
||||||
|
pushd src/python
|
||||||
|
%py3_install
|
||||||
|
popd
|
||||||
|
|
||||||
|
%files
|
||||||
|
%doc AUTHORS CHANGELOG DEVEL.md README.md
|
||||||
|
%license LICENSE
|
||||||
|
%{_bindir}/npc
|
||||||
|
%{_bindir}/npd
|
||||||
|
%{_libdir}/libnispor.so.*
|
||||||
|
%{_unitdir}/nispor.socket
|
||||||
|
%{_unitdir}/nispor.service
|
||||||
|
|
||||||
|
%files -n python3-%{name}
|
||||||
|
%license LICENSE
|
||||||
|
%{python3_sitelib}/nispor*
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%{_libdir}/libnispor.so
|
||||||
|
%{_includedir}/nispor.h
|
||||||
|
%{_libdir}/pkgconfig/nispor.pc
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Feb 02 2021 Fernando Fernandez Mancera <ferferna@redhat.com> - 1.0.1-3
|
||||||
|
- Add support to bond vlan+srcmac tx hashing option. RHBZ#1919986
|
||||||
|
|
||||||
|
* Fri Nov 13 2020 Gris Ge <fge@redhat.com> - 1.0.1-2
|
||||||
|
- Upload new cargo vendor tarbal without crates used for windows platform.
|
||||||
|
|
||||||
|
* Tue Nov 10 2020 Fernando Fernandez Mancera <ferferna@redhat.com> - 1.0.1-1
|
||||||
|
- Upgrade to 1.0.1
|
||||||
|
|
||||||
|
* Mon Nov 09 2020 Gris Ge <fge@redhat.com> - 1.0.0-1
|
||||||
|
- Upgrade to 1.0.0
|
||||||
|
|
||||||
|
* Mon Oct 19 2020 Gris Ge <fge@redhat.com> - 0.6.1-2
|
||||||
|
- Rebuild to load the compose settings.
|
||||||
|
|
||||||
|
* Tue Oct 13 2020 Gris Ge <fge@redhat.com> - 0.6.1-1
|
||||||
|
- Upgrade to 0.6.1
|
||||||
|
|
||||||
|
* Fri Oct 09 2020 Fernando Fernandez Mancera <ferferna@redhat.com> - 0.6.0-2
|
||||||
|
- VXLAN Python fix incorrect destination port
|
||||||
|
|
||||||
|
* Fri Oct 09 2020 Fernando Fernandez Mancera <ferferna@redhat.com> - 0.6.0-1
|
||||||
|
- Upgrade to 0.6.0
|
||||||
|
|
||||||
|
* Sun Sep 20 2020 Gris Ge <fge@redhat.com> - 0.5.1-1
|
||||||
|
- Upgrade to 0.5.1
|
||||||
|
|
||||||
|
* Thu Sep 17 2020 Gris Ge <fge@redhat.com> - 0.5.0-3
|
||||||
|
- Trigger rebuild for CI gating
|
||||||
|
|
||||||
|
* Tue Sep 08 2020 Gris Ge <fge@redhat.com> - 0.5.0-2
|
||||||
|
- Fix the python3-nispor requirement
|
||||||
|
|
||||||
|
* Fri Sep 04 2020 Gris Ge <fge@redhat.com> - 0.5.0-1
|
||||||
|
- Upgrade to 0.5.0
|
||||||
|
|
||||||
|
* Sat Aug 29 2020 Gris Ge <fge@redhat.com> - 0.4.0-3
|
||||||
|
- Fix the ldconfig
|
||||||
|
|
||||||
|
* Wed Aug 26 2020 Gris Ge <fge@redhat.com> - 0.4.0-2
|
||||||
|
- Add ldconfig to post and postun scripts
|
||||||
|
|
||||||
|
* Wed Aug 26 2020 Gris Ge <fge@redhat.com> - 0.4.0-1
|
||||||
|
- Upgrade to 0.4.0
|
||||||
|
|
||||||
|
* Mon Aug 17 2020 Gris Ge <fge@redhat.com> - 0.3.0-2
|
||||||
|
- Fix python linux bridge vlan filtering
|
||||||
|
|
||||||
|
* Sun Aug 16 2020 Gris Ge <fge@redhat.com> - 0.3.0-1
|
||||||
|
- Upgrade to 0.3.0
|
||||||
|
|
||||||
|
* Tue Aug 11 2020 Gris Ge <fge@redhat.com> - 0.2.0-1
|
||||||
|
- Upgrade to 0.2.0
|
||||||
|
|
||||||
|
* Thu Jul 09 2020 Gris Ge <fge@redhat.com> - 0.1.1-2
|
||||||
|
- Include license and documents
|
||||||
|
|
||||||
|
* Wed Jul 08 2020 Gris Ge <fge@redhat.com> - 0.1.1-1
|
||||||
|
- Initial build.
|
Loading…
Reference in New Issue
Block a user