update to the latest upstream release (1.58.0)
This commit is contained in:
parent
2cdd4d5bd4
commit
df5827b2d5
@ -1,34 +0,0 @@
|
||||
From bf8f419ca9f2d8bce48591710aa25f08e3fc67f8 Mon Sep 17 00:00:00 2001
|
||||
From: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
|
||||
Date: Wed, 11 Oct 2023 17:19:05 +0900
|
||||
Subject: [PATCH] Fix build error when both clock_gettime and GetTickCount64
|
||||
are available
|
||||
|
||||
---
|
||||
lib/nghttp2_time.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/nghttp2_time.c b/lib/nghttp2_time.c
|
||||
index 2a5f1a6ff5..dd5a65591f 100644
|
||||
--- a/lib/nghttp2_time.c
|
||||
+++ b/lib/nghttp2_time.c
|
||||
@@ -44,7 +44,9 @@ static uint64_t time_now_sec(void) {
|
||||
}
|
||||
#endif /* HAVE_GETTICKCOUNT64 */
|
||||
|
||||
-#ifdef HAVE_CLOCK_GETTIME
|
||||
+#ifdef HAVE_GETTICKCOUNT64
|
||||
+uint64_t nghttp2_time_now_sec(void) { return GetTickCount64() / 1000; }
|
||||
+#elif defined(HAVE_CLOCK_GETTIME)
|
||||
uint64_t nghttp2_time_now_sec(void) {
|
||||
struct timespec tp;
|
||||
int rv = clock_gettime(CLOCK_MONOTONIC, &tp);
|
||||
@@ -55,8 +57,6 @@ uint64_t nghttp2_time_now_sec(void) {
|
||||
|
||||
return (uint64_t)tp.tv_sec;
|
||||
}
|
||||
-#elif defined(HAVE_GETTICKCOUNT64)
|
||||
-uint64_t nghttp2_time_now_sec(void) { return GetTickCount64() / 1000; }
|
||||
#else /* !HAVE_CLOCK_GETTIME && !HAVE_GETTICKCOUNT64 */
|
||||
uint64_t nghttp2_time_now_sec(void) { return time_now_sec(); }
|
||||
#endif /* !HAVE_CLOCK_GETTIME && !HAVE_GETTICKCOUNT64 */
|
10
nghttp2.spec
10
nghttp2.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: Experimental HTTP/2 client, server and proxy
|
||||
Name: nghttp2
|
||||
Version: 1.57.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.58.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
# Parts of ruby bindings are additionally under GPL-2.0-or-later, MIT and
|
||||
# Kevlin Henney (this one is not recognized by Fedora!) but they are NOT shipped.
|
||||
@ -18,9 +18,6 @@ Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/ng
|
||||
Source1: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz.asc
|
||||
Source2: tatsuhiro-t.pgp
|
||||
|
||||
# Upstream patches
|
||||
Patch1: 0001-nghttp2-1.57.0-clock-gettime.patch
|
||||
|
||||
BuildRequires: CUnit-devel
|
||||
BuildRequires: c-ares-devel
|
||||
BuildRequires: gcc-c++
|
||||
@ -218,6 +215,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 30 2023 Jan Macku <jamacku@redhat.com> 1.58.0-1
|
||||
- update to the latest upstream release
|
||||
|
||||
* Wed Oct 11 2023 Jan Macku <jamacku@redhat.com> 1.57.0-2
|
||||
- fix mingw build
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (nghttp2-1.57.0.tar.xz) = d914eb48afd1ea182c1b2a454bf5e7963a7e28165f1d6d29bb83dd61a1b611c8c469e72a7a22daf23b8037f6e5ae9d4e791150b7d135746c1a5ec71ceb777f92
|
||||
SHA512 (nghttp2-1.57.0.tar.xz.asc) = fa3eaa0af783efa76931a037516e6ddc05d82e45a378fe7f136366ea4bbf94138dfdbc40e337abe8f16a329df3f388fe9b81f148635d936d28bc70fc3f687745
|
||||
SHA512 (nghttp2-1.58.0.tar.xz) = 97b70727c633be1168df6a5b48617dde113b1d1e34176ec8bf22f4449041af2f73b2ada438d14336c9712271ec6bfc7525f000c8ca6a7a9f8d06db01b876dd1c
|
||||
SHA512 (nghttp2-1.58.0.tar.xz.asc) = 4f6b710d6169769d96e65b601c6c585ddf1fe98490aef7531e30ba0ef3f2c212b8b5c88854f3e912544b3a9f19e4b65c6933f41514c328f4434deddcc71aa620
|
||||
|
Loading…
Reference in New Issue
Block a user