update to the latest upstream release (1.4.0)
This commit is contained in:
parent
a122dfe534
commit
8efb526590
75
0001-configure-do-not-enable-hidden-visibility.patch
Normal file
75
0001-configure-do-not-enable-hidden-visibility.patch
Normal file
@ -0,0 +1,75 @@
|
|||||||
|
From 66f1d9c8232d6c5ae4919c5d59db013de9aee92c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
|
Date: Mon, 26 Oct 2015 16:41:17 +0100
|
||||||
|
Subject: [PATCH] configure: do not enable hidden visibility
|
||||||
|
|
||||||
|
... until the upstream test-suite is ready for that
|
||||||
|
|
||||||
|
Bug: https://github.com/tatsuhiro-t/nghttp2/issues/410
|
||||||
|
---
|
||||||
|
configure | 35 -----------------------------------
|
||||||
|
configure.ac | 2 +-
|
||||||
|
2 files changed, 1 insertion(+), 36 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index 07fefc6..724c0d0 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -22983,41 +22983,6 @@ CFLAGS=$ac_save_CFLAGS
|
||||||
|
|
||||||
|
|
||||||
|
EXTRACFLAG=
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -fvisibility=hidden" >&5
|
||||||
|
-$as_echo_n "checking whether C compiler accepts -fvisibility=hidden... " >&6; }
|
||||||
|
-if ${ax_cv_check_cflags___fvisibility_hidden+:} false; then :
|
||||||
|
- $as_echo_n "(cached) " >&6
|
||||||
|
-else
|
||||||
|
-
|
||||||
|
- ax_check_save_flags=$CFLAGS
|
||||||
|
- CFLAGS="$CFLAGS -fvisibility=hidden"
|
||||||
|
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||||
|
-/* end confdefs.h. */
|
||||||
|
-
|
||||||
|
-int
|
||||||
|
-main ()
|
||||||
|
-{
|
||||||
|
-
|
||||||
|
- ;
|
||||||
|
- return 0;
|
||||||
|
-}
|
||||||
|
-_ACEOF
|
||||||
|
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
- ax_cv_check_cflags___fvisibility_hidden=yes
|
||||||
|
-else
|
||||||
|
- ax_cv_check_cflags___fvisibility_hidden=no
|
||||||
|
-fi
|
||||||
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||||
|
- CFLAGS=$ax_check_save_flags
|
||||||
|
-fi
|
||||||
|
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___fvisibility_hidden" >&5
|
||||||
|
-$as_echo "$ax_cv_check_cflags___fvisibility_hidden" >&6; }
|
||||||
|
-if test x"$ax_cv_check_cflags___fvisibility_hidden" = xyes; then :
|
||||||
|
- EXTRACFLAG="-fvisibility=hidden"
|
||||||
|
-else
|
||||||
|
- :
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 59fa5b0..a906b43 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -678,7 +678,7 @@ CFLAGS=$ac_save_CFLAGS
|
||||||
|
AC_SUBST([WARNCFLAGS])
|
||||||
|
|
||||||
|
EXTRACFLAG=
|
||||||
|
-AX_CHECK_COMPILE_FLAG([-fvisibility=hidden], [EXTRACFLAG="-fvisibility=hidden"])
|
||||||
|
+dnl AX_CHECK_COMPILE_FLAG([-fvisibility=hidden], [EXTRACFLAG="-fvisibility=hidden"])
|
||||||
|
|
||||||
|
AC_SUBST([EXTRACFLAG])
|
||||||
|
|
||||||
|
--
|
||||||
|
2.5.2
|
||||||
|
|
12
nghttp2.spec
12
nghttp2.spec
@ -1,12 +1,14 @@
|
|||||||
Summary: Experimental HTTP/2 client, server and proxy
|
Summary: Experimental HTTP/2 client, server and proxy
|
||||||
Name: nghttp2
|
Name: nghttp2
|
||||||
Version: 1.3.4
|
Version: 1.4.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
URL: https://nghttp2.org/
|
URL: https://nghttp2.org/
|
||||||
Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
|
Source0: https://github.com/tatsuhiro-t/nghttp2/releases/download/v%{version}/nghttp2-%{version}.tar.xz
|
||||||
|
|
||||||
|
Patch1: 0001-configure-do-not-enable-hidden-visibility.patch
|
||||||
|
|
||||||
BuildRequires: CUnit-devel
|
BuildRequires: CUnit-devel
|
||||||
BuildRequires: libev-devel
|
BuildRequires: libev-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
@ -41,6 +43,11 @@ for building applications with libnghttp2.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
# Do not enable hidden visibility until the upstream test-suite is ready for
|
||||||
|
# that. See https://github.com/tatsuhiro-t/nghttp2/issues/410 for details.
|
||||||
|
%patch1 -p1
|
||||||
|
touch aclocal.m4 configure {config.h,Makefile}.in
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -101,6 +108,9 @@ make %{?_smp_mflags} check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 26 2015 Kamil Dudka <kdudka@redhat.com> 1.4.0-1
|
||||||
|
- update to the latest upstream release
|
||||||
|
|
||||||
* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
|
* Thu Sep 24 2015 Kamil Dudka <kdudka@redhat.com> 1.3.4-1
|
||||||
- update to the latest upstream release
|
- update to the latest upstream release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user